4 Replies Latest reply: Jun 18, 2012 4:28 AM by OGELTHORPE
tago Level 1 (115 points)
After having unplugged my MBP in can no longer select the internal speakers. I can hear the chime at start up, but that's all. Headphones work fine and a red light is on the audio port. I have tried plugging/unplugging the headphones several times but to no avail. I also deleted the audio preference files, reset PRAM and PMU but nothing helped. I have also tried to insert a toothpick, as read somewhere, inside the port but...nothing. What can I do ? On other threads looks like a sensor switch could be stuck but I can't see/find anything inside the audio port....

MacBook Pro 2.5 Ghz-ACD 20"-iPod 60 GB-TC 500GB, Mac OS X (10.6.5)
  • k.panic Level 3 (605 points)
    Yeah, this can often be a hardware problem, essentially the headphone jack also functions as an optical audio jack, and that's what the red light is. If you were to go into System Preferences > Sound > Output, you'll probably have optical out selected instead of internal speakers. The problem is that the jack thinks something is plugged in and this overrides the internal speakers.

    It's not that the internal speakers don't work or aren't detected, instead it's that the OS is trying to use that jack for output. That's why you hear the chime, but once the computer boots you can't hear anything.

    Sometimes you can clean the jack with compressed air, but a lot of the time it will reoccur and eventually require the logic board or left IO board (audio board) to be replaced, depending on the model of MacBook Pro you have.

    If you're under warranty and the jack isn't loose / doesn't have anything broken off in it (which sometimes happens), it should be covered, unless there's other accidental damage near the jack.

    If you aren't under warranty, I'd call AppleCare or go to your nearest Apple Store and they can set up a flat-rate mail-in repair for you, that's usually less than the part cost + labor for a logic board. Usually in the U.S., for a flat-rate MacBook Pro, you're looking at about $310 plus facilitation charges for phone support, if applicable. They'll let you know when you call. You can also have an Apple Authorized Service Provider facilitate this if there's one near you, their prices may be slightly different.

    I don't know what the toothpick was supposed to do, maybe if there's something stuck in the jack. Either way, in my experience this is almost always a hardware problem.

    Sorry, I know that probably isn't the news you want. :-\
  • greendinjin Level 1 (0 points)
    Have you seen this thread?


    For me it was enough to follow those instructions (insert and remove headphone plug a few times, while wiggling a little bit)
  • Destie Level 1 (10 points)

    Go into System prefrences>Sound>and you should be on the sound effects tab, there should be a drop down menu from the "Play sound effects through:" drop down the menu, there you should see Internal Speakers. Then it works fine. At least that worked for me, just fiddling around with it solved my own problem! I hope it works for you as well! Good Luck!

  • OGELTHORPE Level 8 (42,760 points)

    greendinjin has pointed you to the correct solution.  The red light you see indicates that the internal switch has to be tripped in order for the speakers to be turned on.  If you cannot trip it then take it to an Apple store and have them do it for you.  More often than not, wiggling a thin implement inside the port will succeed.