1 2 Previous Next 19 Replies Latest reply: Dec 30, 2010 3:07 PM by FrannieM
Kf Bayley Level 1 Level 1 (0 points)
Hi...grateful for any experts' help out there .. So I got a new 16Gb iPad for Xmas, lucky man I know.... Im a pro TV/film composer with 2 macbooks, 3 ipods, an iphone 4 and a studio g5 so Im cool with Apple stuff and know my way around them... BUT - I cant wi fi connect to the internet via our home router, a Belkin N10117 Wireless G Router. In terms of info I should say that:

- the iPad can see the router and connects to it but loading Safari says 'no internet connection'
- we have 2 ipod touches, an iphone 4 and 2 macbooks successfully connected to the net via wi fi using the Belkin
- when I try joining the network the IP address and the Subnet Mask are filled in, but the Router DNS Search Domains etc all blank which I take to be bad..
- I have tried the following: brightness fix/multiple restart of router, ipad etc/reset network settings of iPad, forget network etc, then went to Belkin control panel and added Mac Address filtering, adding in Wi Fi address of iPad , still no joy - all other items worked fine after this.

Should add also that my bro in law also got a new iPad on the same day - his also did not work with the Belkin but worked fine when he got home on his network. So it seems it is a setting issue within the iPad/belkin rather than a specific hardware issue or router issue.

Ill be so very grateful for any info - have been on the forum/support sites searching all afternoon and now Im asking for help. One poster quoted success with the Mac address filtering route but no luck for me... if anyone can tell me the Belkin router will categorically will not work with the iPad then so be it but that would seem very poor given that all other hardware works perfectly (theres no info on Belkin site).

To quote Sting and his hundred million bottles washed up on the shore, it seems "Im not alone in being alone" with this problem.... theres a LOT of iPad Wi Fi issues. I love Mac with a passion and use all their gear on TV and film scores but am currently VERY unhappy. Anyones help on helping transform this from a pretty beermat into something useful? Otherwise its a refund and a new guitar....Thanks so much guys.... KB

macbook pro 13, Mac OS X (10.6.4), pro composer, Logic Pro etc
  • 1. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Ralph Landry1 Level 7 Level 7 (32,370 points)
    Hi KB,

    Yes, there have been a number of users with WiFi issues. And not completely clear why some have problems and others do not.

    Have you gone to Settings > Safari and turned AutoFill OFF? That is often the culprit with Safari not connecting.

    Since you are connecting to the internet, are you getting email to work? Or is that failing also?

    I am not familiar with the Belkin router, though they do make good products. How old is the router and have you updated the firmware recently? If not, that is often a good starting point. Many older routers, especially those before Sept 2009, do not have an implementation of the IEEE 802.11 n-protocol that is completely compliant with the standard...adopted in Sept 2009. The iPad implementation is very precise so it tends to reject those that are not as well matched as it wants to see.

    Hope this gives you a couple things to try.
    Ralph
  • 2. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Kf Bayley Level 1 Level 1 (0 points)
    Hi Ralph... thanks for responding on this tricky issue, really appreciated.

    Yes - Ive tried Autofill off, that was mentioned on an earlier search, no joy. The router is probably 3y or so old, and has worked perfectly. According to the Belkin Control Panel (which I currently have open) the firmware is the latest version - but have to say I dont know how to check:

    .... before Sept 2009, do not have an implementation of the IEEE 802.11 n-protocol that is completely compliant with the standard..


    would there be anywhere in the control panel settings that gave us that info? Im sure you're on the right track about the iPad being picky.. Im just not knowledgable enough to know what settings to change myself.. Im curious as to why the Router/DNS/Search Domains boxes were empty whereas on all other mac items theyre automatically filled in....? As you say Belkin are great; Ill buy a new router if I have to but dont know whether that would solve the problem?

    so grateful for any help...cheers

    KB
  • 3. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Kf Bayley Level 1 Level 1 (0 points)
    ps meant to add - not connecting at all to 'net with iPad; all other mac devices in house (iphones/touches/laptops) connecting AOK, web and email...
  • 4. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Ralph Landry1 Level 7 Level 7 (32,370 points)
    Hi KB, had to take some time to update iTunes on a PC laptop...not a lot of joy in THAT operation...anyway, it is highly suspicious that your brother-in-law's new iPad would connect to his router but not yours. And that your iPad would not connect to your router. Have you tried yours on any other router? There have been a number of issues with Linksys routers mentioned on here.

    I have had no problems with a Netgear, Verizon FiOS, Road Runner in NYC, AT&T fiber, hotels, and on the Mars de Champs in Paris. Have not had the chance to try a Belkin router and see what it does, so I am doing some guessing on this one.

    If you are on the Belkin control panel, does it give you an option to check for firmware or driver updates? If it does, and you are logged in as the administrator, give it a try and see if it comes back with newer software.

    If it doesn't, can you try taking the connection information from one of your other devices and enter it in the iPad and see if it connects? I have not had to do that manually, but others on here have mentioned that working.

    Ralph
  • 5. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    pjl123 Level 5 Level 5 (6,135 points)
    I have been using a belkin wireless g router with no issues. Mine is model fsd7230. I have seen the comments about updatrd firmware and routers, and i have never touchrd mine at all ( i just looked, and it is 07 vintage). Can i suggest, you reset the router to factory settings, and try again from scratch.
  • 6. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Kf Bayley Level 1 Level 1 (0 points)
    hi ..thx for both comments. Have tried entering manual dns/domains etc .. still no joy; also tried all other tips across various forums - eg turn off 'ask to join' ..nothing. Router is a 802.11g but lots of people saying this should work fine... last resort I guess it to return this to factory settings but some trepidation with this given that all other mac gadgets in house are working perfectly... wife and teenage children wil be very unhappy if network falls apart, not to mention my laptop and g5...

    Ive been on this for nearly 6 hours - new ipad fast approaching being a shiny frisbee....

    kb
  • 7. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Ralph Landry1 Level 7 Level 7 (32,370 points)
    I know you probably are not thrilled about more expenses, KB, but another option is to get an AirPort (extreme or express) and attach it to the Belkin by hard wire. Then set that up to broadcast the WiFi you attach the iPad to for internet. Before doing that, take the iPad to an Apple Retail store if you can and make sure it connects since they will be on an AirPort.

    By the way, how did you activate? Via your Mac?

    Have you considered using the Mac's AirPort card as the connection to the router? That is also a possibility.
  • 8. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Kf Bayley Level 1 Level 1 (0 points)
    Hi..yes I set the iPad up with the Mac in iTunes. It has nothing on it yet with the lack of wi fi so Im tempted to restore it ...

    Ive been considering getting an airport but my wife's just shelled out for my ipad (very generously) and
    everything I've read suggests the Belkin is a perfectly good router which should work fine. So Im really reluctant to give them any more cash as I personally I believe it should work straight out of the box. Could I ask how Id do as you sugest ie 'Mac's AirPort card as the connection to the router' ?

    may check the connectivity is ok? But ultimately it needs to work straight with the router.. I dont belive its a hardware issue as my bro in laws was exactky the same... K
  • 9. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Ralph Landry1 Level 7 Level 7 (32,370 points)
    I agree the problem is not the iPad does not work right and that the preferred solution is direct access to the router. There is a thread right now about use of a Mac for inet acres..."iMac Internet Sharing" is the subject line on this iPad discussion section.
  • 10. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Lightsound Level 1 Level 1 (0 points)
    I had this problem as well with my Belkin router when my iPad was new. My laptop and iPhone were connecting just fine, but not the iPad. As it turned out, the problem was with the security setting on my Belkin router. In order for the iPad to connect, the router must be set to WPA type security, and not WEP. Once I changed this, then deleted/forgot network from iPad, rescanned and connected all was well. I don't know why the iPad is so much more restrictive than the other devices as far as the type of security used. But I hope this helps you too.
  • 11. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    ianhaynes Level 1 Level 1 (0 points)
    Hi I too am having this issue....BUT....mine worked fine on the home network untill I activated the Orange SIM. Since then I can use the ipad on sim network but the wireless, although showing full bars, simply wont cut in. When I turn the cellular network off it just shrugs and tells me to get lost, in that nice apple way.

    I have 2 other ipads on the netgear (brand new router) network, 4 ipods, i mac book and 4 i phones. My kids and missus are fine and sit there laughing at me. Its now getting personal!

    Ian
  • 12. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Ralph Landry1 Level 7 Level 7 (32,370 points)
    Hi Ian and welcome to the Apple Discussions.

    Since the other iPads are connecting to the wireless without issues, you might try resetting the one that has problems. Order of things to try:

    1. Power off, power on.
    2. Hard reset; hold both sleep/power button and home button until Apple logo appears.
    3. Factory restore by connecting to iTunes and restoring, then reinstall apps, etc that were not originally on the iPad.

    If none of those steps work, it could be a faulty iPad and try taking it to an Apple Retail store and have them check it out for you.

    Ralph
  • 13. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Kf Bayley Level 1 Level 1 (0 points)
    Hi everyone just wanted to say my iPad is finally wi fi net connected and has been transformed from "a shiny frisbee" to " a thing of wonder." Very grateful for everyones input. Having been at my wits end at 2 am this morning, and having tried literally ALL the suggested fixes and after 3+ hours on to an extremely helpful Mac support team, I can confirm this worked:

    - 'forget network' on iPad, power off
    - HARD reset (not just power off or factory reset, but the button on back) of Belkin router
    - this then wipes your ISP/BT Broadband user info so you must then re-enter user and password (before rest of the family revolts..)
    - WPA security enabled on router (thanks Lightsound)
    - this then generated the magically filled in the Belkin network data on the iPad, until then sadly lacking (IP, router, dns etc)

    ...deep breath and then Frankenstein-style, it lived. Router Hard Reset was the key apparently ....Wi Fi connectivity still remains the darkest of dark arts though, and this is confirmed by those more knowledgeable than me...

    Anyway the forum is a warm and wonderful place, big thanks to all and Im also full of praise for the Mac support guys - got straight though, patient and thorough help.

    Happy New Year Everyone... KB
  • 14. Re: New iPad Wi-Fi ;  wont connect to Belkin Router
    Ralph Landry1 Level 7 Level 7 (32,370 points)
    KB, thanks for getting back with your resolution...all of us on the discussions are fellow users and not Apple employees. So the feedback helps us learn more also. Stick around and take part in the discussions. You've learned a lot this week and can no doubt help others.

    Have a Happy New Year.

    Ralph
1 2 Previous Next