Previous 1 2 Next 26 Replies Latest reply: May 7, 2015 10:43 PM by Ross Frank
EntoK Level 1 (0 points)
Recently, for the last month or two, my mac won't let me look at certain websites. (i.e apple.com, hulu.com, some yahoo.com sites.) Cannot find a solution on any forums yet that work for me. The internet works fine on the other computers in the house and I can access those sites with no problems. I have snow leopard on my Macmini, and I tried reinstalling it and the websites worked ONE time, then if I closed the browser the sites would come up with the error, cannot connect to the internet. Or in the case of the Hulu site, show text only with no formatting. I also tried reinstalling Java, and it did the same thing, would let me see the website once and then not again. Not sure what else I can try. Does anyone have any suggestions? Is there some update i have not installed yet that does not come up in my updates? Thanks for all help.

First Gen. MacMini, Mac OS X (10.6.5)
  • sig Level 8 (35,785 points)
    What browser are you using? Have you tried using OpenDNS servers? Reinstalling an entire OS for your issue is overkill and not necessary because it is not an OS issue.
  • k.panic Level 3 (605 points)
    Try a different user on the Mini, or a test user, to see if the problem only happens within your account. If it happens in both accounts, you've probably got something in the root Library causing trouble.
  • imcleod Level 1 (0 points)
    I have this problem as well. K.panic, what would the troubleshooting steps be to find the root Library problem?
  • JcDenaes Level 1 (0 points)
    Same for me, started with Facebook on all browsers (FF, Chrome, Safari)a month or two from now, and today twitter and this very support.apple.com + some software like ClamXav cannot connect anymore to update their database, etc.
    In VirtualBox with Ubuntu and VMWare Fusion Win XP : both with FF, same problem, same websites / IP

    _It is neither the router nor the DNS_ since my wife's computer works fine on the same network with all those websites and apps (PowerPC 10.5.8)
    _It is not the firewall either_ on or off, it does not change a thing.

    So far, I managed to make it all work (even apps like ClamXav) by using Vidalia TOR + Tor add-on on FF || Tor Browser (Safari under Namaroka) works great too.
    Tor makes browsing a little bit slower and anonymity can have its drawbacks, so it is not a long-term solution.

    So for those in need of a quick access to their websites :
    www.torproject.org > Download > Tor Browser Bundle for OS X Intel

    Now, why is that it works with Tor and not without ?
    What to do to solve the situation ?

    TIA for any help !
    --
    Jc.
  • beantown696969 Level 1 (0 points)
    I am having the same exact problem. I can ping twitter.com and apple.com but I cannot load them in ANY browser.

    Not a firewall issue
  • JcDenaes Level 1 (0 points)
    @k.panic : all user accounts on the same computer are affected. Then what kind of root Lib problem shall it be ? How to locate it ?

    @beantown696969 : I confirm : Ping works, not browsing
  • beantown696969 Level 1 (0 points)
    i got twitter to work in safari by making an exception in the proxy for twitter.com

    i'm going to bring it to the apple store today
  • beantown696969 Level 1 (0 points)
    @k.panic it is not specific to the user, it is happening on all user accounts
  • abstruse1980 Level 1 (0 points)
    I have the exact same problem with twitter.com can't connect to it no matter what I do using my MBP. Browser choice and DNS server make no difference. I can get straight on via my iPhone (which is connected to exactly the same network)

    Checked my hosts list and proxy settings, can't see anything amiss. Anyone have more info on this issue?
  • beantown696969 Level 1 (0 points)
    Do you guys have PeerGuardian? Deleted that and it fixed the problem.
  • mctconsortium Level 1 (0 points)
    I am having the exact same issues with Apple.com and Twitter.com. Changing DNS to Google's or OpenDNS fixes issues with Apple.com (although I'm still not sure why the problem started in the first place with my ISP's DNS), but I still cannot access Twitter from ANY browser. Changing DNS does not fix the problem. The guy at the Apple store told me to reinstall my OS, which I did and that did not help. This is very annoying.
  • JcDenaes Level 1 (0 points)
    @beantown : I agree, PeerGuardian is at the root of the problem. If its lists are disable everything return to normal.

    Quesiton is : how is that PeerGuardian interfere if the application is not even launched, not even as a process ?
  • Arhsmacdude Level 1 (20 points)
    did you try chrome? if you can't access it with chrome, then its being blocked by your ISP
  • mctconsortium Level 1 (0 points)
    Chrome is my default browser.
Previous 1 2 Next