6 Replies Latest reply: Jan 27, 2011 11:14 AM by TennisManu
kieran123nz Level 1 Level 1 (0 points)
Hi there,

I have a Macbook Pro A1226 that fails to power on without a battery installed.

i.e. will not run off AC power on its own. I have tried 2 other power adapters, no change. All 3 adapters are outputting the correct voltage without fluctuations.

But, if I am in OSX with a battery plugged in, shutdown the laptop, remove the battery while AC is still plugged in, it will power back on without any issues. But as soon as I remove the battery, it will not power back on using just AC.

Is this an I/O board issue, or a mainboard?

I have power drained the unit and reset the parameter ram.

Thanks

a1226, Mac OS X (10.5)
  • k.panic Level 3 Level 3 (605 points)
    Unfortunately there's probably no way to know without doing hardware component isolation, such as testing the unit with a known-good left IO board or main logic board. It could also be the power cable that runs between the two though I've only seen that once or twice.

    I assume by "I've power drained the unit" you mean you've reset the SMC? It sounds like an SMC issue to me, which points toward logic board. Especially b/c if you remove the battery while AC's plugged in it works.

    You're using 85W power adapters, yes?
  • kieran123nz Level 1 Level 1 (0 points)
    Isn't resetting the SMC just power draining anyway? It may be different, but I just removed the battery and AC and held down the power button for around 10 seconds

    I have around 7 of these at the moment with this issue.

    I have installed a new mainboard in one, which didn't fix it, and then tried the I/O board in another, again no change.

    I may look into the cable. I sent one of them to the Apple repair guys and they sent it back saying the power adapter and battery were causing it, so i ordered those even though the one I had were perfectly fine, and it didn't change anything.

    Extremely frustrating units
  • k.panic Level 3 Level 3 (605 points)
    I just didn't know what you meant by power draining. Some would mean this as 'I drained the battery down to 0%', which isn't the same from removing the AC adapter and battery and holding the power button down for 5 seconds, which is the actual SMC reset procedure.

    This can also be a grounding issue, but a bad battery can also corrupt the SMC and cause this problem. Maybe if the batteries you're testing with are over 300 cycles, Apple determined that they were not known-good batteries. They're not just saying this arbitrarily, they have a battery diagnostic utility that they run.
  • kieran123nz Level 1 Level 1 (0 points)
    Well even a new battery hasn't fixed the issue....I may end up just junking them.

    Thanks for the help!
  • TennisManu Level 1 Level 1 (0 points)
    Any update on this? This is the same thing that's going on with my laptop right now. I was at the Genius Bar and they said they can send it in for repair. Takes 7-9 days and costs a minimum of $310. At the time I was there, my computer wouldn't start up at all, because the battery had drained to less than 20%. It didn't even start with just the power cord (no battery in). The "genius" finally got it to work by doing a PRAM and SMC reset. Got home and was able to recharge my battery to 100%. Used my computer for 2 days before I dared to take it off the power supply. Lo and behold, as soon as I take it off the power cord, then re-connect it, it shows "Not Charging". I tried to do SMC again, but no luck. Keeps saying "not charging". Even tried with a brand new battery. Do I have to get the I/O board thingy replaced?
  • TennisManu Level 1 Level 1 (0 points)
    Oh, I should add that even though it says "not charging", when I briefly take it off power supply, it still has the same percentage of battery power than an hour or so ago. So it does not seem to lose any power, but it says "not charging". Odd?