Previous 1 2 3 Next 36 Replies Latest reply: Jul 30, 2012 2:29 PM by 9207Phoe
Tor Lundgren Level 2 Level 2 (235 points)
What's all this about:

+The server responded with an error.+

+The request for account “[myaccount]@me.com” failed.+

+The server responded with+
+“HTTP/1.1 502 Bad Gateway”+
+to operation CalDAVAccountRefreshQueueableOperation.+

MacBook Pro, MacBook Air, Mac mini, iPhone 4, Mac OS X (10.6.5)
  • Ferd II Level 7 Level 7 (24,200 points)
    Tor,

    I ignored it, took two aspirin and it went away. Seriously, it did disappear, but not because of the aspirin.

    What happens if you go to iCal>Preferences...>Accounts, then either delete the MobileMe CalDav account listed and create a new account, or re-enter the correct password?

  • Jeroen Vink Level 1 Level 1 (10 points)
    I have this message at both my imacs and one macbook pro every day several times.
  • zootopia Level 1 Level 1 (15 points)
    Hi Ferd...

    I tried the elimination of the CalDAV account listed and created a new one and the same thing happened...; however, I only had to click the Revert to Server button once this time... FWIW. Odd bug tho. At the bottom of my Account settings, it says, " The server where this account is located doesn't allow you to see availability..." Isn't it my account? Oh well... I don't use iCal that much but for those who do, I bet it's a real hassle.

    Cheers!
  • Dave Marsh Level 2 Level 2 (325 points)
    I'm also getting this error message multiple times a day. I click on Go Online and MobileMe syncs properly until the next time it pops up. I tried deleting my account in iCal and recreating it, but that didn't help. I participated in the CalDAV beta a few months ago, so I don't know if MobileMe is confused when it authenticates to sync to the new production server, but this error message is definitely becoming annoying.

    I have three Macs, and all are experiencing this error message repeatedly daily. At this point, it seems to be happening hourly when it checks with MobileMe to see if anything has changed, even through Push is activated. At this point, I have no idea how to fix this. My MobileMe credentials are correct, but the server is apparently rejecting them until I tell it to try again when the error message pops up.

    This just started happening over the past couple of weeks, more frequently as each day has passed, now happening hourly.

    Does anyone have any ideas why this is happening, or how to fix it? An Apple Advisor suggested that I have a corrupted repeating event, but iCal doesn't give me any way to find out if that's true by identifying a bad event.
  • Jeroen Vink Level 1 Level 1 (10 points)
    Hi,

    My problem is solved. I had contact with Apple Care (MobileMe) and Nolan helped me with this chat session:

    NOLAN:
    First step would be to go ahead and open iCal, go to the iCal menu > preferences > accounts.

    See your MobileMe account listed?

    Go ahead and select that and click the minus icon in the lower left.

    Account removed?

    Me:
    Yes and all data seems to be deleted

    NOLAN:
    Excellent, go ahead and quit iCal.

    Click on the magnifying glass in the top right corner of your screen and type in "Terminal"

    Copy and paste the following command in...

    +defaults delete com.apple.iCal UserHasRemovedMobileMeCalDAVAccount+

    Press return on your keyboard to submit that command.

    And then do the same copy/paste and return for this command...

    +defaults delete com.apple.iCal CalMobileMeMigrationToCalDAVRequestUpgradeAfterDowngrade+

    Me:
    I get 2011-01-02 22:25:15.024 defaults[3457:903] There is no (CalMobileMeMigrationToCalDAVRequestUpgradeAfterDowngrade) default for the (com.apple.iCal) domain.Defaults have not been changed.imac-van-ons:~ Vink$

    NOLAN:
    That's fine, go ahead and close out of Terminal.

    Then re-open iCal and your account should automatically re-add itself.

    Me:
    iCal is filling up again now

    NOLAN:
    Excellent.
  • alainca1 Level 1 Level 1 (0 points)
    Thank you! Had the same problem, the fix worked.
  • Matt Crawford2 Level 1 Level 1 (95 points)
    I have the same problem (frequent "Bad Gateway" errors).

    I just tried the solution posted by Jeroen Vink.

    When I came to the two "defaults delete ..." commands, I had neither key present, so I got "Defaults have not been changed" twice.

    When I restarted iCal, it did NOT automatically add my MobileMe account. (But perhaps it's relevant that I already had a Google CalDAV account present.)

    I had previously deleted and re-added my MobileMe CalDAV account and the problem continued. But I had not quit & restarted iCal in between. Now it has been an hour and the error has not recurred.
  • Tim Meesseman Level 1 Level 1 (110 points)
    Excellent! That fix worked for me!
  • Matt Crawford2 Level 1 Level 1 (95 points)
    Nope, no good. The error still happens.
  • chip.r Level 1 Level 1 (30 points)
    Thanks for that transcript. I followed the process and it worked as described. Now we'll see if it prevents that error from reoccurring.
  • bleusky Level 1 Level 1 (0 points)
    This worked - thanks for posting!
  • Webmason1 Level 1 Level 1 (0 points)
    Hi,

    Add my name to the list of those this is happening to.

    I have preformed the fix above and now just waiting to see if it works for me too.

    Thanks for posting it!!
    Tom
  • Bruce Johnson5 Level 1 Level 1 (5 points)
    Tried all the solutions here and none worked. Used Apple chat and we finally figured out the problem (which may help any old legacy .mac members).

    When we deleted my Mobile Me account (iCal > preferences > accounts > delete Mobile Me) and the screen came up when I went to add a new account, it defaulted to my .mac address. When I changed that to .me, everything sync'd. Unfortunately, it only took an hour to figure that out

    Hope that helps someone else!
  • Windy Level 1 Level 1 (0 points)
    I stumbled on the .mac problem after I had tried the nicely posted solution and it didn't work. The calendar has now refreshed and I will check my other computers to see if they too are getting the same glich. Thanks.
Previous 1 2 3 Next