6 Replies Latest reply: Jan 6, 2011 5:32 AM by Tom Gewecke
Sid M Level 1 Level 1 (0 points)
I'm American and used to using a QWERTY keyboard, but I like to do some occasional writing in German. On my PC, the added alphabet characters are easy with an alternate keyboard layout selected.

I got an iPod touch recently and with (U.S.) English selected as the language I was happily able to select the extra German letters of ä,ü,ö, and ß by holding after a tap the a,u,o, or s respectively and then sliding to the select the variant I wanted. Everything was perfect...

A couple of days ago, I upgraded to OS 4.2.1 (I had 4.1.something before) and now it seems the "ß" option has vanished (ä,ö,ü are still available as before). The only way to get the ß back is to change to "German" under Settings-General-International-Language. Aghhh.

Can somebody who *hasn't upgraded* confirm that holding a lowercase (it has to be lowercase I think) "s" gives an option to pick "ß" ? And can somebody else who has "upgraded" to 4.2.1 confirm that indeed the β has now disappeared, i.e. holding the lowercase "s" offers nothing additional.

Also, am I correct in assuming that the "Hardware Keyboard Layout" only concerns an external keyboard and not the softkey keyboard that pops up on the iPod Touch itself? I tried tinkering with those settings, but they don't seem to do anything for me (no external keyboard).

Thanks!!!!!

iPod Touch 4G, iOS 4, keyboard layout
  • Tom Gewecke Level 9 Level 9 (74,955 points)
    Can somebody who *hasn't upgraded* confirm that holding a lowercase (it has to be lowercase I think) "s" gives an option to pick "ß" ? And can somebody else who has "upgraded" to 4.2.1 confirm that indeed the β has now disappeared, i.e. holding the lowercase "s" offers nothing additional.


    Yes, that has changed. Tell Apple you want it back here:

    http://www.apple.com/feedback/ipodtouch.html

    Also, am I correct in assuming that the "Hardware Keyboard Layout" only concerns an external keyboard and not the softkey keyboard that pops up on the iPod Touch itself?


    Yes, it means exactly what it says -- those layouts are for (external) hardware keyboards only. The ones for the software keyboard are listed separately.
  • Robert Newall Level 3 Level 3 (605 points)
    Sid, from what you and Tom say may I suggest this. Use an external keyboard. I know you can't connect a usb keyboard to the iPod Touch but you can connect a bluetooth keyboard.
    I am prone to use very long WiFi passphrases, so long I would not like to risk the keying to my fat fingers and the tiny iPod keys. So I paired the device with an Apple BlueTooth KB I have and used it's full size keys to Key my WiFi password. Of course you would need to be able to write with the wireless KB in the iOS app you write the German in and I have never tried to use the wireless KB to type German characters. You could try that and Im sure Tom G would be able to help squeeze the character out of the input device.
  • Tom Gewecke Level 9 Level 9 (74,955 points)
    The only way to get the ß back is to change to "German" under Settings-General-International-Language.


    Surely you can also type the ß by just switching to the German keyboard layout. You add it via Settings > General > Keyboard > International Keyboards > Add New Keyboard. Once added, you can switch to it quickly by hitting the Globe key or holding the Globe key down and selecting Deutsch. By tapping German on the keyboards list, you can choose to have it Qwerty instead of Qwertz if you want. It's not necessary to change the OS language to German.
  • Tom Gewecke Level 9 Level 9 (74,955 points)
    I have never tried to use the wireless KB to type German characters.


    It should work just fine. If you hit Option/alt + s, you'll get the ß.
  • Sid M Level 1 Level 1 (0 points)
    Everyone -
    Thanks for the kind responses. Yeah, I know I can hook up an external wireless keyboard, but once I start doing that, it's no longer iPod sized... I might as well have an iPad. My "need" (and it isn't a true need, just an annoying downgrade in functionality) is for doing short notes, posting to German friends' Facebook pages and the like. If I'm doing some serious writing, it's at a laptop.

    Tom suggested selecting the German keyboard layout (but keep QWERTY). I actually already tried that (and tried again just now just to re-check), but the problem with that is that unless you keep "globing" back and forth between US& German keyboard layouts, the German keyboard screws up the auto-correct bigtime and amusingly capitalizes all (or almost all) nouns even in English words (sometimes I'm mixing languages). I guess I could turn off auto-correct as well, but it's probably not worth it for a minor gripe. I just wanted to see if I was crazy or if the "ß" did indeed go away for the U.S. keyboard. Looks like it did, which is annoying... not sure what it was hurting having it there....
    I guess I'll act like the Swiss and use "ss" as a replacement.

    Thanks again, everyone.
  • Tom Gewecke Level 9 Level 9 (74,955 points)
    the German keyboard screws up the auto-correct bigtime


    Using the German keyboard is supposed to activate proper autocorrect for German. And of course when you write German with the English keyboard, it should be doing autocorrect for English.

    I just wanted to see if I was crazy or if the "ß" did indeed go away for the U.S. keyboard. Looks like it did, which is annoying... not sure what it was hurting having it there….


    Perhaps someone was overly obsessed with matching keyboards to what is normally used in the language. Maybe they will go back to the earlier version if enough people complain via the feedback channel.