Previous 1 2 Next 21 Replies Latest reply: Jan 3, 2011 1:14 PM by barryjacq2
barryjacq2 Level 1 (0 points)
I have two macs, one is a powerbook (Power PC G4) running 10.4.11, the other is a Macbook running 10.5.8.

I have had absolutely no problems accessing the wireless internet on the Powerbook. The internet connection works perfectly and works when the computer is woken up after sleeping.

However the MacBook continues to have major very frustrating problems to the point at which I am considering going back to a windows machine.

This is a controlled experiment, since the two machines are both running off the same wireless internet connection and in the same location, and that I have problems with the one mac but not the other. I have run the experiment with a different router model, and had exactly the same results. Again, no problems at all with 10.4.11 and horrendous problems with 10.5.8. It is clear that something in the 10.5.8 operating system is broken compared with the 10.4.11 OS, in spite of what Apple says. It is nothing to do with the router (I have tested two of them). I have so far wasted hundreds of hours (so much for Mac productivity!) researching the internet for a solution and nothing has worked.

I suspect the problem is due to interference with other devices in the apartment block. The internet connection worked fine for 12 months, until someone visited me with an iPhone. Whenever the iPhone was turned on, I could not access wireless on the 10.5.8 macbook. When the person with the iPhone left the area, everything was fine once again for four months. Then some more internet connections appeared in the neighborhood and I am no longer able to access wireless, although occasionally I have managed to get onto the wireless connection when I move the computer very close to the router (within three feet - not a good solution!).

I have tried every solution found on the internet for this problem except that I cannot change the channel because the internet router does not allow me to do that. The internet company sets the channel to automatic and there is no way to change it on the router.

At this point, I will need to throw the computer away unless anyone can suggest another solution. However it is clear to me that it is an apple OS problem, not a problem with my router or my settings. What I don't understand is why apple cannot go back to the software they had in 10.4.11?.

Over the past few years the mac operating system has had a lot of (mostly superficial from a users point of view) interface improvements, at the cost of losing the most critical functionality. It's a question of not seeing the wood for the trees from Apple's point of view. It is very sad to see Apple's emphasis changed from usability (which is why I have until now been a loyal mac user from when the very first macs were made), to sexy interfaces which are all flashy image and no substance from a usability point of view.

What happened to Apple's HCI (Human Computer Interface) expertise? I suspect these people still exist inside of Apple but are being overridden by marketing people who seem to not understand the fundamental principle of marketing, which is that in order to survive in the long term you need a USP (unique selling proposition). Usability used to be Apple's USP. Now it has lost it.

If someone from apple could respond to this posting I would be grateful.

Macbook, Mac OS X (10.5.8)
  • Andreas  Level 4 (1,510 points)
    I think that you are likely to remain frustrated until you can try different channels -- how you arrange to do that has to be up to you. Ranting about Apple or others is less likely to be of help.

    I personally have four Macs of varying vintage, some running Leopard, some Tiger, all accessing the same internet connection. Some channels give a dreadful result -- I don’t use those! 

    Using “Interference robustness” might help you slightly, but not more than slightly -- and at the possible expense of overall performance. I have never heard of a router that does not permit choosing from a range of channels, but that seems to have been your choice. Your next move is also entirely your choice!

  • barryjacq2 Level 1 (0 points)
    The internet router is not my choice. It is a proprietary model supplied by the internet provider, in my case Telecom Italia (this is in Italy). Since this company is the only provider of internet services in the area, there is no alternative. I have copied below the control panel you get with the internet company. The line 'canale' translates to 'channel'. The value 'automatico' I assume means you cannot change it.

    If the channel were the problem, then why does my other Mac not have the same problem? This only logical conclusion is that there is a fundamental flaw in Apple's new operating system, that did not exist in the previous version.

    With regard to my comments regarding Apple's recent poor UI design, my comments still stand. An experienced OS interface designer would never design a system that requires the end user to change channels, since most end users would not know what a 'channel' is, let alone know how to change it.

    fyi. this is the screen you get with the internet company:
    Rete Wi-Fi (SSID) Alice-76709920
    Stato Interfaccia Radio Abilitato
    Canale Automatico
    Modalità di cifratura WPA-PSK TKIP 256 bit
    Chiave cifratura
    9cbcl0j1pp0sgkjhokpfrir3 [ASCII]
    Controllo Accesso Disabilitato
  • Andreas  Level 4 (1,510 points)
    It is a proprietary model supplied by the internet provider

    Some ISPs supply a router as a courtesy but have no objection to your using a different one, or a different combination of router and modem. Have you spoken to Telecom Italia? Have you asked for their advice?

    The value 'automatico' I assume means you cannot change it.

    Not necessarily. The choice is often (perhaps usually) either one from a range of numbered ‘canali’ or ‘automatico’.

    If the channel were the only problem, then my other mac would not work.

    Not so. That ignores a host of other variables. I have to repeat that with your problem the first troubleshooting step should be to try alternative channels.

    In bocca al lupo!

  • barryjacq2 Level 1 (0 points)
    Thanks for the suggestions. You were quite right about the 'automatico' being an option. I did find out how to change the channel. However I tried all the channels from 1 - 13, some allowed me to see the network, but when I tried to connect I always got the 'connection timeout' error.
  • Andreas  Level 4 (1,510 points)
    Something is wrong with your settings. “Connection Timeout” is a well-known problem. Google might help you find the solution that you need -- sorry, there isn’t just one for all situations. Don’t follow suggestions which sound too complicated -- the one you need is likely to be simple as well as logical. I just did a one minute search and found, for example, this. The hardware and software don’t match yours, but the advice is universal, sensible, and worth a try. Also, you might try removing security (in System Prefs / Network), clicking on “Apply”, and then re-applying security -- use WPA (e.g. ‘WPA2 Personal’) in preference to WEP. As well as removing and re-applying security, you could also remove the entire Network Name entry, clicking “Apply”, and then re-creating the entry.

    In spite of what you have just written, when you see that you are winning you should again try to find the best channel.

    BTW, I'm sure you will have checked that your Router has the latest firmware.

  • barryjacq2 Level 1 (0 points)
    Hi Andreas,
    Thanks for the reply.

    I have tried removing the network name entry and re-creating it several times but this does not solve the problem.

    I have checked the router's firmware. It is updated remotely by the phone company. (the modem manual says "Firmware aggiornabile da remoto"). (ps. I cannot call the phone company to double check because they will not answer questions unless you give them $30). However since the firmware is remotely updatable and there is no way of updating it locally, then one must assume it is kept up to date.

    I tried removing the security in system prefs network (I clicked on Airport, then Advanced to do this). I then re-applied WPA2 Personal. This also did not work.

    It appears that although my partner and I have worked for 25 years in the computer industry and would consider ourselves experienced computer users, the simple and logical solution is still eluding us even though we have googled "Connection timeout" many times already and tried both simple and complicated solutions. In fact we've probably spent about 30-40 hours already over the past year googling and trying out various fixes. We must be dumb to have wasted this much time trying to fix the problem! However the most frustrating thing is that all this time, my ten year old Power PC 10.4.11 mac has worked perfectly in connecting to the internet, no matter where I use it or with what router/modem. It is only the newer machine that has problems.

    Any other simple logical things I could try?
  • Andreas  Level 4 (1,510 points)
    It sounds as if Telecom Italia ought to experience some competition. However, to be fair to them, it does sound as if the problem is most likely to be specific to your MacBook.

    You might try a search for “connection timeout”, or make a post, in a more specific forum. I'm disappointed that no-one else has responded here. Try e.g....

    one of the AirPort forums or the MacBook forum

    If you make a post give the link to this thread to avoid having to repeat everything. Sorry I can’t be more helpful.


    BTW, re
    It is clear that something in the 10.5.8 operating system is broken compared with the 10.4.11 OS

    It is likely to prove a waste of time but it can’t do any harm to (re-)run the

    OS X 10.5.8 Combo Update

    As you probably know, you can re-apply a Combo Update as often as you like. At worst it will do nothing, but there is always the chance that it might replace a corrupt item.

  • WZZZ Level 6 (12,795 points)
    You can get a fifteen day demo version of AirRadar, which, except for closed networks that don't broadcast their SSIDs, will show you which channels are occupied and strongest and which are open. Since there may be closed networks on channels which appear to be completely open, it's not a perfect solution, but it's better than having no idea at all. You do know that if you option click the Airport Icon in the MenuBar, you will get a signal strength and transmit rate readout. I wonder what that looks like?

    And there's iStumbler which is completely free.

    I would also follow Andreas' suggestion and apply the 10.5.8 Combo. There isn't any reason why 10.5.8 should work any worse than 10.4. I would also follow up on the Airport or MacBook Internet and Networking forum. There are some very knowledgeable people there who could continue to troubleshoot this.

    It is also possible that there is some kind of malfunction with the MacBook Airport card. You may have already mentioned this and I don't know what vintage the MacBook is, so it may not have shipped with Tiger, but did you ever have 10.4 running on the MacBook. If so, was it problem free then?

    Message was edited by: WZZZ
  • barryjacq2 Level 1 (0 points)
    Thanks for the reply.

    Actually I have already been using iStumbler to check the channels and see what other internet users in the area are using.

    The signal strength readout on the 10.5.8 macbook is:
    0:0:0:0:0:0 (don't know what that means)
    Channel 11
    RSSI -66
    Transmit Rate 54

    I wanted to get the equivalent signal strength readout on the 10.4.1 powerbook (right next to it) but the option click trick does not work on this OS. However the signal strength has 4 bars on the powerbook, and there is no problem with the connection.

    The macbook is running the OS it shipped with. The problem is intermittent. I had bad problems with it over a year ago in another apartment. Then I changed apartments and it worked fine for almost 12 months except when there was someone in the apartment with an iphone switched on. It worked fine for another couple of months after that, then just started to have problems again, and now will not connect at all, except very occasionally when I am right next to the router.
  • WZZZ Level 6 (12,795 points)
    I believe the Hardware Test will check the Airport card. I'd run it in Extended. It may be necessary to run it several times before it picks up any error.
  • Andreas  Level 4 (1,510 points)
    You may have found a useful clue. That first set of six numbers should be the ID of the router you are accessing. *That set of zeroes looks like something that needs investigating*. (The RSSI and the Transmit Rate look OK).

  • barryjacq2 Level 1 (0 points)
    Do you know if the Apple Hardware Test is on one of the disks that shipped with the computer? I only have three disks:
    Mac OSX Install Disk 1
    Mac OSX Install Disk 2
    Applecare Protection Plan Tech Tool Deluxe
    Is it on one of these disks?
  • WZZZ Level 6 (12,795 points)
    Depends on what it shipped with.

    +* For Intel-based Apple computers shipping with Mac OS X v10.5.4 or earlier, Apple Hardware Test is located on the Mac OS X Install Disc 1 and should be included with your computer.+
    +* For Intel-based Apple computers shipping with Mac OS X v10.5.5 or later, Apple Hardware Test is located on the Applications Install Disc 2 and should be included with your computer.+

    Maybe this will help if you don't remember.

    Other than that, you have a 50% chance of getting it right.
  • Andreas  Level 4 (1,510 points)
    A wild guess which may or may not be relevant to your Mac not reading the router’s id...

    If you are using a setting of Telecom Italia’s firewall you could try turning your Mac’s firewall off -- Sys Prefs / Security / Firewall / “Allow all incoming connections”. Then do a "hard reset" of the router, or power it down and back on again - according to its instructions.


    Also, I feel sure you will have already tried a variety of DNS Servers, but the one supplied by Telecom Italia (or any decent ISP) should be fine.

Previous 1 2 Next