12 Replies Latest reply: May 20, 2012 5:30 AM by Kalsta
AshleyTarver Level 1 Level 1
As the title says, when I am using a text entry box within Safari and press backspace it actually goes back a page instead of just deleting the last letter I typed. This is really starting to annoy me. I tried to Google an answer to stop Safari doing this but it isn't easy to come up with the right combination of words to locate a fix.

Any ideas?

iMac, Mac OS X (10.6.5)
  • Carolyn Samit Level 10 Level 10

    From your Safari menu bar click Safari / Preferences then select the Autofill tab.

    Click the Edit button next to: Other forms.

    Remove all.

    Quit Safari (Command + Q) then relaunch Safari. See if that makes a difference.

  • AshleyTarver Level 1 Level 1
    Hi Carolyn and thank you for your response.

    Unfortunately that didn't resolve the issue. I notice that other browsers (firefox and IE) suffer the same problem by using the backspace key as a navigation aid. I have to wonder what people were thinking when they clubbed together and decided that was a good idea ...

    BACKSPACE is for correcting spelling mistakes within text fields and URL fields. I already have my thumb button on my mouse set to go back a page, why on earth would I want to disable my delete button?!

    Ugh, it's making me mad thinking about it. Thanks for taking the time to reply though, much appreciated.

  • andyBall_uk Level 7 Level 7
    Hi Ash

    the problem shouldn't show up once you have focus in a text field... so if it does, there's something amiss; but that said, this thread suggests a Safari extension KeyStroke to alter the behaviour.
  • AshleyTarver Level 1 Level 1
    Hi andy and thanks!

    I will set up Keystroke to disable this 'feature' on my iMac Safari, but I also use Safari on my Windows7 PC and so the behaviour affects that as well ... and as far as I know I can't change that Safari's behaviour ... I might just have to install Firefox and be done with it on the Win machine. Which I really didn't want to have to do.

    I've said it before in the occasional thread, one thing I hate is being forced to use 'features', there should always be options to alter the behaviours to how we want them to be!


    /sips tea.


    Message was edited by: AshleyTarver
  • andyBall_uk Level 7 Level 7
    ... and as far as I know I can't change that Safari's behaviour...

    Doesn't Safari for windows have extensions too?
  • осёл Level 1 Level 1
    This is the most annoying behaviour of the new browsers. You should be able to disable it. You can't just sit there like some kind of self-righteous idiot and tell users that "if you don't like it, then you're not working in the right way."

    (Yes, I've seen that in other forums- for example I'd like to change the windowing behaviour on a Mac so that it's more like Linux, but that is the response other people have gotten over that request, and frankly, it's short-sided, prejudiced and intolerant of others' work behaviours.)

    Here's the situation. I log into busuu.com, for example, and write a 200 line response to someone in Russian. It takes me about 2 hours. I then go back to proof-read the thing. I'm clicking on the text box, I make a change, then the slider bar, then the text box, then the slider bar. Maybe I make a MISTAKE and actually don't click on the text box. Then I hit the backspace key to delete one stinking little character and I LOSE MY WHOLE *ING MESSAGE

    This is rediculous. First it appeared in Opera a couple of years ago, it was totally annoying. Then Internet Explorer picked it up. Now it's considered a completely normal thing to do and can't be disabled on ANY browser. (Let me know which one doesn't do this, and I'm switching.)

    What's the message? NEVER try to put any thought in anything you write in any textbox, because if you try to correct it, or try to do something else, you'll be whisked off the page... You might as well say something quippy and absolutely insipid than put some thought into something. It's absolutely aggravating and I'm about to sign off the whole fricking web over it. Change it! Do it now! This is a stinking bug as far as I'm concerned.
  • angelo1977 Level 1 Level 1
    Hi Guys

    I know this problem is really annoying and STUPID I found out that this is happening just in dialog box in chat rooms, however the only simple solution I have found after searching a lot is use the key Shift + Backspace in order to delete what I have typed without sending me to the previous website. I understand this is not really smart but it is the simplest solution before going crazy with this f. issue.

    I hope this help

  • L.Shaner Level 1 Level 1

    You can disable the "backspace goes to previous page" behavior in Firefox, by going the following url:




    (type the above, "about:config" in the address bar [no quotes])


    Then next to "Filter" type "backspace" to find parameters corresponding to backspace.


    Then set the value of the following parameter to 2.




    That will insure that at least when using Firefox, if you accidentally hit the backspace button then it will not navigate to the previous page...which should allow you to avoid losing your input on the current page.

  • jimc99999 Level 1 Level 1

    Thank you so much for that tip, I tried it and it works great.  Firefox will now become my default browser so I don't have to put up with this incredibly annoying behavior any longer.

  • Kalsta Level 1 Level 1
    Mac OS X

    I agree… A really bad 'feature' of the UI and I can't believe Apple included it. Using a single key to perform such a potentially destructive action is almost unforgivable. There are various instances where going back to the previous page might lose data… One is where the user has typed into a form, and accidentally hits delete when no text field is active. I discovered another while trying to use online emulation software. Safari was obviously not aware that the software was accepting text, so it jumped me back to the previous page as soon as I tried to delete a character. The entire state of the program was instantly lost, and I had to reload the page from scratch.


    There is already a perfectly good keyboard shortcut for this: Command-[ which performs the same function, but it requires two keys which aren't likely to be pressed accidentally or for any other purpose.


    I've submitted my feedback to Apple regarding this issue, and suggest others do the same here:


  • hupjack Level 1 Level 1

    This is either a design flaw / human factors bug, or a handy dandy feature depending on what camp you are in.  (I find it an obnoxious flaw), and I call it that because it can blow away your data.


    With one key stroke, if the focus has shifted away from a text box (which is very easy to do with a laptop touchpad), you can hit the backspace key, and lose all the data you had just been typing.


    This is destructive, and that makes it bad enough that users should at least be given the option (like they are given in FireFox) to disable this mapping.


    I just hit this bug 2x yesterday - with FaceBook - and wrote this up on my blog, complete with this video capture of Firefox flexibly working around the FBook bug.


    I added my response to the Chrome Design Lead's comments over here at Quora (if you think voting it up will help - go right ahead). I don't have a clue who to bother @ Safari.


    Finally, now I echo my comments here, to let you Safari users know, you aren't the only ones. Chrome has the same problem / feature.


    So I have switched back to FireFox. I was looking for a reason, and now I have one. Voting with my feet... it feels good. Open source non-profit rainbow sunny freshness :-)

  • Kalsta Level 1 Level 1
    Mac OS X

    hupjack wrote:


    I don't have a clue who to bother @ Safari.


    See my comment right above yours…




    You're welcome.