1 Reply Latest reply: Jan 2, 2011 2:38 PM by William Boyd, Jr.
SarahC0612 Level 1 Level 1 (0 points)
Hello,
I recently updated from Tiger to Snow leopard on my Mac Book. I use airport to connect to the internet wirelessly and we have a hidden and secure wireless account with our phone company. When not in use, I put my computer to sleep. Before I upgraded to snow leopard, my computer was always connected to our network. All I had to do was open it and I'd be connected instantly. But ever since I upgraded, I have to reconnect to the internet every single time I wake my computer from sleep mode.

To sign in, I have to go to system preferences, and actually type in the network name that I want to join (since ours is hidden). Then to enter the password, I have to select WEP 40/128-bit hex from the drop down menu and then enter our password. I thought it was just WEP password, but that did not work... it says that it's connected to the internet, but there is no IP address. I have absolutely NO IDEA what the difference between WEP and WEP 40/128-bit hex is or if it's even relevant, but thought I'd share just in case it was.

My question is, how do I set my computer up to remain connected to the internet like it was before I upgraded my operating system? I have tried everything, but nothing is working. I am really confused. Please help.

Thanks!
Sarah

MacBook, Mac OS X (10.6.3)
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    SarahC0612 wrote:
    since I upgraded, I have to reconnect to the internet every single time I wake my computer from sleep mode.


    Welcome to Apple's discussion groups.

    To sign in, I have to go to system preferences, and actually type in the network name that I want to join (since ours is hidden).


    Have you tried the option "Join Other Network" under the AirPort menu bar item?

    how do I set my computer up to remain connected to the internet like it was before I upgraded my operating system?


    Open the Network panel of System Preferences, select the AirPort connection item on the left, click the "Advanced" button, then select the "AirPort" tab. If it's not checked, check the box for "Remember networks this computer has joined". Click "OK", then "Apply".

    If that doesn't help, it may help to reset the connection settings on your Mac using these steps:

    1) Use the AirPort menu bar item to turn AirPort off, then on again.

    2) In the Network panel of System Preferences delete the AirPort item from the left column, then add it back.

    3) In the same panel as (2), define a new location and see if you can make that work.

    4) In the same panel, select the AirPort connection item, click the "Advanced" button, select the "TCP/IP" tab, then click "Renew DHCP Lease".

    5) In the folder /Library/Preferences ( not <yourhomefolder>/Library/Preferences), move the folder SystemConfiguration onto the Desktop, then restart your computer. See if you can now make your AirPort connection work.

    They may not help, but they'll only take a couple of minutes to try. Before you try these, note all your network settings, because the latter steps will destroy them.