8 Replies Latest reply: Feb 3, 2011 9:34 AM by baltwo
mooska Level 1 (0 points)
Cannot boot up iMac Intel Core Two Duo. Keep getting the Apple logo and it won't advance from there. Have tried connecting fire wire to another Intel iMac by placing the computer in Target mode. Host computer does not recognize the target computer. I've also put the original installation disk in, held down the "c" key and brought up the disk utility program. Thought I would try to repair disk. That didn't work either. Any ideas would be greatly appreciated.

iMac, Mac OS X (10.5.8)
  • baltwo Level 9 (62,210 points)
    Zap the PRAM and try booting again.
  • Ted Alley Level 1 (0 points)
    Try disconnecting your peripherals before booting. I've had my iMac not boot before simply because I had a couple FireWire drives plugged in. Otherwise, I hate to say it, but it could be a dead HD. When they die on Macs, the computer stops after it shows the Apple Logo, which is what you describe.
  • OS Crasher Level 1 (0 points)

    I have the same problem with my MacBook: it would not boot anymore, in my case after a total crash just on leaving Safari (which started to regularly crash without doing other visible harm some months ago). I get the folder with the question mark when trying to boot. Tried everything described on apple.com and guides.macrumors.com short of plainly erasing the hard disk. (The hardware check was okay, though.)

    In Disk Utility (accessible while pressing "c" when booting with the originally shipped OS 10.5 DVD), the hard disk is grayed, and I can't mount it ("Mount failed - The disk 'Macintosh HD' could not be mounted"). When I try to repair or just verify the disk, I get a failure message ("volume check failed") mentioning an "invalid node structure".

    I also tried a Time Machine backup, but I get: "An error occurred while erasing your restore destination volume. Restart your computer and try restoring again --- Cannot erase volume". I tried again, but this second time, the disk was not even found anymore in the "Select a Destination" screen. Furthermore, the disk "Macintosh HD" is not even named as such anymore in Disk Utility, but "disk0s2".

    Does this mean that my hard disk is "dead"? If so, are data retrievable, and at what cost (financially speaking)? Also, is there any sense in buying and installing a new hard disk, or would this match the price of a new notebook?

    Grateful for any ideas... :/
  • baltwo Level 9 (62,210 points)
    With *"invalid node structure"*, you need something stronger, such as DiskWarrior or TechTool Pro.
  • OS Crasher Level 1 (0 points)
    Thanks! I'll try those or just install a new hard drive (my data is safely back-upped...).
  • baltwo Level 9 (62,210 points)
    Let us know how that turns out.
  • OS Crasher Level 1 (0 points)
    Having Linux check my bad hard drive let to the same results: some obscure problem (what my Mac called a failing node structure), so impossible to do anything with this drive without specialised programmes.
    I finally installed a new hard drive, got a nice Western 320 GB, 7200 RPM. Recovered data from time machine and recent stuff from my USB and camera. Everything is working fine again, except that a disk verification in disk utility let to the circle of doom - don't even know why I did this, but it's a bit disturbing. I just hope that's nothing serious and my machine keeps running again... I'll let you know if anything strange happens...