Skip navigation

AirPlay audio sync issue

45530 Views 36 Replies Latest reply: Dec 15, 2013 3:43 AM by andymellor11 RSS
1 2 3 Previous Next
retropc Calculating status...
Currently Being Moderated
Jan 4, 2011 11:52 AM
I'm using AirPlay to stream audio over WiFi from iTunes 10.1 to both an Airport Express and a 2nd gen Apple TV. My network setup has a DSL modem connected to an older (Buffalo) WiFi base station, with the Airport Express connected as a WDS remote. Both the MacBook serving audio via iTunes and the Apple TV get their wireless connection via the Airport Express, which is about 35 feet away. Signal strength as seen on the Macbook is good (5 bars).

If I play audio simultaneously through the speakers connected to the Airport Express and the computer speakers, there is good synchronization. However, the audio played through the AppleTV is delayed by several (10s of?) milliseconds, which means that playing through AppleTV and computer in the same room results in a significant echo effect. The same is heard when playing through the AppleTV and Airport Express at the same time.

Has anyone else had this problem playing from iTunes through the AppleTV? Any suggestions as to how to solve this, or will it require another software update? My understanding was that AirPlay was meant to synchronize audio played through multiple speakers - this is not the case with my setup. Music played in two rooms is difficult to listen to when between the two sets of speakers.

Chris
MacBookPro 15" (2.6GHz), Mac OS X (10.5.2), AppleTV (2nd gen), Airport Express
  • dtommyd2 Calculating status...
    Currently Being Moderated
    Jan 4, 2011 4:00 PM (in response to retropc)
    I'm glad I saw your post. I was going to try to ask someone from Apple about this same issue. I have 3 Macs, 2 Apple TV2, 1 Apple TV 1 (yes it still works with AirPlay). I have an AirPort as well. I'm not sure how Apple could ever expect these things to sync perfectly. These echos can't really even be accounted for from an Apple TV2 playing on my Samsung Plasma, to the Apple TV in my basement on my Denon. These Milliseconds add up fast and I've gone back to my FM transmitter. It's too disracting. It's like watching a movie and your rear surround speakers are late. Apple can't be accountable for how fast my Samsung TV spits out the music. There are a million people with a million different TVs. Apple also can't fix the speed of sound. Everything in nature has a speed. There must be a hundred variables. These tiny adjustments can't be fixed by a firmware update. My kitchen is 50 feet that way, and my basement is over there. I need a manual adjustment. If I can't adjust this, I can't use it, simple as that.
    Also - along the same line- I have my Apple TV 20 feet away from my tv on my reciever. I'm having the same audio/ video sycing issues. It's very high quality hdmi and I don't know where to start there either. I need to be able to adjust it.
    How about an iPhone/Mac app that can listen to the room, tell it where you are(or gps?) and the app adjusts the timing system wide through iTunes.
    There - go make a million with that one. All yours.
    core2duo 2.4ghz, Windows 7, Atv1+2, iPad, 3 iPhone 2g, iPod Touch 1g - 3 Macbook- 4 win7
  • MiceAge Calculating status...
    Currently Being Moderated
    Jan 11, 2011 7:45 AM (in response to dtommyd2)
    I have the same issue with an imac / with harman kardon and a apple tv2 linked by hdmi to my tv then av cables to a panasonic 5.1 surround sound system, the apple tv was orginally wireless from a time capsule, i first tried changing it to wired ethernet to see if this would improve the lag , which it didnt.I am now thinking of trying the optical out from the apple tv straight to the 5.1 - does anyone think this might work? If i have any success i will the results post here.
    iMac 2.4, Mac OS X (10.6.5), Apple Tv , iPhone 3G , 2nd Gen Touch , Imac G5 PPC 1.9
  • MiceAge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2011 12:52 PM (in response to dtommyd2)
    Just tried the optical audio from the apple tv2 and this worked, synced perfectly.
    iMac 2.4, Mac OS X (10.6.5), Apple Tv , iPhone 3G , 2nd Gen Touch , Imac G5 PPC 1.9
  • bakerster Calculating status...
    Currently Being Moderated
    Jan 13, 2011 7:12 AM (in response to retropc)
    I've got the same issue. I'm completely updated on all ends, both the Apple TV, and all software updates for the iMac are good.

    When playing to an Airport Express, the iMac & express are perfectly in sync..

    When playing to Apple TV 2, audio is not in sync.

    I also, do not have the ability to connect with optical, only HDMI.

    Router is brand new, Netgear N600, and both devices are on a 5GHz 'n' connection.

    Terribly annoying.
    iMac 27", Apple TV 2, Mac OS X (10.6.6)
  • newagemac Level 2 Level 2 (240 points)
    Currently Being Moderated
    Jan 13, 2011 7:36 AM (in response to retropc)
    I'm hooked up with HDMI to my receiver for my ATV2, RCA cables for my Airport Express, and regular computer speakers for my Mac and all of them are perfectly in sync. Airplay provides about a 2 second buffer delay so that everything can be in sync so you shouldn't have that problem. How is the Apple TV connected to your audio equipment and what audio equipment are you using? Is there some type of HDMI switch or splitter in between?
    Unibody Macbook Pro | 2010 Mac Mini | iPhone 4 | Apple TV 2G, Mac OS X (10.6.5)
  • newagemac Level 2 Level 2 (240 points)
    Currently Being Moderated
    Jan 13, 2011 8:24 PM (in response to retropc)
    It might be the conversion from digital to analog from your TV to the amp. You should try disconnecting the amp to see if just using the TV speakers still causes a sync problem.
    Unibody Macbook Pro | 2010 Mac Mini | iPhone 4 | Apple TV 2G, Mac OS X (10.6.5)
  • bakerster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2011 8:45 AM (in response to newagemac)
    I have no amp, this is pure HDMI to TV. The delay has to be either the TV or the Apple TV. There's no other culprits.
    iMac 27", Mac OS X (10.6.6), 8GB Ram, 1tb HD, HD Radeon 5750
  • Romeodawg Calculating status...
    Currently Being Moderated
    Feb 18, 2011 7:09 PM (in response to retropc)
    Same issue here, and it's just started today for the first time - I've been having no problems playing iTunes using the computer and ATV1 (and now ATV2) via Airport Express for years.

    Today for some reason the sync is off -- not sure how to troubleshoot.
    iMac 27" 2.8 GHz Intel Core i5, Mac OS X (10.6.6)
  • Romeodawg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2011 5:29 PM (in response to Romeodawg)
    Same issue -- using it with no problem for years. Now's it's totally screwed. If audio doesn't sync, the idea of multiple-speakers is useless.

    Using ATV, 27" iMac.
    iMac 27" 2.8 GHz Intel Core i5, Mac OS X (10.6.6)
  • jimrobo Calculating status...
    Currently Being Moderated
    Mar 16, 2011 11:05 AM (in response to Romeodawg)
    Hi guys, I had exactly the same problem. It turned out it was my TV.

    If you google the make of your tv and engineer menu you can get into the engineer menu. There is actually an audio delay option and on mine it was set to 80ms. I changed it to 0 and the problem was resolved.

    It looks like this audio delay setting is common to all samsung lcd tv's!!
    iOS 4
  • Frogbeater Calculating status...
    Currently Being Moderated
    Apr 11, 2011 12:08 PM (in response to jimrobo)
    That did it!

    I have a Samsung and I found the setting under Sound-SPDIF Output-Audio Delay

    Works perfectly now!!
    Many
  • WunWingLoh Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 22, 2011 10:11 PM (in response to jimrobo)

    jimrobo wrote:

     

    Hi guys, I had exactly the same problem. It turned out it was my TV.

     

    Thank you so much, I did't believe it could be the TV in my situation - because I don't play sound through the TV, but a Denon AVR-3311 - but all I did was turn off the TV and after the amp did some cycling the sound came back IN SYNC. Again, thank you so much.

     

    My set-up:

     

    A latest MacMini serving via HDMI to a Denon AVR-3311 and via a WIRED 100BaseT connection to a Airport Express connected via analog stereo cable to a NAD pre-amp + power amp. With the TV on the sound via ethernet to the NAD is 0.2-0.5 sec FASTER than via HDMI.

     

    For those scrathing their heads, I'm not interested in video when I'm Airplaying, I only use it when playing music, so I can combine speakers on several floors of the house so it can be heard all over. All though the TV is the monitor for the MacMini it's easy to control without the TV either via screenshare with my MBP or iTunes Remote on iPhone or iPad.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.