4 Replies Latest reply: Jan 5, 2011 3:09 PM by barratree
barratree Level 1 Level 1 (0 points)
Hi all,

Having trouble completely removing clamXav. A process called clamscan occasionally pops up and uses 80-95% of the CPU on a friends computer. The app has been removed, but typing "locate clamXav" shows that the engine is still installed in /usr/local/

However, in finder I can't access this, even with hidden files viewable, and even in terminal I can't rmdir the directory.

Searched long and hard for solution online but no avail.

Thanks,
Barra

Mac OS X (10.5.8)
  • K Shaffer Level 6 Level 6 (11,145 points)
    You can get some info & support of a type from the home page;
    and also get the correct uninstaller, plus contact the maker...

    • ClamXAV:
    http://www.clamxav.com/

    One of the listed FAQ's in Documentation, says how to remove the product and the virtual engine...
    http://www.clamxav.com/index.php?page=FAQ#15

    *15. How do remove ClamXav and the associated engine?*


    "First, you must download the Engine Remover. When you unzip it (making sure to use either OS X's built-in
    unzipper or the most recent Stuffit Expander or similar), double click clamavEngineREMOVER.command.

    This will open up the Terminal where you'll be asked to enter your Admin password.
    The rest takes care of itself. Finally, drag the ClamXav application from wherever you
    installed it, to the trash..."

    • ClamXAV - Engine Remover:
    http://www.clamxav.com/clamavEngineREMOVER.zip

    • Mark's Software Forums - Index: (includes ClamXav)
    http://www.markallan.co.uk/BB/

    Hopefully this helps resolve the primary issue; you could probably contact the software
    maker directly to see if they have some way of correcting the problem you faced with it.

    Good luck & happy computing!
  • barratree Level 1 Level 1 (0 points)
    Thanks for that but problem remains. Tried that method from ClamXav FAQs and didn't work. Instead I get the following message from the terminal script it runs:

    {quote}rm: /usr/local/clamXav: No such file or directory
    rm: /Library/Receipts/clamav*: No such file or directory
    rm: /Library/Receipts/ClamAV*: No such file or directory

    As you're running OS X 10.4 or higher, the clamav user was not removed because it was created by Apple.
    The actual engine and any schedules you had set have been removed though {quote}

    But if I run "locate clamXav" in terminal, the following shows up:

    {quote}/usr/local/clamXav
    /usr/local/clamXav/bin
    /usr/local/clamXav/bin/clamav-config
    /usr/local/clamXav/bin/clamconf
    /usr/local/clamXav/bin/clamdscan
    /usr/local/clamXav/bin/clamscan
    /usr/local/clamXav/bin/freshclam
    /usr/local/clamXav/bin/sigtool
    /usr/local/clamXav/etc
    /usr/local/clamXav/etc/clamd.conf
    /usr/local/clamXav/etc/freshclam.conf
    /usr/local/clamXav/include
    /usr/local/clamXav/include/clamav.h
    /usr/local/clamXav/lib
    /usr/local/clamXav/lib/libclamav.3.0.3.dylib
    /usr/local/clamXav/lib/libclamav.3.dylib
    /usr/local/clamXav/lib/libclamav.a
    /usr/local/clamXav/lib/libclamav.dylib
    /usr/local/clamXav/lib/libclamav.la
    /usr/local/clamXav/lib/libclamunrar.3.0.3.dylib
    /usr/local/clamXav/lib/libclamunrar.3.dylib
    /usr/local/clamXav/lib/libclamunrar.a
    /usr/local/clamXav/lib/libclamunrar.dylib
    /usr/local/clamXav/lib/libclamunrar.la
    /usr/local/clamXav/lib/libclamunrar_iface.3.0.3.dylib
    /usr/local/clamXav/lib/libclamunrar_iface.3.dylib
    /usr/local/clamXav/lib/libclamunrar_iface.a
    /usr/local/clamXav/lib/libclamunrar_iface.dylib
    /usr/local/clamXav/lib/libclamunrar_iface.la
    /usr/local/clamXav/lib/pkgconfig
    /usr/local/clamXav/lib/pkgconfig/libclamav.pc
    /usr/local/clamXav/sbin
    /usr/local/clamXav/sbin/clamd
    /usr/local/clamXav/share
    /usr/local/clamXav/share/clamav
    /usr/local/clamXav/share/clamav/daily.cvd
    /usr/local/clamXav/share/clamav/freshclam.log
    /usr/local/clamXav/share/clamav/main.cvd
    /usr/local/clamXav/share/clamav/mirrors.dat
    /usr/local/clamXav/share/man
    /usr/local/clamXav/share/man/man1
    /usr/local/clamXav/share/man/man1/clamconf.1
    /usr/local/clamXav/share/man/man1/clamdscan.1
    /usr/local/clamXav/share/man/man1/clamscan.1
    /usr/local/clamXav/share/man/man1/freshclam.1
    /usr/local/clamXav/share/man/man1/sigtool.1
    /usr/local/clamXav/share/man/man5
    /usr/local/clamXav/share/man/man5/clamd.conf.5
    /usr/local/clamXav/share/man/man5/freshclam.conf.5
    /usr/local/clamXav/share/man/man8
    /usr/local/clamXav/share/man/man8/clamav-milter.8
    /usr/local/clamXav/share/man/man8/clamd.8{quote}

    That the programme still runs occasionally and hogs the CPU would also indicate it still exists. When I try "sudo rmdir /usr/local/clamXav" it finds no file. When I enable hidden files in finder the same, even after granting read and write permissions. /usr/local shows up empty.

    Any help much appreciated!

    Barra
  • K Shaffer Level 6 Level 6 (11,145 points)
    Could it be the ClamXav was installed under a different method
    as described in the web site; & Uninstaller script can't go there?

    Since the notations you cite from the system log indicate the
    path is certainly in Terminal or perhaps accessed via a booted
    single-user mode to attempt to disengage or change what is
    going on inside the Mac OS X system, there must be another
    way to attack this issue within the machine's Terminal.

    Of course, since I do not know the Terminal well or have more
    than a passing awareness of some of its features, I am of little
    to no help in this part of the technical resolution.

    Was there a contact email, or reference to any kind of similar
    issue/problem noted in their user forum, link in previous post?

    Unfortunately, I am probably not the one to do it! There was a time
    that I'd have gone rather far into a crash-course to learn answers
    to user problems in online forums, ones I never experienced. But
    I don't have the undivided time to expand my own horizons, to help.
    I also do not have the time to experiment with my Macs as before.

    And I have things to do and people to see; actually, I have to take
    someone else around to do those things - while I get to wait...

    {However, *one answer may be to perform an 'Archive & Install'* &
    update the system; the one catch may be a new system may try to
    import the bits you can't remove from the old User files, if the option
    in Archive & Install (to save users and settings) is chosen. So, that
    would mean more work to restore a working system as it once had,
    less the files related to ClamXav you can't be rid of presently.}

    Good luck & happy computing!

    +{ edited }+
  • barratree Level 1 Level 1 (0 points)
    Have clarified issue over on the forums of the developer of CLamXav.

    Mark, the author of clamXav, said the locate command uses an infrequently updated database, unlike linux which I'm more used to. So uninstaller script seems to have worked, but the locate database just hasn't noticed it yet.

    Thanks for your help K Shafter!


    All the best,
    Barra