Previous 1 6 7 8 9 10 11 Next 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 Go to original post
  • Ron R Level 2 (320 points)

    Having the same problem on and off for over a year with a Pixma MX350. Was working fine for the last couple of months with no "communication errors". However, just yesterday, it happened again. Using the Canon iJ network tool, it can't find the printer.Print prefs can't add a printer.  So,  I restarted the MacBook Pro, no change. Turned off the printer and restarted, reset the printer wifi connection, no change.  Rebooted the router.... connected again. Looks like it's a Verizon problem. not apple or canon.

  • lmonaco421 Level 1 (0 points)

    I agree with Loganfrom MO (way too complicated for average end user). To Ron R's point, I've only owned two wifi printers -- a Kodak and a Canon. BOTH of them give me communication errors with my Mac (I have no wifi PC to check this with). They both work fine with the USB cable, and they will both work wirelessly for a little while but then they stop working. I tend to think this is a Mac problem as it is the common denominator.

  • Harden Long Level 1 (0 points)

    I gave step-by-step istructions. Rather than say "that's too hard," why not ask follow up question for the steps you do not understand? We can't help you if you don't tell us which part you aren't understanding. That said, if you just want to throw up your hands and blame Apple and not print, that's OK, too. :-)

  • rampa6e Level 1 (0 points)

    I configured the printer a while back with the dedicated IP address, etc... It works most of the time but I still get the communication error far too often. The fact is it shhould not be this tricky to get a wifi printer to work!

  • loganfromMO Level 1 (0 points)

    You lost me from the get-go.  I am not a tech and I do not understand any of the terms you are using. Please forgive my ignorance. I work better with screen shots.  I would be happy to give you my email so you could provide instruction in terms that a non-tech person can understand.  I never had any problems until lately.  I am also not being able to print from PC to this printer.

  • henryfromsanta cruz Level 1 (0 points)

    I hate to schill for Canon or reward poor product support, but I finally conceded and bought a Canon MG6220.  Very expensive workaround, but it works great, has AirPrint (lets me print from my iphone), a few other nice things.  Best thing is no more communication errors.  Gave the MP560 to my Windows-using brother-in-law.  Now he's happy too.  Good luck everybody.

  • lmonaco421 Level 1 (0 points)

    Harden -- your instructions were awesome -- very specific and you clearly know what you're doing. I'm sorry if you felt I was impugning your assistance. My frustration comes from the belief that I shouldn't have to be doing any of this.  That, plus performing your workaround on my two printers and three MacBooks when it's supposed to be a simple matter puts me over the edge. I know you meant it sarcastically, but I actually HAVE thrown up my arms, blame Apple and now print only via USB.

    If I were to ask follow up questions for steps I don't understand, they would be something like this:

    1) How do I assign my printer a static IP?

    2) DHCP is a server?

    3) Where do I get dd-wrt firmware and how do I run it on my router? Does it matter what kind of router I have? Does it always come with DNSMasq? What if it doesn't?

    Etc., etc., etc.

    As I said, your workaround is awesome (I mean that). But I feel like a housewife being told how to land a 747 jet because the cockpit crew was poisoned ("It's real simple: just flip the IFR and adjust the glide path until the stabilizer reads -10 db. Then ramp the upper frammitz until the port manifold goes green, then you're good to go for 3 clicks. Just be sure that the aileron GCU doesn't FPO while the altimeter sweeps the next beacon. Got that? Just let me know if you have any questions, because you can always just throw up your arms, blame the catering company and not fly. :-) )

    Sorry, Harden. That last part was unfair...just my frustration talking. None of this is your fault, and I applaud you for the help you've given.

  • uskrums Level 1 (10 points)

    I also have given a dedicated IP address to my printer as was discussed earlier by Oz, but still have the communication problems. I am hoping that manual add that was given by Harden Long (nice!) will work. So far so good. For the non tech savy, some basic info and screenshots:


    First, you have to go into the menu of the printer and enable LPD. Follow Harden Long's instructions.


    Second, you have to give a dedicated IP address to your printer. Depending on your router, this could be different. However if you click on the airport utility (found in the Applications folder/Utilities)Screen Shot 2013-01-23 at 6.34.31 PM.png

    Once you click on that, it will show your router. I have an airport extreme, so your screen may look different. When I edit the Airport Extreme, it looks like this:

    Screen Shot 2013-01-23 at 6.35.19 PM.png

    Click on Network and you will see this:

    Screen Shot 2013-01-23 at 6.41.42 PM.png

    I have made a DHCP reservation outside the normal DHCP range of my router. Routers assign IP addresses randomly in the range...Oz had said creating a permanent one would help in communication. All I did was hit the + button, assign an address 1 above the range and name it.


    Next, you want to go to the Settings icon and click on it. You will see this:

    Screen Shot 2013-01-23 at 6.35.56 PM.png

    Click on the Print&Scan and you will see this:

    Screen Shot 2013-01-23 at 6.36.32 PM.png


    If your printer is already listed, hit the - sign. Then hit the plus sign to add it. The pop-up will be:

    Screen Shot 2013-01-23 at 6.36.46 PM.png

    My printer is already listed. You should se a blank. Click on the IP icon:

    Screen Shot 2013-01-23 at 6.36.58 PM.png

    Select Line Printer Daemon - LPD. In the second line, put the DHCP address you put in in the steps above. Under 'Print Using' scroll to 'Select Printer software' and then select Canon your model name.....

  • Harden Long Level 1 (0 points)

    ROFL... Harden. I love that someone actually adressed me as Harden. Can I tell my wife Norma you send regards? :-)


    1) You use the little click-wheel thing on the printer to navigate to the settings menu. Under there there's something like LAN Settings and/or Other settings - can't recall off the top of my head. Anyway, you want to pick the "manual" option for configuring the network setting. It then prompts you for an IP address, Gateway, etc. (All of this info is in the Canon manual.) As you've pointed out, however, if you don't know what IP addresses and Gateways are this is not likely going to help you.


    2) DHCP: All consumer-grade routers provide DHCP. This is what saves you from having to know about #1. Good routers allow you to configure their DHCP server to doll out the same IP address to a particular network client every time it requests one. In this way that client ends up with a static IP, but all the configuration is done on the server (router) rather than on the client (printer). All network clients/devices/appliances have a unique identifier that they present to the network called a MAC address: Via the same settings menus on the printer used to configure other networking features you can see the MAC address. It is usually also printed on a sticker on the bottom of the device. On the router end, you'll then configure DHCP so that it always gives the client with that MAC address an IP address that you specify. e.g. See:


    The Apple Airport Extreme is one of the better routers that support static DHCP. If you have that, google and you shall find the howto. In my case, I have an older Buffalo router running the open source firmware dd-wrt:


    With me so far? So you have to choose between option 1 and option 2. In either case you have to have some basic understanding of how your network is configured, and how it works. There is no easy button for this stuff - it was designed to do things for universities, businesses, and governments. :-) The fact that we can all affordably have home networks and wireless network appliances is AMAZING, and companies like Apple are developing software to make it all as maintenance free as possible. See:


    3) - this is not for you, trust me.


    Here's something to consider next time you have some cash burning a hole in your pocket... the newest Airport Extreme routers ($130 refurb or $170 new) support USB printing. Plug the printer in to one of those and you have wireless printing. Better yet, pair your new router with one of the many new printers that support Air Print and Google Cloud Print.


    Sorry if none of this helps the layman, but there's good reason Best Buy and Staples are able to [over]charge ludicrous fees to "fix" computer issues. While in line at the latter the other day I listened while an older women scheduled a "techinician" to come to her home to install the printer she was buying... for a $100 "I showed up" fee PLUS an hourly rate. Holy crap! I almost offered to just follow her home and do it for free, but had my own stuff to tend to.


    To sum up for the tech savvy: LPR is the workaround to this bug.

  • Harden Long Level 1 (0 points)

    OK, here's a solution for those non-techy types. Replace your router with an Airport Extreme and plug the printer into its USB port. Viola! A working Bonjour printer.


    OK, that solution will run your $170, but it's a phenomenal router. My Cisco e4200 P.O.S. is headed for fleaby. That thing was flaky as flaky can be.

  • mik194254 Level 1 (0 points)

    As a UK resident some of the answers (etc) for this problem do not seem relevant.


    I have had this problem since acquiring my Canon MG6250 printer. I get the communication error form my iMac but it is not all the time; furthermor I have never had the problem when accessing the printer wirelessly from my iPad, MacBook Pro, my wifes iPad, my iPhone or my wifes iPhone; that suggests that the problem is definately something to do with the iMac. I find that when the problem occurs I simply "pause Printer", "resume Printer" a few times and eventually it bursts into life.


    My broadband supplier is British Telecom who provide a very good router which gives me good wireless coverage and if fact the iMac is literally 3 feet away from the router anyway (so no wireless degredation problem). Following one of the suggestions in this chain I ran the AirPort utility which indicates that I have Internet connection but also has a message which indicates that "No configured AirPort base stations have been found" - so can't do much with that. I have allocated a static IP address for the printer from my router (i.e. via DHCP server) but that doesnt seem to make any difference.


    I believe that the problem occurs when the printer effectively goes to sleep and the iMac can't wake it up. If I force the printer out of its sleep condition then it only takes a couple of pause/resume cycles to communicate successfully. I re-iterate that this is NOT a problem from other devices using the printer wirelessly so it can't be a problem with either printer or router. This has got to be something to do with the hand-shake mechanism between iMac (or OSx - incidentally I am on 10.7.5) and the network (i.e. not necessarily the printer)


    From this analysis (and I should mention that I have been in the computer industry principally on Mainframe system for 42 years as Systems & Software Engineer & Project manager) the problem seems to rest at Apple's door. I have also been to the Apple Shop in london and discussed this with the "genius Bar" which puts me in mind of the joke on Big Bang Theory where Leonard announces their sport of making fun of the Genius Bar guys (sorry Apple...)

  • davej00 Level 1 (0 points)

    I agree that it seems related to the printer sleeping. If I open a terminal window on the mac, and ping the printer ... Using the ping command

    , then resume the print queue it usually works.

  • thechao Level 1 (0 points)

    I did some tests with the MP560 sitting 18" away from my airport express, and some tinfoil.


    • My mp560 is at IP address:;
    • I use the ping utility from the terminal to ping the address; note: at all times ping can resolve the printer's address;
    • When the ping is < 2.5ms, the time to recognize the printer after restart with a fresh driver install is <10s;
    • As the ping beings to creep up to 10ms, the printer recognition time slowly creeps up to the several minute range;
    • Once the ping time is >10ms, or packet loss >25%, the resolution time of the printer effectively goes to infinity.


    So, essentially, to address connectivity robustness issues, you need to make sure the ping time is <10ms, and packet loss <5%.


    I can't quite narrow down the exact "cross over" time, but having written network-capable drivers, 10ms is a fairly common number to use for "give up"; 10-20% is a common range for packet-loss driven "give up times".


    So, how to fix the problem? Move the printer near enough to your access point that ping times are <10ms and packet loss is <5%.

  • uskrums Level 1 (10 points)

    My printer has always been on the same desk as my Airport Extreme. Still has problems.

  • NichoTL Level 1 (5 points)

    What do you mean 'the same desk as my Airport Extreme'. Is the printer plugged into it? via USB or via Ethernet?

Previous 1 6 7 8 9 10 11 Next