Previous 1 7 8 9 10 11 Next 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 Go to original post
  • robolz Level 1 Level 1 (10 points)

    I have the same situation a Uskrums.  Even with the WiFi router a few feet from the printer, I still get the problems (not all the time, but often).


    I would plug my printer (Canon MP560) straight into the network, but it is WiFi only, and does not have an Ethernet socket...


    NB: I have taken all the steps previously recommended in this discussion, but these have not resolved the issue.

  • NichoTL Level 1 Level 1 (5 points)

    Well the problem is not a WiFi problem so the physical location shouldn't have an effect on the issue. From what I have read so far, plugging the printer via network (ethernet) cable shouldn't solve the problem either. The issue might lie (as said before) with the discovery protocol: Bonjour/Zeroconf. Personally, I haven't tried changing from Bonjour to Direct IP printing, but that is an interesting thought.

  • uskrums Level 1 Level 1 (10 points)

    Mine has always been Wifi because I once had 3 PCs and a MPB on top of the mini sitting in the office. Now I am down to 2 PCs, but mainly just the Mini and the MPB print off it. You can see my screen shots above, I've set eveything up accordingly. But it still gets communication errors. I think it has to do with sleep/wake mode. But, pause/delete job/unpause/turn printer off&on always works. Pain and I will definitely do my homework before my next printer. (this one was bought before I had started converting to Macs)

  • NichoTL Level 1 Level 1 (5 points)

    I don't dispute that you get errors while connected via WiFI (I do too), but what I am saying is that it's not the WiFi connection itself that's the problem. Anyone connected via ethernet care to chime in?

  • Ron R Level 2 Level 2 (320 points)

    I have an MX350, that has wifi and ethernet.  I had been connected via wifi for a year or so, occasionally getting the "commmunication error".  Played around with all the fixes. it would work fine for quite a while, then there it goes again.  so, since the printer is now about 2 feet away from the router, about a month ago, I switched to a wired connection.  no errors so far. will give periodic status updates.

  • Harden Long Level 1 Level 1 (0 points)

    Enabling LPR fixed my issue as stated further up in the thread, but no sooner did that issue go away than the stupid thing started jamming on every job. Argh! Took it apart, cleaned it, put back together and it still eats paper. In the landfill it goes... with a full set of new ink cartiriges. I guess one can't expect to get more than 5 years from these things.


    Oh, well. I picked up an MX892, yesterday, so my son could print out his homework. I plugged it in to ethernet. (Wish the MP560 had had that option.) So far it is a very nice upgrade. AirPrint is wonderful. The document feeder is, as well. Scanning is much, much faster, possibly due to wired ethernet vs. wireless. (Though I did replace my Cisco e4200 with an Airport Extreme at the same time, so who knows why?.) No regrets, and so far no frustration.


    I did look long and hard an a few Epson and Brother inkjets, but in the end it was Canon's software that lured me back. The remote scanning, especially, works just too well. (By comparison, you can't even scan from the scanner to a computer with an Epson - scanning has to be initiated at the computer, which means more walking back and forth. With the MX892 Canon added scanning memory so that hitting the button will, by default, remember your last scan destination. Great enhancement and a time saver, too.)


    Oh, the MX892 is bigger and heavier. It requires more room for sure.

  • amylevin Level 1 Level 1 (0 points)

    Hi there

    I have posted before but I want to reiterate that I continue to have this issue with my Retina MacBook Pro (OSX 10.8.2) printing to a Canon MX870 AND an Espon Workforce 645. Inevitably some combination of manually waking up the printer, powering the printer on and off, pausing and unpausing the queue, or re-starting my computer tends to fix the issue and eventually my queue will print. Most of the time my printing is not urgent. The Epson is right next to me at home, at my office I have to walk across the office to the Canon so mildly annoying if it happens 3 times an hour. I haven't tried any of the fixes posted here because they all seem to working under the assumption that it is a Canon issue but I just got (another) communication error from my Epson when I tried to print.

    So, my fairly novice opinion is that this is still an Apple issue. Also in my layman, farirly tech savvy but not highly technical opinion, I can't understand how this could be Canon's issue if Apple insists that we use the Apple drivers that come with the OS. It's so frustrating that this has not been fixed. This has been going on for at least a year? Maybe two?


  • WinterHawk1344 Level 1 Level 1 (0 points)

    I just solved a similar problem.  I just moved, and restarted my network in my new home.  While the computers (Mac and Windows) both logged onto the LAN without issues, the printers (HP and Cannon) did not. 


    When I went through the network set-up process on the printers and logged onto the network (with passphrase), everything was back to normal, and I could successfully print again.

  • emw2013 Level 1 Level 1 (0 points)

    I'm struggling here

    I have Macbook Pro, and wifi


    I have set up Canon pixma MG5250 to print via wifi - worked fine for a few weeks.

    Then Christmas Eve I got "communication error"

    and I haven't been able to connect via wifi or usb cable since.


    On the advice of a previous poster I deleted the printer from my MacBook, I've reset the Lan Settings.

    I've gone through the entire set up again, put in the wifi code, installed the disc and i get the same result - the computer can't find the printer.


    I turned off the wifi got a usb cable re set up again, and still no luck - even with the usb cable attaching the printer to my computer the computer can't see the printer!

    I now have a very expensive oranment in my home office and I have to go to the local internet cafe to print my documents !!

    My husband has a macbook also and experiencing the same thing


    Any magical solutions - If I can find the receipt I will return the printer ....

  • davej00 Level 1 Level 1 (0 points)

    The fact you cannot connect via USB is a bit scary. That implies broken printer to me (assuming no issue with the USB port on your mac)

  • emw2013 Level 1 Level 1 (0 points)

    well usb port works fine for other stuff

    but printer seems to be ok, in that there are no error messages.. and all the correct lights are on


    its just seems that it's invisible and I can't get the laptop to see it. its so fustrating 

    I replaced my espon stylus printer with the canon as it would much better and now ive nothing

  • NichoTL Level 1 Level 1 (5 points)

    Is your printer otherwise responsive? I mean, is the menu working? Can you turn it off (I mean by pressing the on/off button)?

  • emw2013 Level 1 Level 1 (0 points)

    yes I have turned it on and off, and I got it to print out a page of the wifi settings from the printer menu (on the printer)

    From another thread somewhere - there is something about setting a static IP address for the printer and that should solve it .. so am about to google how to do that and hope it works

  • patties passion Level 1 Level 1 (5 points)

    I have a MP560 canon printer and also got the error.  Have mine set up usb, could never get the wi-fi to work.  I was printing out some ruled paper that is in the printer menu at the time. . Now my printer won't turn on at all.  I did the update through apple but didn't think it would do any good since my printer won't come on and is listed as offline.  I just figured canon wanted everyone to buy a new printer from them..  Very disappointed since this is my 3rd printer in 6 years. 

  • mik194254 Level 1 Level 1 (0 points)

    Having had this problem with my MG6250 since purchase and following all the recomendations in this discussion to no avail I had given up and just decided to put up with the problem. However I have just purchased the Apple Time Capsule which replaces my BT router (UK ISP) and lo and behold the problem is now fixed. This tends to suggest that the problem of "waking up" the printer is in fact down to the router (albeit could in fact be the wireless handshake mechanism between iMac and Router or Printer & Router) - so I suggest as Apple would probably recommend get yourself a Time capsure of possibly Airport Extreme.