Previous 1 7 8 9 10 11 Next 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 Go to original post
  • ldamario Level 2 Level 2 (175 points)

    I don’t know if this is the solution, but it has worked for me for about a full week now. I almost hesitate to post this information, because many solutions have been proposed in the past that get people’s hopes up, but eventually do not hold up. In any case, here goes. I purchased a Canon MX892 in October 2012. My Apple MacBook Pro (OS 10.6.8) and the printer are on a wireless network provided by my ISP. After several months with no problems, the communication error problem started happening. It got to the point where this was happening many times each day. The only surefire solution was to delete the printer and add it back. But this was only a temporary solution, and the problem always started up again. I scoured the online discussions groups relative to this problem, and I found one suggestion that so far has worked for me. What I did is a two-part process. The first part is as follows:

     

    1. With the printer turned on, disconnect the power cord from the wall socket. Wait 30 minutes. This may be a longer wait than necessary. I think the suggested time was 10 minutes, but I waited 30 minutes to be sure.
    2. Plug the power cord back in. You will see an error message. Ignore this. I think you have to press “OK” on the printer control panel or something like that to return the printer to normal operations.
    3. Turn the printer off from the control panel. Wait 30 minutes. Again, you may not have to wait a full 30 minutes.
    4. Turn the printer back on.

     

    The second part has to do with custom printing profiles. On a Mac, when you print a job, you can select from various preset printing profiles. These are shown in the “Presets” dropdown menu. See included screen shot below.

     

    Screen shot 2013-03-03 at 10.36.53 AM.png

     

    I was always in the habit of creating multiple printing profiles for things like printer quality, two-sided vs. one-sided printing, etc. After I performed the procedure described above, I did not do this. I have been using only the default supplied list of printing profiles, and I have been adjusting quality, two-sided vs. one-sided, etc. manually from the dropdown menu immediately below the Presets menu. I don’t think this has anything to do with eliminating the communication error problem, but I thought I would mention it.

     

    So far I have not had an occurrence of the communication error problem for more than one week, as compared to seeing it multiple times per day. I would be interested in hearing whether this works for anyone else. 

  • LTParis Level 1 Level 1 (0 points)

    uskrums wrote:

     

    I also have given a dedicated IP address to my printer as was discussed earlier by Oz, but still have the communication problems. I am hoping that manual add that was given by Harden Long (nice!) will work. So far so good. For the non tech savy, some basic info and screenshots:

     

    First, you have to go into the menu of the printer and enable LPD. Follow Harden Long's instructions.

     

    Second, you have to give a dedicated IP address to your printer. Depending on your router, this could be different. However if you click on the airport utility (found in the Applications folder/Utilities)Screen Shot 2013-01-23 at 6.34.31 PM.png

    Once you click on that, it will show your router. I have an airport extreme, so your screen may look different. When I edit the Airport Extreme, it looks like this:

    Screen Shot 2013-01-23 at 6.35.19 PM.png

    Click on Network and you will see this:

    Screen Shot 2013-01-23 at 6.41.42 PM.png

    I have made a DHCP reservation outside the normal DHCP range of my router. Routers assign IP addresses randomly in the range...Oz had said creating a permanent one would help in communication. All I did was hit the + button, assign an address 1 above the range and name it.

     

    Next, you want to go to the Settings icon and click on it. You will see this:

    Screen Shot 2013-01-23 at 6.35.56 PM.png

    Click on the Print&Scan and you will see this:

    Screen Shot 2013-01-23 at 6.36.32 PM.png

     

    If your printer is already listed, hit the - sign. Then hit the plus sign to add it. The pop-up will be:

    Screen Shot 2013-01-23 at 6.36.46 PM.png

    My printer is already listed. You should se a blank. Click on the IP icon:

    Screen Shot 2013-01-23 at 6.36.58 PM.png

    Select Line Printer Daemon - LPD. In the second line, put the DHCP address you put in in the steps above. Under 'Print Using' scroll to 'Select Printer software' and then select Canon your model name.....

    This solution worked for my MX870.

  • PaulaVF Level 1 Level 1 (0 points)

    I'm joining the chorus: MacBook Pro OS 10.8.2 with Canon MP560.  Works great with my Dell PC, but communication errors ever since I upgraded to Mountain Lion.  Arrggg!

     

    This solution worked marvelously for me, PAHU.  I can print wirelessly once more, however, I can't scan.  I only have my Canon MP560 series showing as a printer.  When I click +, the only thing that pops in in the Canon MP560 series (Kind: Canon IJ Network) again, no scanner.  How do I get scanning capabilities back?

  • PaulaVF Level 1 Level 1 (0 points)

    I got my scanner back .  I saw someone else had the same problem as me, so here's what I did.  In order for my Canon MP560 scanner to appear in the System Preferences, Print & Scan, + (add) window, I worked with the menu on the Canon.  I chose Scan, then came back to my MacBook and clicked + (add) in the Printer window.  That wasn't working before, but with the Canon menu showing the Scan function, it did work.  I was then able to select Canon MP560 series Scanner and it works.  I guess I am about as happy as all of the previous posters to have things working right now, but I sure am braced for more problems.

     

    Apple, please fix this!!!!!

  • deepwapiti Level 1 Level 1 (0 points)

    Setting my printer to print via LPR/LPD seemed to be the lasting fix for me.

     

    The only problem is that I can't get ink details or know when the printer needs attention, e.g., out of paper or low in ink. Is there any way around this?

  • kschestag Level 1 Level 1 (0 points)

    Thank you for this post! After months of having this problem, I found this thread and fixed it! THANK YOU THANK YOU THANK YOU

  • ejh4isu Level 1 Level 1 (0 points)

    I bought a Pixma Pro 100 and I've been troubleshooting the error 306 for a few days now.  I've read every reply in this thread and tried every fix...twice.  I'm still getting the 306 error during printing (and wasting expensive paper and ink in the process.) Should I just give up and connect it via USB ? Right now its wireless via my Airport TimeCapsule.  Connecting to the airport via LAN isn't possible due to setup location, but I could just plug it in USB (which would be a pain, but I guess a work around).

     

    I'd hate to return such a nice printer over something so stupid.  I've restarted everything, repaired permissions (and there were a TON that got repaired that had to do with Canon files )...I'm just very frustrated.  If there's anything else I could try, I'd love to hear it.

  • DocG Level 2 Level 2 (300 points)

    Had same issue on Pixma MG3250 on WiFi

     

    Goto Printer configuration by typing in the printers IP address in Safari

     

    If you don't have this you can find it by first going to your router config page by typing it's admin IP address in Safari (see your router manual) and find any WiFi devices connected. The router will tell you your IP address of the wireless devices connected.

     

    If your Printer isn't connected try resetting the router and try again.

     

    Once you have the Printer IP address enter it in Safari

     

    Change the network settings of the printer.

     

    Use a fixed IP address (e.g. 192.168.1.10 etc) and make a Bookmark of this. Sometimes you can "jolt" the printer into life by clicking on its config page IP address. The BT Home Hub 3 has a particular issue with dropping wireless devices and this may help.

     

    Change the encryption the printer connects to the network with to WPA / TKIP if you have this option.

     

    So far this seems to have solved my problems and the wireless connection to my BT Home Hub 3 is stable.

  • uskrums Level 1 Level 1 (10 points)

    Well, our printer gave us the B200 error and I finally had had enough. My solution was to buy an Epson. Setup was flawless. No more problems.

  • loriloui Level 1 Level 1 (0 points)

    OK, I had the very same problem and found that it was actually related to my firewall (which, following a hard drive failure and subsequent re-boot/formatting at the genius bar was set to block all traffic - unbeknown to me!).

     

    I solved the problem by going into the security preferences, firewall and then changing my settings to:

     

    "automatically allow signed software to receive incoming connections."

     

    I realise that many of your issues are more complex and require a different fix, but for those of you out there who have had no success then perhaps it's worth a try.

  • brad_at Level 1 Level 1 (0 points)

    I was having internet speed issues so I reset my router configuration to Channel 1 (from Automatic)

     

    As my iMac received this Support code 300 error pretty well soon after - I reset my Routers Wireless Access Point to a more standard Channel 11

     

    The printer kicked in immediately!

     

    Hope it helps

  • PMJ61 Level 1 Level 1 (60 points)

    I have had same reported problem with MG3250.

     

    It worked at first, but then would only print the first line of a document and got the 306 error when using Wifi.  Works fine via USB.

     

    I tried a lot of the above - delete/respecify; fixed IP; turn off and on; reboot Mac.

     

    What seems to be working today is reinstall of the printer driver. I downloaded 10.67.2 from the canon site installed, then deleted the printer from System Preferences and selected it again (I think I chose Bonjour rather than Canon IJ network,  though I have no idea what the significance of either is).

     

    I'm just wondering whether I picked up a spurious software update.  One kicked off the night after installing the printer and I thought I say 10.72.1 or something like that somewhere.

     

    Mac: Intel iMac Core 2 Duo (late 2006); OSX 10.6.8

    Router: Netgear DG834G (b/g Wifi, not n)

  • PMJ61 Level 1 Level 1 (60 points)

    Further to previous.

     

    Problem recurred, though now the driver is not reporting a communication error, it just doesn't print the whole document and hangs in the print queue.

     

    I talked to Canon support. Their first suggestion was that the WiFi signal was inadequate (it was around 60%).  I moved the printer to within 2m of the router with a clear line of sight. Same issue.

     

    Meanwhile the printer will work from my iPhone.  ie, the connection between the router and the printer is adequate. The second operator suggested I talk to my "network provider" to improve the WiFi signal.  We had a difference of opinion about whether my ISP had anything to do with the WiFi performance (and no - the router is not supplied by the ISP in this case).

     

    I also pointed out that when the Canon would only print the first line when it was 2m from the router, the HP Deskjet downstairs was able to print OK.  I was told it couldn't be a problem with the driver as it would not send any data at all if it was the driver.

     

    Now waiting to hear back from Canon support.  I have said the printer will go back if I can't resolve within a reasonable timescale.

  • PMJ61 Level 1 Level 1 (60 points)

    WiFi signal strength is a complete red herring.

     

    I have now followed this excellent post from about 5 pages back:

     

    https://discussions.apple.com/thread/2708074?start=65

     

    What struck me here was the problem of having multiple connection routes.

     

    The key to getting this working for me was that the printer will get some kind of network error printing over WiFi if the Mac has  its LAN cable connected

     

    With the LAN cable in, the printer will still work off the USB connection, but not WiFi.

     

    It will also print from another Mac which is out of range, either connected through the LAN cabling, or (contrary I think to the printer user manual) through a WiFi extension network.

  • Richard Laycock Level 1 Level 1 (55 points)

    This is all speculation.  The fact is, as usual, Apple's printing to Windows is screwed up.  In this case I think the blame is on the Open Source CUPS program and their lousy 1.7 update for Mavericks.  The threads make it pretty obvious.  As for the LAN or WAN or Wi-Fi.  Printing doesn't work on my Mavericks laptop wi-fi to three Canon printers on Mac 10.5, 10.6 or Windows XP.  And, no, while there's a mix of ethernet and wi-fi there are no multiple connections involved on any single unit. Not that it should make any difference in our century. That's what we call a NETWORK.  

     

    This isn't anything new.  Most Mac upgrades take MONTHS before they will reliably coexist with Windows.  It's always been a pain to upgrade since Win 3.1 and 95 right up to today.  Apple has always made the difficult easy and the easy **** near impossible.  Printing is their worst feature.  CUPS is total geek bs compared to printing on Windows 7 or 8.  Printing is possibly Microsoft's best feature.  Go figure.  Starting with Next to Mavericks the Jobs team has yet to make network printing work like the rest of Apple's software. 

     

    When the heck are they going to get it right?