Skip navigation

Canon MP560 "A communication error has occurred"

113111 Views 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 RSS
  • Funderburko Calculating status...
    Currently Being Moderated
    Jul 15, 2011 4:50 PM (in response to Funderburko)

    Btw: Scanning via wireless connection is a-okay -- the communication error happens just with printing.

     

    Furthermore, I think the "trusty" on-&-off trick just failed me, and I think it's failed me before but I just thought I forgot a step in it -- eg, if the job's still live in the queue, need to kill it or pause the printer and then do the on-&-off, then send it again.

     

    It's a driver thing, ain't it? Maybe I do need to do the de-install & re-install, but I think that's BS too... Dangit.

    I'm gonna do it and then find out I don't know what I'm doing and have a sh***y time figuring it out all over again...

     

    It was awesome, the day I established wireless printing, like a new home office era or something.

  • Mugendai Calculating status...
    Currently Being Moderated
    Aug 30, 2011 11:55 AM (in response to Funderburko)

    I had this problem with 10.6.6.. reset the LAN settings on the printer and reset the printer settings on the mac and my MP560 worked again, but then I updated to 10.7.1 and the whole this is buggered again and no ammount of resettings ( I have done 3) has worked.

     

    What is it with this good yet infurriating multifunctional. It is now 2 error messages away from the window!!!

  • ian24 Calculating status...
    Currently Being Moderated
    Sep 3, 2011 1:56 AM (in response to Mugendai)

    Same problem with a Canon mx870.  On/off or resetting things only seems to be a temporary fix...

  • loliloli123 Calculating status...
    Currently Being Moderated
    Sep 4, 2011 11:49 PM (in response to PAHU)

    I hit the minus to take the mp560 link out then it didn't show back up in default, and nothing is showing anywhere else either, how do I link my mac back up to my printer?

  • MostlyNuts Calculating status...

    I have had both my mac and mp560 for more than a year and I get this problem every week. Reseting the printer helps sometimes and deleting and readding does a swell. The real problem is that this is getting OLD! I hate having to troubleshoot everytime I want to print something.

    Does either Apple or Canon have any REAL solutions yet?

  • sbhabyn Level 1 Level 1 (0 points)

    Same here. MP 560 connected to iMAC 10.6 via USB and a second iMAC via wireless link. All worked perfectly well for months, then 306 communication error. Fixed via system preferences >print/fax and used the reset printers option. (Right click over name of printer.) All is now well. You do, of course, loose all those special print settings so lovingly created, but a small price to pay for it working again.

  • The_Hawk79 Calculating status...

    I'm running a MBP and have always kept the latest OS and updates.  I used to have an MP640 that had this problem, the upgraded to a MX870 which has only recently started showing the same issues.

     

    In both cases I am using ethernet to connect the printer to a TimeCapsule and WiFi to connect the MBP to the same TC.  It's a real pain the bum that this doesn't work all the time, the whole point of a network printer was so I could print from multiple machines without having to screw around.

     

    I will note that in my case, when the printer doesn't work, the scanner doesn't seem to show up in Image Capture or in Acrobat for me to scan stuff either. 

  • LMarine Calculating status...

    I've tried all of these "cures" and nothing has changed. My MP780 worked fine for years and then with this latest software update, wham... problems. The only thing that works is to connect it to the USB port on my MacBook Pro.

     

    Another thing that has popped up, too, is that I get banding in my color prints. B&W seems fine, the test page printout is fine, but printing color from any source results in 1/4 inch bands of horizontal color offsets. Weird.

     

    All this since that latest "update."

     

    C'mon Apple, that's a Microsoft kind of mistake!

  • henrysantacruz Calculating status...

    Me too. MP560, Snow Leopard. Does anybody get this problem on Lion? I'm thinking about upgrading to see if that helps since nothing else seems to. Must be an Apple problem since no one seems to have this problem from Windows. Does anyone know which update started the problem?

     

    Also, unplugging and restarting the printer seems to work for me. Sometimes I have to do it twice. I'm sure the 10 minute unplug is unnecessary. If it doesn't work the first time just try again. Not that we should have to do this at all.  Google "xkcd Wisdom of the Ancients" for a bit of web humor that anyone reading this thread will relate to.

  • henrysantacruz Level 1 Level 1 (0 points)

    Sorry, just noticed that mugendai had the problem on 10.7. I guess I won't bother with the upgrade. Sigh.

  • nurseratchit Calculating status...
    Currently Being Moderated
    Nov 20, 2011 10:36 PM (in response to sheffdog)

    this suggestion worked for me, thanks!

  • tomandsherri Calculating status...
    Currently Being Moderated
    Nov 24, 2011 6:28 PM (in response to sheffdog)

    Thanks sheffdog - this was very helpful. FWIW I found that I started having a problem when I updated the firmware on my Airport Extreme to v.7.6. It was not finding the printer - so I had to go back through the LAN setup process on the printer to get it the network to recognize the printer again. Once I did that and reinstalled the driver (not using the Bonjour printer per your suggestion) it worked. Thanks again!

  • RonfromBroughtonAstley Calculating status...

    Yep, me too!  Exactly the same problem!  Canon MP560......driving me crazy!!!  Off, on, off, on!  Now it's quit completely.  I will try all of your suggestions, than you for talking about them online - very reasuring that I'm not a complete techno-divvy!

  • uskrums Level 1 Level 1 (10 points)

    Me as well. Constant problem that seems to fix itself at times if I turn it off and on or reboot the computer. Mainly occurs when trying to print from a website. Driving me crazy. Wish they would fix it, but instead they will both just point fingers at the other....

  • Eclipse97z Calculating status...

    I referred to sheffdog's rememdy, but to no avail I still have the same problem.  Like you, I had my MBP not recognizing my Canon MP560 on my Airport Extreme until after the firmware update to 7.6.  Before this, I had no problems.  I followed the instructions EXACTLY as he stated and even resorted to yours--by not selecting the BONJOUR driver.  But now, I'm not getting that either. BUM

1 2 3 4 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.