Previous 1 2 3 4 5 Next 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 Go to original post
  • kloughman Level 1 Level 1 (0 points)

    Good Evening,

    I have been having this same problem now for months ~ probably as long as 6 months! I also have a Macbook that I have had for about 4 or so years and a Canon MX870 that I have had for well over a year (most likely two years now) and they have worked perfectly until about 6 months or so ago. I am going crazy with this! I have not done "reinstall" route yet, but after reading the posts here I am not sure that I will since it doesn't seem to be making any difference to anyone. This is frustrating to me since all of the computers in my house are Macs, and the only printer I have now is not working.....

  • explorz Level 1 Level 1 (45 points)

    Me too!  Mx870.  Happens with both my iMac and my Macbook Pro.

     

    Turning the printer on and off still fixes it for me.  I have reinstalled drivers, deleted and added the printer, reset the LAN setting on the printer.

     

    I am connecting to the printer wirelessly.  This is a serious pain in the butt.  I think it startd with the Airport 7.6 frimware update.

  • LastLion64 Level 1 Level 1 (0 points)

    I just deleated old one and installed new drivers

  • airatic Level 1 Level 1 (0 points)

    Same problem here - printer worked fine until a couple days ago, suddenly this communication error and I can't print at all. It is COSTING ME MONEY!! I print shipping labels via USPS and without the ability to print, I pay over 80 cents more per package! That's my entire profit margin on some items

     

    Why hasn't this problem been fixed? It looks like many people have the same complaint.

     

    I tried all the reasonable sounding solutions here, and all I got was the inability to even find the printer anymore.

  • uskrums Level 1 Level 1 (10 points)

    Keep getting the same problem. Each time I have to pause the printer, delete the jobs, resume the printer. turn it off and then back on. Then it will print fine for a few hours or even a day or so. But always seems to reoccur. As long as I keep doing the above steps, I can continue to print, but it's a pain.

  • kitebuggy Level 1 Level 1 (0 points)

    Possible fix:

     

    Check your firewall settings.  Under Lion, signed software needs to be allowed to accept incoming connections, else the Canon drivers/software cannot receive the WiFi communications and the network error message will pop up.

     

    This drove me mad all morning till I found the fix, now working perfectly.

     

    Good luck,

     

    Jason

  • bristlybadger Level 1 Level 1 (5 points)

    Usually, I've been able to fix this issue by re-entering the WEP key on the printer. But this time that's not working.

     

    The communication failure occurred immediately after I installed the latest version of OpenOffice 3.3.0 (Build 9567) on OS 10.6.8, and I suspect this may be a related issue. OpenOffice itself is unable to establish a network connection for automatic updates - I have to download them manally.

     

    Is anyone else with this problem using OpenOffice?

     

    I had to turn the firewall off to find the printer (which was listed both as a canoninjet connection and under Bonjour, so I chose the canoninjet option. It's now working again.

  • horsebitten Level 1 Level 1 (0 points)

    Thanks PAHU, your Jan 5th 2011 solution worked for my MX876.  Deleted the printer by clicking Minus icon, then added it again using the Plus icon.

  • bristlybadger Level 1 Level 1 (5 points)

    In addition to my earlier comment, I've found that I have to keep turning off the Firewall to access the printer. I just turn it on again afterwards. Not ideal, but it works.

  • robolz Level 1 Level 1 (10 points)

    I have had countless problems with maintaining connectivity to the Canon MP560.  Most recently, today, I had the problem that I could scan (using ImageCapture) but I could not print via the "canonijnetwork" driver - on this occasion resetting didn't help, but the trick of removing the printer within the Apple Mac settings and then re-adding the same printer and driver did work.

     

    I try and support 3 Macs in my home trying to print to this computer.  I can't expect the other members of my family to go through a routine of "removing" and then "adding" a printer just in order to print.

     

    I have tried the Bonjour drivers, which at some time have worked (but not recently with my Apple Lion setup).

     

    Does anyone know a way to get Canon to fix this?

  • MediumRare Level 1 Level 1 (0 points)

    I have an MX340 and have been having the same problem every couple weeks or so.  While removing the printer and re-adding it (-/+) have worked in the past, I tried something new today which also worked.

     

    First I paused the printer (via the print queue).  Then I turned off the wi-fi on my laptop, waited a minute and then turned it back on.  By restarting the printer (via the print queue) the file waiting to print started. Solved.

     

    By the way, I also noticed that my network hard drive had disappeared from Finder, and then reappeared once I restarted my wi-fi connection as described above.  It's weird, because I had an internet connection the whole time, but there miust be some strange workings of the home network here.  Interested to hear if this works for anyone else.

  • TommyCanuck Level 1 Level 1 (0 points)

    Like everyone else, I having been having the same problem for about six months. Prior to that, no problems. Removng and adding the printer works, but it is only temporary. The error will reappear again. I would second airatic's question above:

     

    WHY HAS THIS NOT BEEN FIXED? Apple  - you have been giving out these printers with your Macs. I don't care whose fault it is, just fix it! I switched to Apple because I was tired of problems like this with Windows!

  • mcoburn71 Level 1 Level 1 (0 points)

    I have a Canon870 and this same problem happended to me today.  Worked fine up until this month.  I deleted the printer from the Print & Scan screen and added it again.  Printing wirelessly works again.  Hope it keeps working!

  • uskrums Level 1 Level 1 (10 points)

    Don't worry, it will return. Been dealing with this for more than a year and a half. I've deleted and reinstalled, I've adjusted the firewall, etc... Still is a problem

     

    Good news is the whole family is aware that when it goes into this funk you need to :

     

    Pause the printer

    Delete all jobs

    Turn the printer off

    Wait 10 seconds

    Turn the printer on

    Unpause the printer

    Print normally.

     

    So very Windows-like.

  • Retireland Level 1 Level 1 (0 points)

    I'm really looking forward to a solution to this. I'm in an apple office, I have one on my desk but the laggard I am means I run a HP Compaq windows laptop on my desk also (yes I have iPhones, pods and pad) that prints every time to our Canon MX870. The people that actually do the work in the office want a new printer brcause they have to turn off the printer for most prints. In the meantime they have spect nearly a thousand dollars on visits from the tech guys that reload the drivers for a short term fix. I guess ill have to buy another brand of printer but I wonder however what brand of printer actually works well on a wireless Mac network?

    The HP Compaq set up the printer so incredibly seamlessly that I bought two more for the family - we run the MX870 at home also and I don't want to buy problems.

    Can you imagine the number of people that read these posts without posting themselves - there are a lot of bugged people out there - hopefully an Apple person will read our posts one day and we get an email with a solution link.

    We live in hope.

Previous 1 2 3 4 5 Next