Previous 1 2 3 4 5 6 Next 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 Go to original post
  • tymcode Level 1 Level 1 (0 points)

    I'm getting this all the time now with my Leopard and Snow Leopard Macs and my MX340.  Deleting and reinstalling the printer works for a while but not for long.  Turning the printer off and on also works but that's a hassle.  I keep installing Canon printer updates through Apple Software Update thinking "Finally!  They HAVE to have fixed it now!"

     

    But no.

     

    I regret buying the Canon.

  • bristlybadger Level 1 Level 1 (5 points)

    I've found a solution to this problem on my Mac which is running 10.6.8

     

    I was looking in System Preferences > Accounts > Login Items (right tab), when I noticed something to do with Canon in the list. I hit the minus button to delete it and, following a restart, the printer now works on WiFi. I don't have to keep turning off the firewall as I did previously.

     

    One other thing - I added my printer via System Preferences > Print and Fax > +, and then using the canonijnetwork rather than the Bonjour Scanner option under "Kind". The canonijnetwork adds some sort of IP number to the printer, which I think makes the connection more consistent.

     

    Unfortunately, I didn't note exactly what this Canon thing in Login Items was, but I'm not missing it so if anyone else has it and deleting it also works, do tell. Cheers.

  • shakman Level 1 Level 1 (0 points)

    Another thing to remember here is that the whole point of the wifi printer is that many computers/devices are sharing this printer. Be sure to update the printer driver on all the macs accessing this printer. Even if 1 of the computers is out of date, it results in this 'communication error' on all the computers!  I wish they would fix this...

  • henrysantacruz Level 1 Level 1 (0 points)

    I only have one mac and I still get this problem every time I print.

     

    Has anybody tried calling tech support about this issue for either Apple or Canon?  If so, how did they respond?

  • bristlybadger Level 1 Level 1 (5 points)

    Apple has added a new Canon Printer Software Update to its automated software updating. The new version is 2.7. Not sure if it will solve the problems cited here, but worth a try. Run Software Update from your Mac or download from Apple here:

     

    http://support.apple.com/kb/DL899

  • LMarine Level 1 Level 1 (0 points)

    I installed this update and it did nothing to improve the situation. I have a 4 year old MacBook Pro and a Canon MP780 connected through my Time Capsule. My symptoms are just like the rest. It worked fine, then all of a sudden it started having communiction errors. Not only that, but colors print out in horizontal bands of lighter and darker coloring. The only way I can get it to work is direct connect it to my MBP and set it to print in high color (Quality and Media). Even then, it will only print a few pages and then stop mid-page.

     

    If I had wanted this much frustration I would have bought a Microsoft-based product.

  • NichoTL Level 1 Level 1 (5 points)

    Well, only time will tell but it looks like the latest Canon drivers have fixed it for me. I have the latest Lion and a MP640 via Wi-Fi.

    Again there is no way to tell for sure because of the randomness of the problem. All I know is that it feels like every time my wife wanted to print from the MBP I had the problem before the driver update, and she just printed a few minutes ago without issue (and this after not having used the printer for what seems like a week).

    Fingers crossed...

  • shakman Level 1 Level 1 (0 points)

    Same here. Time will tell... so far so good.  Remember to update ALL devices/computers that access the printer with latest software update.

  • Ninalimar Level 1 Level 1 (0 points)

    I had a similar problem.  Can't print on MP560 unless I turn the printer off and on again after every print job.  I have three Macs feeding the printer via wifi.  I did software update on ALL the macs.  Printer behaving fine for now.

  • NichoTL Level 1 Level 1 (5 points)

    Well the problem reappeared for me (see 3 posts up). Funny thing is, I had the same problem on my PC running Windows 7: could not print till I restarted the printer, etc... *sigh*. What on earth is going on?

  • CraigClermont Level 1 Level 1 (0 points)

    I'm having the same issue too.  Have an MX870 that I've owned for over a year.  All of a sudden, today, it decided not to print.  I used to sometimes get the communication error, but usually restarting printer or computer worked.  Now nothing is helping.  I'm at a loss, and need this to work for my business.  Help!!

  • LMarine Level 1 Level 1 (0 points)

    The way I saw it, this is ultimately Canon's problem. If folks can't print using their brand of printer, who loses? Apple or Canon? To that end, I tossed my Canon printer and bought a $130 Epson Workforce 845. Should've done this months ago. Much happier with the Epson than the Canon.

     

    Problem solved!

  • lmonaco421 Level 1 Level 1 (0 points)

    I had this problem with my Canon MP640. Tried all the above suggestions to no avail, then pitched the Canon and bought a Kodak ESP Office 6150 instead. Same problem. There are no words for the frustration I feel. I can print via USB, but wireless is almost always not working unless I do the various voodoo dances above and it still quits after a print or two.

    I've been on the phone with both Canon and Kodak more than once. They ask for a lot of pointless information and have me try all the same pointless fixes above. It works, then after I hang up, it doesn't. Right now, the printer doesn't even appear on the Add Printer list anymore -- only the scanner shows up which is puzzling.

    I went to the Apple store and they so very politely understood my frustration and in a very hip and friendly way offered no help at all.

    Looking through this thread, I'm appalled by the silence from Apple.  This is moderated by them, isn't it?  This thread is over a year old, and clearly Pahu's suggestions are (were?) only momentary fixes, i.e. no solution at all.  If there is nothing wrong on Apple's end, then they should explain this.  Saying nothing just makes things worse for us.

    I will try bristlybager's suggestion involving the System Preferences > Accounts > Login Items to see if there's something to it, but my gut tells me it's another noble attempt that doesn't permanently solve the problem (sigh).

     

    Apple -- are you listening? Do you care?

  • davej00 Level 1 Level 1 (0 points)

    I see same issues under lion on Mac Book with MP640. Works fine from my Window 7 PCs -- no problem. Very frustrating. Have noticed that if I "ping" the printer from a terminal window, then pause-resume the print queue, it works OK. Very odd. Looks like Apple problem to me rather than canon.

  • TomFromGolden Level 1 Level 1 (0 points)

    Same problem here with Lion, MacBook Pro, Canon MX340.

Previous 1 2 3 4 5 6 Next