Skip navigation

Canon MP560 "A communication error has occurred"

112884 Views 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 RSS
  • davej00 Calculating status...

    Do you know the IP address of your printer? If you do, open a terminal window, try "ping ..." where ... is the IP address of the printer. Hit ctrl-c after it has pinged a few times. Then pause/resume your print queue. Seems to work every time for me !

     

    - Dave

  • jhmau Calculating status...

    I've just now found my way through what seemed an intractable communication

    problem, albeit with an MP640.  The various reponses I found on the web did not

    speakl to my case.  I finally went to the dial on the printer, then to:

      Wireless LAN Setup | Device Settings | | LAN Settings | Confirm LAN Settings | Wireless LAN setting list

    Tabbing down I observed that Wireless LAN security was set to WPA-PSK (TKIP)

    I then checked the security setting on my Linksys WRT54G (Rev 7.00.8) router.

    Changing this from WPA2 AES to WPA TKIP+AES did the trick.  As I have not

    found this specific problem mentioned, and as I suspect it is generic across the

    MP640, MP870, MP560 and other such printers, It seems to me useful to note

    it here.  The MP640 does not ssem to allow any alternative to TKIP.

     

    The printer had been working for maybe a year or more on the wireless connection

    without problem, then suddently stopped working.  My guess is that something

    changed, either with a Lion upgrade, or when I did a firmware upgrade to the WRT54G,

    or when I adjusted the router settings for another reason.

  • Austin Bellagirl Calculating status...
    Currently Being Moderated
    Apr 7, 2012 7:55 PM (in response to jhmau)

    I was excited at the prospect of finally finding the solution to this increasingly irritating problem, but alas, my AT&T router is already set to WPA TKIP+AES.  I have a MacBook Pro and have found this problem resurfaced after converting to OS Lion.  I have reinstalled the print driver for my Canon MP560 innumerable times.  If the problem is due to Lion, I implore Apple to fix this, please!  It's insane that each time I go to print a document, I have to sit with fingers crossed and pray it will work this time, inevitably returning back to the Communication Error message after I'd managed to get things working again.

  • TOT10 Calculating status...

    I can't believe that this is still not fixed.... It is so frustrating that the forum has been talking about this issue for over a year yet we're still subjected to the same problem.  Listen up Apple::::: I'm losing the faith!

  • tymcode Calculating status...
    Currently Being Moderated
    Apr 16, 2012 8:28 PM (in response to TOT10)

    To be fair, Canon is the problem, not Apple.

     

    At least, that's what conventional wisdom says.

  • FromOZ Level 2 Level 2 (400 points)

    The problem is not with Apple but with the Canon printer. I just fixed this directly for my brother who had been going through this thread and could not get it working following advice in the thread.

     

    There are three components (Mac machine, wireless router/network device, Canon printer) to this which need to be considered, I am going to post an 'ideal' setup and solution and refer to that. You don't necessarily have to follow the exact same setup for each component but do it the way listed and it will work. I will point out also during the setup documentation some common errors that people do (my brother had wrong also).

     

    1. Wireless router - this device connects you to the Internet (WAN = Wide Area Network) and usually these days also provides connection point for your home network (LAN = Local Area Network). It will typically provide both wireless and wired connections (the number wired connections may be limited) to your LAN.
      1. The typical home network range will be 192.168.1.0 - 192.168.1.254 (yours may look different that should not an issue) with the wireless router having a LAN (not WAN) address of 192.168.1.1 it then becomes the gateway device to the Internet.
      2. The wireless router usually provides a feature called DHCP (Dynamic Host Configuration Protocol) which basically means it acts as device which assigns IP addresses (like your home street address i.e. where are you) to devices on the LAN.
      3. It is best to have servers/services like printers having a static IP address (that is manually set, not set automatically via DHCP). Note I said best, not mandatory, but you do want to get your printer working - yes?
      4. Go to web page configuration for your wireless router (read instructions for your device) and find the section which talks about DHCP. In there make the DHCP client address range to be 192.168.1.100 to 192.168.1.200 - this will allocate 100 IP addresses for your Macs, Macbooks, iPads, iPhones etc. (you do naturally only have Apple gear yes ) if you have more than 100 devices then what are you doing reading this thread! Get a networking specialist . This will then (working on assumption that the wireless router LAN address is 192.168.1.1) give you the range of 192.168.1.2 to 192.168.1.99 for manual IP address setting.
    2. Canon printer - this can be setup to connect to your home network (LAN) both wired and wirelessly. Ideally you should connect it wired, not wirelessly. I will assume you have it connected wired, regardless you should NOT have it connected BOTH wired and wirelessly. On the Canon printer display you can see and set some basic settings. Assuming you have it connected by network wire (not USB) turn off the wireless connection and write down the IP address of the printer (for example let's say it is 192.168.1.6 - yours will/may be different). By default the printer is setup to use DHCP to get it's (home network / LAN) IP address.
      1. Go to web browser on your Mac and type in address you got from your Canon printer (for example 192.168.1.6 - yours will/may be different) so like this http://192.168.1.6 (yours will/may be different)
      2. Select menu selection (on left) of 'Network Settings'. On detail screen change network from DHCP to manual and type in (making assumptions that your LAN network is in range 192.168.1.1 to 192.168.1.254 AND your router is 192.168.1.1) manual address of 192.168.1.10, click 'OK" on top. This will change the IP address of the printer from whatever dynamic (DHCP) address it was to a manual/static address. It is always better to have a static address for servers/services than dynamic address so client machines (your Mac, iPad etc.) can find the server/service. It's like your local MacDonalds having a street address that changes all the time, be a pain looking for it always.
      3. When you click 'OK' the address of the printer will change to the new static address - in your web browser then you will have to enter the new IP address. So (assuming you used address I said) in your web browser type in http://192.168.1.10 - the Canon web configuration will come up.
      4. Choose the menu selection on left 'Other Settings'. Assuming your printer model is Canon MG6150 change the following settings (use the values in quotes) is your printer model is slightly different follow the example and change names appropriately:
        1. Printer name setting: "Canon-MG6150"
        2. Bonjour setting: "Enable" (if it is not already)
        3. Service name: "Canon_MG6150"
        4. LPR service notification: "ON"
        5. LPR protocol setting: "Enable"
        6. Then click OK button.
    3. Mac computer - this can be connected to your home network both wired or wirelessly. You should NOT have any device connected both wired and wirelessly to the network (LAN). Typically, if you have a desktop machine (iMac) and you have your Internet access device (wireless access/router device in point 1 above) close by with a spare wired (Ethernet) connection it is better to connect via wired. Now we are going to connect to the Canon printer via the network. Do NOT connect the printer to your Mac via USB cable to install it. Again that is confusing your Mac as to the 'address' of the printer because - unless you are going to leave the printer connected via USB - you set it up via USB and then disconnect it.
      1. On the Mac go to System Preferences | Print & Scan.
      2. If you have Canon printer already listed there delete it.
      3. Click the + button to add a printer.
      4. From the 'Add Printer' dialog box with the 'Default' tab selected you should see two entries for the Canon, both named 'Canon_MG6150', choose the kind 'canonijnetwork'. This selection gives you the full function of the printer including being able to see ink quantities and so on.

     

    That's it - enjoy printing.

    iMac, Mac OS X (10.7.2)
  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    Apr 21, 2012 5:18 AM (in response to TOT10)

    See my post here

     

    https://discussions.apple.com/thread/2708074?start=60&tstart=0

     

    for some reason direct links to posts are not working on this thread, this will take to you the correct page then go down to bottom for my detailed posting.

  • fromoz2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2012 5:24 AM (in response to FromOZ)

    Thanks Bro!

  • NichoTL Calculating status...
    Currently Being Moderated
    Apr 22, 2012 4:32 AM (in response to FromOZ)

    Thanks FromOz for the detailed post. For me the crucial bit seems to be the LPR service notification setting on the web interface of the printer, as I had already done everything prior to that (reserved an IP for the printer etc...). As it is an intermittent problem, it is too early to say if this is the definitive solution, but it sure helps.

  • fromoz2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2012 5:48 AM (in response to NichoTL)

    It was the LPR stage that definitely fixed mine.

  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    Apr 22, 2012 7:36 AM (in response to NichoTL)

    I would agree that the crucial step would be the 'LPR service notification: "ON"'. That is because the printer has to 'advertise' its' services via the Apple Bonjour network protocol. If it does not advertise itself, when an Apple device (iMac/Macbook) goes out to the network and asks is there any printers there the Canon will not answer.

     

    From where I sit the problem is 100% Canon. To put Bonjour networking in printer and then not advertise its services is just dumb.

     

    The other detailed steps I listed are good practices (fixed IP address for printer) for having shared service devices on network. The advice about deleting printer setups done with connecting via USB is because the computer gets confused as to how to get to printer.

     

    Trust it solves problem for you finally.

  • rampa6e Calculating status...
    Currently Being Moderated
    May 11, 2012 8:29 PM (in response to FromOZ)

    I've been living with this frustrating problem for months... kept doing the power on/off workaround but my patience was wearing thin. Thank god I found this post before I chucked this printer out the window. Seems to be working now!

  • uskrums Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 13, 2012 6:12 AM (in response to FromOZ)

    Thanks for the info, but for me  lot of this doesn't apply. I have an Apple Airport Extreme and the Canon MP560 is running wirelessly on the network. The initial setup of the computer was done on my Mac. I didn't setup any of those Canon utilities.

     

    The new user interface  of the Airport Extreme is very basic. While I love it and have no problems whatsoever with my network, I don't see the easy way to switch out of DHCP to manually assign an IP address nor do I understand how Bonjour fits into the Mac setup. Isn't that Windows only? I really wish someone from Apple would figure this out and it would be straightforward and based on a Mac setup.

  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    May 13, 2012 8:54 AM (in response to uskrums)

    I'm assuming you have the problem stated?

     

    I can assure you of two things:

     

    1. All of the information applies to your setup (if you have the Canon printer). Wired or wireless doesn't matter.
    2. The problem is 100% Canon and 0% Apple.

     

    Bonjour is technology invented by Apple (http://en.wikipedia.org/wiki/Bonjour_(software), nothing to do with Microsoft. Apple did also extend Bonjour to the Windows platform, but I have no experience in that area.

     

    Apple doesn't have to 'figure this out', because the problem is not with their product - it is Canon. Having said all that - and if you are willing to accept it (it's a fact) I can give you further pointers for how to fix the Canon problem.

     

    Re: DHCP I said to set the DHCP range from something like xxx.xxx.xxx.100 to 200 where the xxx.xxx.xxx is the 'network part' of the IP address range and the 100 to 200 is the host (computer etc.) part of the address range. I suggested to put the printer, which should be considered a 'server' device, outside the DHCP assigned address range (by the DHCP device, typically home user wireless router device) and to set it's IP address manually.

     

    The Airport Extreme has full facility to do this - and a lot more - even in the new simplified user interface version, version 6. See screenshot here of relevant screen from my Airport Extreme.

     

    Airport_Extreme.png

     

    My network range is 192.168.42.x where x = hosts. I have set DHCP hosts to go from 100 to 200.

     

    In the Airport Extreme you can also do:

     

    • DHCP Reservations — where you tell DHCP server that a specific host (actually the host/machine's MAC address) should always be given a specific IP address
    • Port Mapping — where you tell Airport Extreme to direct specific protocols from hosts on the Internet to one or more internal IP addresses.

     

    As I said the new Airport Extreme software version, version 6, has been simplified from previous versions but you can still download and install the previous version, version 5.6, and have it running on your Mac.

     

    You can get it here — http://support.apple.com/kb/DL1482

     

    You didn't mention if you checked and got the IP address of the Canon printer and logged onto it's setup web page. If you do and follow my previous instructions (and I still recommend that people set the printer IP address to manual, not DHCP, plus have printer connected wired not wirelessly) and fix the setttings which Canon did wrong (see points 2.4.2 & 4 & 5 in my first post) then the printer will work.

     

    That will fix the error with the Canon printer — which is where the issue is. Nothing to do with Apple

  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    May 13, 2012 8:58 AM (in response to rampa6e)

    Great - good to hear and pleased to be able to help.

1 ... 3 4 5 6 7 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.