Skip navigation

Canon MP560 "A communication error has occurred"

112793 Views 150 Replies Latest reply: Dec 9, 2013 12:58 AM by PMJ61 RSS
  • moudyfromsan diego Calculating status...
    Currently Being Moderated
    May 13, 2012 2:54 PM (in response to FromOZ)

    Thank you so much. I finally took the 15 minutes out of my day to fix this really annoying issue. Followed your instructions and it worked well. I printed two documents without fussing with it.

     

    Hope it stays consistent.

     

    Thanks again!

     

     

    My Setup

    AirPort Extreme

    Canon MP560

    Various Apple Macs @ 10.7.4

  • uskrums Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 17, 2012 1:40 PM (in response to FromOZ)

    Thanks, I'll give it a try when I am back at home in a couple days.

  • mkd-az Calculating status...
    Currently Being Moderated
    May 30, 2012 3:04 PM (in response to FromOZ)

    So, I've been reading the posts regarding the Canon MP560.  I started to follow the steps outlined by FromOZ -- quite helpful, but my router (Belkin N+) doesn't have the ability to create my own DHCP pool.  It allows me to USE a DHCP pool with an established range which is set between 192. ... 2.2 to 192. ... 2.100.  So, then I went to step 2.  My printer is connect wirelessly to the LAN, but also wired to a (not always on, very old) windows (XP) desktop.  Anyway, I went to the advanced settings on my browser and noticed that the settings (appeared to me) to already set to a static IP 192. ... 2.2, and the only change I made was to make the LPR service notification 'ON'.  So, I let that sit for a while, and now about 3 hours + later it is off the network again.  Am I missing something?

  • MediumRare Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 3:13 PM (in response to mkd-az)

    Changing the LPR notification didn't help me either.  The problem in my case appears to be the link between the laptop and the Belkin Router - there are times my network connection gets dropped momentarily (or even for longer) and then various things don't work correctly (printer, remote hard drive, IMAP).  Generally if I turn Wi-Fi off and then back on the laptop finds everything again.  But it's so annoying to do this 5 times a day or more.

  • tweezerme Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 3:46 PM (in response to FromOZ)

    Thanks FromOZ for the tip!  After setting my wireless network to use the IP range of 100-200, I had to do a couple of things to get my printer to work:

     

    I had to reconfigure my Airport Time Capsule (using AirportUtility) so that it would join my existing wireless network (Verizon wireless router) rather than "Create a wireless network".  Not sure why it was set like that but I think that may have confused things.  I realized this when my printer indicated there were 2 wireless access point with the same network name when I tried to set up the wireless connection again.

     

    I then selected "reset LAN  settings" on my Canon MP560.  Afterwards I joined it to my wireless network.  My printer is too far to connect to the network by wire.

     

    I then set the 'Other Settings' value on my printer and added the printer to my Print & Fax printer list.  Before, I also had to add the MP560 Scanner in order to scan but now, I can print & scan using the 1 printer in my set up.

  • NichoTL Level 1 Level 1 (5 points)

    Some clarifications:

     

    I'm going to try to explain/second guess parts of FromOz's post so that some of you don't spend too much time on some secondary issues.

     

    1. Setting the range of DHCP addresses to 100-200: while it is good practice to do such a thing, it isn't entirely necessary. It is true that, if you do implement it, it is a lot easier to track who are the normal DHCP clients (100-200) and the ones with a special purpose (others) like servers, NAS, printers, routers, etc... But what FromOz was trying to achieve was a FIXED IP for the printer. But depending on your router, it can be a lot simpler.

    For exemple, the ADSL router sent to me by my provider DOES NOT have the ability to specify the DHCP pool range. But that's not a problem: because if I go onto the config pages of the router and look for the list of current DHCP clients, I can see a list of IP and the corresponding hostnames. Some hostnames are blank or non trivial (i.e. no idea which machine it is, so obviously not helping), like, as luck would have it, my printer. So a quick look on the printer's config pages (on the printer screen, not the web page because I still don't know the printer IP so can't really access its web page. It's the whole point of the exercise) and I now know its IP address as assigned by the DHCP server of my router. Back to the list of clients, and I now know which one is my printer. In my case, there is a column named 'reserve' with tickboxes for each client in the list. Tick the one for the printer, apply changes, and that's it your printer will always have the same IP.

    I know this help because now if I want to access the web interface of my printer, I know its IP address, and I can bookmark it. Now what I don't know is if it helps with the network error itself (does getting a different IP address fro the DHCP mess up the printer config in the Mac?).

    So the short version is: don't spend time trying to modify the DHCP pool range, what you are trying to achieve is a fixed IP for your printer and it might be simpler with your hardware (or not).

     

    2. It turns out that with some printer models the LPR settings are directly accessible via the printer menu. So it's not even needed to use the web interface!!!

     

    3. I have a feeling that Windows PC do have an impact on how well this solution works. I have a mixed PC/Mac environment at home, and when I use my Macbbok Pro (with the help of FromOz) the printer works fine. But as I was writing this post I tried to access the web interface of my printer from my PC and I got no response. I tried pinging it no response (for the record, the printer is on). I went on to the client list in the config pages of my router, and the printer is there with its fixed IP but the router seem to think that it's not currently active. So it looks like the network comm of the printer has hanged or that it hasn't been 'released'. Unfortunately I can't remember if I printed from the Mac or one of the PCs last...

     

    (I'll take a break)

  • mkd-az Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 31, 2012 4:00 PM (in response to NichoTL)

    Since my printer (Canon MP560) is now continuously falling off my network, and only staying on (when restarted) for a few minutes -- max; I'm wondering if it is possible to connect this printer directly to my Belkin N+ router via its USB port and have the router act as a print server, too?  If so, is this a difficult propositon using a Macbook Air running OS X 10.7.4?

  • uskrums Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 8, 2012 6:32 AM (in response to FromOZ)

    Thanks OZ. I think I may have fixed it now. One thing I was confused on was the client list of the Airport Extreme. Previous versions had it set up differently. I finally realized that to get the IP, you just had to roll over the client and not hit the "Edit" button.

     

    Before doing that, I did actually find all the printer setttings for the internet off the machine itself, but havint the web interface makes it much easier. I have done everything you said except the DHCP reservations. I am going to print from several different computers over the next couple days with some time in between and see if all those settings fixed it. If it doesn't than I will do a DHCP reservation for the printer. And you say to reserve that outside the normal range, right? On my Airport Extreme, the router mode, "DHCP and NAT" is greyed out so I am assuming I stick with DHCP but use the "reservations" for static IP addresses.

  • shakman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 14, 2012 5:24 PM (in response to FromOZ)

    Well, the printer was working well for a few months after enabling the LP protocol, but started acting up again now!

     

    So now I tried Oz's suggestions for static IP and enabling the LP protocol etc., but having the same problems, in fact worse than before... seems to now get the 'communication error' within half hour between print jobs. And yes, I made sure the DHCP range is outside of the static IP address, but no luck.

     

    I give up. I'm going to trash this printer and get another.. this is just not worth the trouble!

     

    A quick workaround I found was to login to the printer via the static IP, change the static IP address to another unused address, then it works again for a while.... half hour later, dead again. Arrrgh! I've wasted waaaay to much time on this; wish I had trashed it months ago.

  • amylevin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2012 9:05 AM (in response to tymcode)

    I have this problem on my Canon MX870 and my Epson Workforce 40. It is infuriating. And is not a Canon problem. It has been happened for at least a year with my Canon. Started happening with my Epson in the past 6 months, after I updated to Lion.

    I just upgraded to a Retina MacBook.

    Lion 10.7.4

  • amylevin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2012 9:06 AM (in response to shakman)

    Has anyone found a printer that doesn't have this issue? I would happily buy a new one (they are relatively "cheap" these days) but am concerned the problem will persist.

  • uskrums Level 1 Level 1 (10 points)

    I too thought I had it fixed, but this week it is acting up again. Agree, this is ridiculous. One thing I never had to worry about with my PCs was printing! Is it just Canon's?

  • uskrums Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 20, 2012 7:19 AM (in response to uskrums)

    OK, so I went back in and made a DHCP reservation on my Airport Extreme of xx.xx.xx.201. My DHCP range is 2 to 200. My router is 1. I then went to the Canon web interface and hit manual assign the ip address to the 201. It is printing once again. (I had been getting the "printer is not connected" error reccently, not the "communication error"). I have 3 Macs that I then deleted and added the printer back in and printed from all three. I am going to test the Win7 machine I have in the basement...

  • amylevin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 20, 2012 5:39 PM (in response to uskrums)

    I am having this issue with my Epson as well as my Canon

  • DanaB519 Calculating status...
    Currently Being Moderated
    Jul 20, 2012 7:31 PM (in response to PAHU)

    This worked for me!  Thanks so much!!! 

1 ... 4 5 6 7 8 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.