Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Canon MP560 "A communication error has occurred"

Hi there,

I purchased my first mac in september 2010, and along with it the Canon Mp560. I have it setup to print wirelessly from my macbook to the printer. Everything was going great until about a week ago. I can not get it to print, an error pops into the utility, saying "A communication error has occurred." But the interesting part is that I can still get it to print test pages (printer head alignment etc.) from my macbook. I dont really know too much about troubleshooting on macs. I read a little about someone who had a similar problem, and they said that they tried to repair permissions, and I found where to do so, but I am not sure if I should just go ahead a repair them? I don't know if that is relevant though. I checked my system update and according to it, all my software is up to date. I really could use any help that any one could offer. Thanks for taking the time to read my monster size post and thank you in advance for any advice on where to go from here.

Macbook, Mac OS X (10.6.5)

Posted on

Reply

Page content loaded

Jan 5, 2011 2:08 AM in response to robotwholearned In response to robotwholearned

Hello and welcome to Apple Discussions.

The first thing I suggest you try is simply opening Print & Fax, selecting the MP560 and pressing the minus button under the printer list. This will remove the print queue but not the driver so you will just need to add the networked printer again. With Print & Fax still open click the plus button to add. With the Default view selected the MP560 Scanner will appear first. And if you wait a few more seconds the MP560 Printer will also be displayed. Select this entry, which will be shown as canonijnetwork in the Kind column. The Print Using menu should change to Canon MP560 series and when it does click Add to complete. Now try printing with this new queue. If this doesn't work then reply and we'll try something else.

Jan 5, 2011 2:08 AM

Reply Helpful

Feb 4, 2011 12:11 AM in response to robotwholearned In response to robotwholearned

Hi,

I am having the same problem. I went through the steps that were outlined below in the potential solution email, but now I can't add the printer back in the "add printer" window. The name of my printer does not appear in the window, so I cannot select it. Can you help me? I am connecting to the printer via WiFi. Thank you!

Feb 4, 2011 12:11 AM

Reply Helpful

Feb 4, 2011 12:58 AM in response to Colleen Cleveland In response to Colleen Cleveland

When you select to add the MP560 you should see the scanner and printer components. Do you see either? If you don't then you could have a network issue. Is the MP560 blue wifi light on? Do you see the MP560 in the Shared section of the Finder sidebar? Can you open Safari, select the Bookmarks icon and select the Bonjour entry. The right pane should show the MP560 if the Mac can see it.

Feb 4, 2011 12:58 AM

Reply Helpful

Feb 17, 2011 9:45 AM in response to robotwholearned In response to robotwholearned

just for the record, I had the same problem start around about the same time. This can't be a coincidence, so perhaps there's a bug in a recent update? (I've been using exactly the same equipment for about a year without any change of settings and no problems until now.)

Feb 17, 2011 9:45 AM

Reply Helpful

Feb 26, 2011 11:31 AM in response to Fr Gr In response to Fr Gr

I recently started having a similar issue. In the past turning the printer off and back on helped, but today no such luck. I finally stopped my time machine back up and then it started printing fine. Not sure if this will work for others, but worth a shot in case Time Machine/Time Capsule is interfering some how with the printer communication.

Feb 26, 2011 11:31 AM

Reply Helpful

Feb 26, 2011 10:47 PM in response to Ryan Samoheyl In response to Ryan Samoheyl

I also had this issue. My printer was connected fine and then one day I started just getting the 306 error.

My Solution was this.

1.In system preferences go to the printers window and delete the printer.

2. Then ctrl-click in the printer window and reset printing system

3. Restart

4. Reinstall the canon driver for the printer

5. DELETE the new printer from your printer preferences window again!

6. Hit the + button to add a printer

7. You will see your printer name with "Bonjour" to the right of it DO NOT SELECT THIS ONE

8. Wait a minute and a second canon printer will appear with canonijnetwork to the right select this one

9. Now print all you desire!! YAY! User uploaded file

Feb 26, 2011 10:47 PM

Reply Helpful

Mar 16, 2011 8:36 AM in response to robotwholearned In response to robotwholearned

I had the same problem and Pahu's suggestion fixed the communication error problem. Yay! However, I accidentally deleted the scanner queue from the Print & Fax window too. Now when I go to Add Printer, I only see the printer and no scanner. I tried scanning and it doesn't work via wi-fi anymore. I restarted the printer and the computer with no luck. I also re-installed the drivers and that didn't help, either. Any ideas on how to re-add the scanner??

Mar 16, 2011 8:36 AM

Reply Helpful

May 14, 2011 11:54 AM in response to robotwholearned In response to robotwholearned

Count me in as well as a longtime user (over a year) with no problems up until today, and now it keeps giving me this error. Restarting the printer and then pausing and resuming it in preferences worked for about twenty minutes, then again am getting this error.

May 14, 2011 11:54 AM

Reply Helpful

Jun 30, 2011 9:28 AM in response to robotwholearned In response to robotwholearned

I am having the same problem with my Canon MP560 right now. I wanted to print a poster but it said "communication error" so I pressed the power button on the printer to shut it down. Usually this works but the printer still hasn't shut down....it has been 2 days....what am I supposed to do to get my printer working? all the printer is doing is pausing all jobs, the green light keeps flashing, and the screen on the printer keeps showing those stupid blue lights.

Jun 30, 2011 9:28 AM

Reply Helpful

Jul 15, 2011 3:34 PM in response to m.leung65 In response to m.leung65

For the record / case-building / solidarity, same here -- Canon MX870, MacBook Pro OS 10.6.8, wireless connection via AirPort. No problems printing from a PC laptop in same space.


Never happened until a few days ago. Turning printer off & on again typically lets me print once or twice before communication error happens again.


Thanks to those of you providing remedy procedures and work-arounds, but I don't want to go screwing around in settings, deinstalling & reinstalling, remembering some kind of difficulty establishing functional connection in the first place and not having time to fool around.


Going to continue doing the off-&-on maneuver until I'm fed-up or don't mind the time troubleshooting, but I'm hoping a resolution is on the way from Canon or Apple. Obviously there's a broad, common concern here.

Jul 15, 2011 3:34 PM

Reply Helpful

Jul 15, 2011 4:50 PM in response to Funderburko In response to Funderburko

Btw: Scanning via wireless connection is a-okay -- the communication error happens just with printing.


Furthermore, I think the "trusty" on-&-off trick just failed me, and I think it's failed me before but I just thought I forgot a step in it -- eg, if the job's still live in the queue, need to kill it or pause the printer and then do the on-&-off, then send it again.


It's a driver thing, ain't it? Maybe I do need to do the de-install & re-install, but I think that's BS too... Dangit.

I'm gonna do it and then find out I don't know what I'm doing and have a sh***y time figuring it out all over again...


It was awesome, the day I established wireless printing, like a new home office era or something.

Jul 15, 2011 4:50 PM

Reply Helpful
User profile for user: robotwholearned

Question: Canon MP560 "A communication error has occurred"