4 Replies Latest reply: Apr 13, 2013 2:55 PM by Yoshipop
peter.holm Level 1 (0 points)
Hi all

I have a Mac Mini running Mac OS X Server. I recently changed a bunch of network settings, and since then I can't get the Mac to acquire an address from DHCP through the wired connection.

The wireless ethernet connects to the same router and acquires it's IP address, DNS, and router information through DHCP without a problem.

The wired ethernet connection is unable to communicate with the DHCP server. The router detects it, and sees it as having it's self-assigned ip address ( The subnet mask is wrong ( vs. as well. Both are greyed out in network preferences when DHCP is selected. I've tried all of the obvious steps (restarting networking, rebooting everything, running the diagnostic tool, disabling wireless airport, etc.) to get it to work, with no change.

I can get it to connect with a manually assigned IP, but that's not a long term solution for my network.

I have had this issue with multiple routers. Currently I'm using a gigabit-e router - netgear WNDR3700. Other machines connect to the router just fine through wired ethernet (xbox360 and linkstation mini).

I'm new to Mac OS, but not new to networking. Any help would be appreciated.

Mac Mini 4.1, Mac OS X (10.6.5)
  • Jim Coleman Level 1 (55 points)

    I periodically have the same problem with my 15"PB running 10.5.8.

    I tried all the usual things to get it connected to a comcast modem using an ethernet cable and finally found something that worked.

    In system preferences > security > firewall I always check the bottom box labeled "set access for specific services and applications".

    I found that with this box checked I would start up the PB, open Safari, and click on something like google and would get the "not connected" signal.

    I would then go to the system preferences>security>firewall menu and change my selected box from the bottom one to the top one labeled "Allow all incoming connections".

    Within a couple of seconds of making this change I would be connected and I would change back to the more secure setting.

    I know it's a pain to have to do this but it is the only way I can get connected sometimes.

    Hope this helps,

  • peter.holm Level 1 (0 points)
    Thanks, that was exactly the solution. I added a firewall exception for "DHCP and Netboot Client" on port 68 after re-enabling the firewall. Hopefully that will prevent this problem in the future.
  • xoofoo Level 1 (0 points)

    I have a similar problem;
    I understand it's a firewall issue.
    But when I go to "System Preferences" > "Security" I do not have the firewall tab.
    I see only 2 tabs: "General" and "FireVault".

    I am running MAC OS X server, version 10.6.3

    Did I miss something at the setup of the machine?
    Do I have to activate something somewhere/update the soft?

    Thanks for your time and help!
  • Yoshipop Level 1 (95 points)

    This might be an old discussion but it was helpful to me.  Well, almost.  After reading this discussion, I arrived the same place that xoofoo above did.  After some poking around, I was able to find the answers.  (Feel free to correct me if I'm wrong, please!)


    Here's what I did:


    1. Launch "Server Admin" in Applications/Server folder
    2. Open the list of services by clicking on the triangle next to the Server listed in the left pane.
    3. Click on "Firewall"
    4. Click on "Settings" tab
    5. Click on "Editing services for" and select "192.168-net" (or if necessary, select "any".)
    6. In the window below, go down the list and tick both "DHCP and Netboot client" and "DHCPDISCOVER".  (hint, this list is sorted by ports number, go down and look for port 68).
    7. Click "Save".


    That should do the trick!  Hope this is helpful to others in the future.