Previous 1 2 Next 20 Replies Latest reply: Jan 6, 2011 10:10 AM by Lawrence Finch
Conork2 Level 1 Level 1 (0 points)
Hi, I am having a problem where the iphone can't connect to my home wifi network, because when the password is entered it always says incorrect password. I've found a few threads online about this but none of the answers seem to work. My ipod touch 1st gen can connect to the router (old APC WMR1000B, can only use WEP 64 and 128, doesn't support any other inscription) but my dad's iphone 3g and my brand new iphone 4 cannot. When the WEP is completely disabled the iphones can both connect properly, but obviously some sort of protection is needed on the network.

Things i'v tried:
resetting the wireless settings on the iphone
tried a couple other passwords(in each case entered the Hex and the actual word)
tried putting the dollar sign($) in front of the password(both hex and word)
changing from WEP 64 to WEP 128
Edit* have also tried adding it under other networks on the iphone, same error occurs

Any help with this problem would be greatly appreciated, thanks

Message was edited by: Conork2

Toshiba A300-1mc, Windows Vista
  • wjosten Level 10 Level 10 (93,995 points)
    WEP security is no security at all & can be cracked in a matter of minutes with software readily available on the internet. You need to change to WPA2 & I suspect your connection problems will be solved as well. If your router does not support WPA2, buy a new router.
  • Conork2 Level 1 Level 1 (0 points)
    As i'v read before, It isn't about trying to stop a hacker, it's about trying to stop some opportunist from using our wifi, a higher level password isn't needed in the area i'm in.
  • David Willis Level 1 Level 1 (0 points)
    I'm having the exact same problem with my iPhone 4 running iOs 4.2. My iPad connects fine and my Macbook Pro connects fine, but the iPhone keeps telling me that the password is incorrect. I've even went as far as to restore my iPhone and it still has the same problem.
  • wjosten Level 10 Level 10 (93,995 points)
    Here's the deal, WEP is an older outdated security method & the simple fact is iPhones don't play nicely with it, as you've found out. So, either buy a new router or run your existing one with security disabled. WEP can be cracked so easily that even with it turned on it's like having no security at all. But if you want to try & get things to work, do this:

    Make sure your router firmware is up to date, then on your phone, select your network & then select forget this network. Then, make sure you're using a hex key and not a pass-phrase. Then, try putting a "$" before your hex key when entering such on your phone. See it doing this works.
  • Conork2 Level 1 Level 1 (0 points)
    Saying WEP isnt usefull ( and im quoting this from another site) is like saying locking your doors isnt usefull when you can just use a brick to get through a window.
    Checked for router firmware, APC do not seem to have any firmware updates for it. Also quite alot of places still use WEP so its crazy if the Iphone doesn't work with it
  • wjosten Level 10 Level 10 (93,995 points)
    Did you follow my suggestion about the "$" ?

    I could care less what security you use/don't use. All I can do is give you factual information. What you chose to do/not do is strictly up to you.
  • Lawrence Finch Level 7 Level 7 (33,330 points)
    That's a really poor analogy. If you use WEP anyone withing range of your router can monitor and record all of the traffic going into and out of your computers, including your personal information, passwords, financial transactions. They can then access the sites you log in to and pretend to be you. They can also install malware on your computer and download anything on it, and, if you haven't set a good admin password on the router, can take control of your router. All without you knowing it. It isn't just about preventing others from using your network. With a brick you can at least see the broken glass. For more information google for "firesheep". But,hey, it's your data, not mine.
  • Lawrence Finch Level 7 Level 7 (33,330 points)
    The iPhone should work with WEP. Have you tried the other suggestions in the thread? Also try these:

    0. Make sure you have the latest firmware on your router.
    1. Reboot your router.
    2. Forget the network on the iPhone and reboot.
    3. Reset Network Settings on your iPhone and reboot.
    4. Make sure you are using a hex key and not a passphrase, and, if you are using 40 bit WEP, that you are using the proper key number.
  • Conork2 Level 1 Level 1 (0 points)
    The analogy is to show that WEP is a deterrent, if WEP were not there anyone walking by without any computer expertise at all could hook up to the web through our router. With WEP someone needs at least a basic understanding of how it would work. Oh and at least it would be better then what the previous post suggested, which said i might as well have no security. Also this is painfully off topic, while im greatfull for your concern, this has nothing to do with the iphone compatibility.
  • Lawrence Finch Level 7 Level 7 (33,330 points)
    The iPhone should work with WEP. See my message below for troubleshooting. It's possible that your router is simply too old. As routers are really cheap if nothing else works you might want to consider replacing it.
  • wjosten Level 10 Level 10 (93,995 points)

    It takes just three seconds to extract a 104-bit WEP key from intercepted data using a 1.7-GHz Pentium M processor. The necessary data can be captured in less than a minute, and the attack requires so much less computing power than previous attacks that it could even be performed in real time by someone walking through an office, with little to no computing knowlwdge. This can even be done with some PDAs or mobile phones, easily.

    But we're off topic...have you tried any of my suggestions?
  • Conork2 Level 1 Level 1 (0 points)
    also, i believe in my original post i said i'd tried the "$" method
  • wjosten Level 10 Level 10 (93,995 points)
    Depending on the age of your router, you may never be able to get it to work with your iPhone. Since there are no firmware upgrades available and given how cheap routers are. My best suggestion is to purchase a new router.
  • Conork2 Level 1 Level 1 (0 points)
    Hmm the router is old, but like i said, i got it working when i took the WEP protection down for a while.
Previous 1 2 Next