Previous 1 2 Next 23 Replies Latest reply: Jan 31, 2011 12:30 PM by AllenETD
IndyJinx Level 1 Level 1
I purchased kidpix 3d, and it shows up on the purchased tab in the app store. However, when clicking the install button, I get an error box that says:

"The application could not be downloaded."
"The server gave an error during download: 403 Forbidden."

With a cancel and retry button. Retry does nothing.

Macbook Pro 2.53, Mac OS X (10.6.5)
Solved by Edwin @ Feral Interactive on Jan 7, 2011 3:26 AM Solved
I am sorry that you have experienced a problem when downloading LEGO Harry Potter from the App Store.

It seems that there were problems with the App Store after yesterday's launch - we suspect that this could have been caused by the size of the application that you were trying to download. We are currently working with Apple and hope to have it resolved later today.

Edwin - Feral Interactive
Reply by newbie74 on Jan 6, 2011 12:17 PM Helpful
I purchased the Kid Pix 3D through the app store with same problem. Apple said this is probably due to the app store being brand new. They had me contact the software provider who is now working with Apple to get this solved for me. Disappointing for sure but think they will get it working.

All replies

Previous 1 2 Next