Previous 1 2 3 4 5 6 Next 78 Replies Latest reply: Nov 14, 2015 9:54 AM by marlacparker Go to original post
  • NoonPokpak Level 1 (0 points)

    I have same problem, please check topic below, I still not try it yet.

    https://discussions.apple.com/message/15700632#15700632

  • jsconnelly Level 1 (0 points)

    I'm having the same problem and the linked solution did not work for me.  I'm running Lion and the majority of purchase attempts gives me the error.  Some purchases have gone through but I'd say only about 2%.  It doesn't seem to matter whether it's a pay app or a free one.

  • iOS Software Engineer Level 1 (10 points)

    I had the same problem on a MacBook Air that ships with Lion

     

    This is how you fix it

     

    0. Close Every App (Safari, iTunes, AppStore, etc)

    1. Launch Finder

    2. Press CMD+SHIFT+G (or click on Go then Go To Folder)

    3. Type the following /var/folders

    4. Open up Console (Spotlight Console and launch it)

    5. Open The AppStore

    6. Try to buy something free and you will see this message "The product distribution file could not be verified. It may be damaged or was not signed."

    7. Switch to Console and look at the error message

     

    8/31/11 6:50:37.121 PM App Store: FRPurchaseManager: Preflight operation for 415571499 failed with error: Error Domain=com.apple.appstore Code=0 "The product distribution file could not be verified. It may be damaged or was not signed." UserInfo=0x7f9b2464aa00 {NSLocalizedFailureReason=Cannot create PKProduct from "file://localhost/var/folders/3p/sflvgxwj3hs4kdkjpgb30r4c0000gn/C/com.apple.app store/415571499/preflight.pfpkg" Error Domain=NSURLErrorDomain Code=-1100 "The requested URL was not found on this server." UserInfo=0x7f9b2464ac00 {NSUnderlyingError=0x7f9b24648230 "The requested URL was not found on this server.", NSErrorFailingURLStringKey=file:///var/folders/3p/sflvgxwj3hs4kdkjpgb30r4c0000gn/C/com.apple.appstore/41557 1499/preflight.pfpkg/index.sproduct, NSErrorFailingURLKey=file:///var/folders/3p/sflvgxwj3hs4kdkjpgb30r4c0000gn/C/com.apple.appstore/41557 1499/preflight.pfpkg/index.sproduct, NSLocalizedDescription=The requested URL was not found on this server.}, NSLocalizedDescription=The product distribution file could not be verified. It may be damaged or was not signed., NSUnderlyingError=0x7f9b2464ac40 "The requested URL was not found on this server."}

     

    In my case the problem was some file in the /var/folders/3p

     

    5. Quit AppStore

     

    6. I deleted the entire 3p folder (it gets recreated when you launch AppStore). If you really want to be safe, create a copy of that folder.

     

    You don't need to restart. Just Launch AppStore and it works!

  • serico Level 1 (0 points)

    I've applied your fix and Xcode is being downloading now. Thank you very much for the detailed and helpful solution!

  • Mikezhang Level 1 (0 points)

    Thx! I've fixed the same problem.

  • micliz Level 1 (0 points)

    This worked for me.

  • annabelle Level 2 (460 points)

    Look at this answer too if the other fixes don't work for you

     

    this one solved my problems 

     

    Annabelle

  • David Scollin Level 1 (5 points)

    Great info - thanks! In my case I just had one ap that wouldn't download with the same "The product distribution file could not be verified. It may be damaged or was not signed." error message. I did as you instructed, although my folder with the error message was q1. I then looked in that folder and found the com.apple.applestore folder and just deleted that. That fixed the problem. Thanks again for sharing your fix.

  • robertfromlansdale Level 1 (0 points)

    This worked for me.  deleted the /var/folders/ys  restarted app store and could finally download.  Thanks!

  • ehrenfromcincinnati Level 1 (0 points)

    Worked perfectly.  Thanks for the post.

  • gregar Level 1 (0 points)

    I bought a Mac Mini with Lion pre-installed and could not update iPhoto as I kept getting this same error. At the same time I bought an iMac with Lion pre-installed and it updated iPhoto without a hitch.  So I went back to the Mini and tried this solution and it worked...instantly.  Thanks so much for this fix.  I can stop scratching my head, at least for a while.

  • Buzzfriend Level 1 (0 points)

    Thankyou thankyou thankyou!  I got the run around from Apple support then found this post...yahoo...I can now download software again!

  • rob-via-mac Level 1 (0 points)

    Thanks, this solved my problem  

  • Paradise Pete Level 1 (10 points)

    None of these solutions worked for me. After watching the directories and the errors (in the console app) it seemed like it was unable to create a file it needed. So on a hunch I ran Disk Utility -> Repair Permissions.

     

    Problem solved.

  • kevinpk Level 1 (0 points)

    PERFECTO.  Thanks.