13 Replies Latest reply: Jan 3, 2013 5:59 PM by mightyquin
kelato89 Level 1 Level 1 (0 points)
Whenever I click the "install" button, it shows that it's downloading, but it doesn't appear on my dock or applications folder. Then I go to the "purchases" tab in the store window, and it shows another "install" option. So I click it and it starts installing, but again it doesn't show up anywhere, not even when I do a search in Finder. Then when I refresh the store window, it shows the "install" button again. WHY AREN'T MY APPS INSTALLING???

iMac, Mac OS X (10.6.6)
  • Carolyn Samit Level 10 Level 10 (100,380 points)
    Hi and welcome.....

    Troubleshooting help here for you.

    Mac App Store







    Carolyn
  • kelato89 Level 1 Level 1 (0 points)
    Thanks for the reply, but all the troubleshooting says is this:

    +"If the app is listed under Purchases as "Installed"+

    +Look in your Applications folder again for the app.+


    +If the app is listed under Purchases with an "Install" button next to it+

    +Click the Install button. The app will then be downloaded and installed into the Applications folder. You will only be charged for the app one time."+

    I did these things and nothing worked. I even tried restarting the computer, but the same thing keeps happening.
  • kelato89 Level 1 Level 1 (0 points)
    bump
  • Barney-15E Level 8 Level 8 (43,320 points)
    Open Disk Utility and repair permissions.
    Then try again. I'm just guessing that it is trying to move it to the Applications folder, but failing for some reason without reporting.

    Also, open Console (Utilities folder) and see if there are any messages relating to the Mac App Store that might indicate a problem.
  • kelato89 Level 1 Level 1 (0 points)
    Thanks for your help!

    According to Console, it looks like it's trying to go to /applications/akamai/loader.pl, but then it says "No such file or directory".

    Is there any way I can get the app store to send the app to a different location?
  • Barney-15E Level 8 Level 8 (43,320 points)
    Just saw [this post|http://discussions.apple.com/thread.jspa?threadID=2711948&tstart=0] pop up. See if that works for you.

    Also, I don't think they meant to delete the whole /Library/Caches folder, just the com.apple.appstore in both locations (if it exists). I only found it in my user caches.
  • kelato89 Level 1 Level 1 (0 points)
    I cleared the cache folder but still nothing. And I tried restarting the computer after that, but right now when I click on purchases, it says that the app store is unavailable.
  • kelato89 Level 1 Level 1 (0 points)
    I just downloaded another app perfectly fine. Maybe it's just not working for certain apps.
  • Jen 15214 Level 1 Level 1 (0 points)
    I am having the same trouble and am super frustrated. I purchased Pages and a free app. Neither would download, just sat in "Waiting...". I did everything...cleared caches, removed the user cache file, restarted everything. Even contacted Apple and they were unable to help so far--apparently I've been escalated to a senior advisor, but I'm not sure how long it will take to hear from someone there.

    Extremely frustrated. I'm out $20 for Pages and want my app!

    If I get a good solution from the senior advisor, I'll post it here.
  • danzitting Level 1 Level 1 (0 points)
    I don't suppose you figured this out? I have the exact same problem with one app that I had uninstalled to install the App Store version. Now it won't install and have tried clearing caches, etc., etc. like you. On the Puchases tab in the app store I click the"Install" button, the button changes to "Installed", but the app is nowhere to be found. Then, when I switch tabs in the App Store and go back to purchases, the button has changed back to "Install". Driving me crazy
  • Mark Miller8 Level 1 Level 1 (35 points)
    Same problem here. I had Xcode and it was having problems updating so I deleted the app so I could just install again. I have it in my purchased list and the Install button is there but clicking does nothing. Very frustrating especially since I went with the app store version to simplify updates. Now, I can't even get a working copy to do my work.

    Time to dig through the Time machine backups.....
  • justshady Level 1 Level 1 (0 points)
    Same here, GrowlVoice waiting for the past 2 days. I deleted, reformatted, cleared, repaired, reinstalled. Nothing
  • mightyquin Level 1 Level 1 (0 points)

    I'm having the same problem right now, did you manage to sort the problem out and if so how?

     

    There are many similar threads on here, but none I've found say whether or not the problem was resolved - almost as frustrating as the problem with the app!!

     

    Thanks,