6 Replies Latest reply: Jun 25, 2011 7:39 PM by chrisoundz
dougtomp Level 1 Level 1 (0 points)
I've seen similar posts, but there doesn't seem to be an answer.

I can connect my iPod Touch to my wireless router but cannot connect to the internet. Safari gives the following error:
"Cannot open page. Safari cannot open the page because it is not connected to the internet".

Other devices (wireless and not) can connect to the internet.

In the Wi-Fi settings, I have an IP address and subnet mask, but nothing for Router or DNS. I have reset the Wi-Fi settings a couple of times.

The router is a SpeedStream 6540.

Any help would be appreciated.

Windows XP Pro
  • lllaass Level 10 Level 10 (157,850 points)
    What IP address is being assigned? If it starts with 169 you never connected to the router. If you tried all the other suggestion in other discussions I have no additional suggestions.
  • dougtomp Level 1 Level 1 (0 points)
    Thanks - yes, the IP address does start with 169 ...
  • lllaass Level 10 Level 10 (157,850 points)
    Have you tried the standard "fixes":
    - Resetting iPod
    - Resetting network setting on the iPod
    - Powering off and then back on the router
    - http://support.apple.com/kb/TS1398
  • JimHdk Level 7 Level 7 (27,290 points)
    dougtomp wrote:
    Thanks - yes, the IP address does start with 169 ...


    The DHCP service on your router is not working correctly. This is why you get the 169... IP address. Is DHCP turned on in your router or have you assigned fixed IP addresses to your other devices?

    I believe that the SpeedStream 6540 is a combined DSL/router/wireless AP with 802.11b/g capability. It's not the newest equipment ~2004. Presumably you got this box from your DSL provider? You might want to check with them to see if there is a firmware update for this box or if they could provide something newer/better.
  • dougtomp Level 1 Level 1 (0 points)
    Thanks. Yes - this is the box from the provider. Hmmmm ...I don't recall manually assigning IP addresses to the laptops we have but my kids actually set up theirs.

    I just tried updating the firmware, but it failed. Next step - I'll call Bell.

    Thanks for your help!
  • chrisoundz Level 1 Level 1 (0 points)

    I had the same problem on older dsl modems if your IP address is 169 you must connect to your router even if it is showing bars that your wii-fi is available & working. It took some time for me to figure this out but you must go to settings click on wi-fi (even if its showing your wii-fi signal name & that it is on it will only do this if you put in a password which is usually on the back/bottom of your modem in form of a sticker that reads device/access code or something similar  or it may do this automatically remember just because you are connected doesn't mean you have access as of yet) Ok so here's the trick to it all you must select other then type in your network name same as your wii-fii name for example mine is a # yours maybe speedstreamer560 etc  and then enter security code which is usually found on the back or bottom of your modem it will usually be a very very long # if it is wep you may also have wpa wpa2 etc your modem's sticker will let you know what you have so make sure under the security tab you press the > to select the security that applies to you. then yousave it or press done I forget it says and you will be connected but you must make positively sure you typed in all the right info especially those of you with wep theres like a combo of letters & #'s totaling 26 so just one mistake & no connect. Hope this has helped