Previous 1 2 3 Next 30 Replies Latest reply: Dec 20, 2011 6:31 AM by nisson Go to original post
  • Stephen McNutt Level 1 Level 1 (0 points)
    I've got the same problem--"Cannot Connect to the App Store". I've tried:

    1. Repairing permissions
    2. Changing Keychain Access settings as suggested by PAP60
    3. Creating a new admin account
    4. I'm not running anything like Little Snitch.

    None of this worked.

    I don't know how to do this, PAP60: ...also added App Store to the apps access list for the appleid.apple.com and id.apple.com items.

    Any more suggestions?

    Message was edited by: Stephen McNutt
  • PAP60 Level 1 Level 1 (0 points)
    To answer your question: "I don't know how to do this, PAP60: ...also added App Store to the apps access list for the appleid.apple.com and id.apple.com items."

    On the keychain access app, find the item (appleid.apple.com, id.apple.com), double click to open the item, click on the "Access Control" tab, click the "+" button on the bottom left below the list of apps, a selection window will open, navigate to the Apps folder and select the App Store app.

    It is probably not necessary to do this but it won't do any harm either. Before I did this I created another account and noticed that the App Store would work on that account which made me suspicious of the settings on my normal account. Seems that another account did not work for you so your problem might be something entirely different.
    My only other suggestion is if you have a router with a firewall enabled. Did you check router's firewall settings?
  • zkarj Level 1 Level 1 (0 points)
    I have had this problem more often than not since the app store launched. It seems to coincide with what are busy times for my location (I'm in New Zealand). So I suspect it may be related to traffic somehow.

    In short, the only solution is contained in the help for the App Store app...

    "Try using App Store again later."

    It *****, but that's all there is to it, I think.
  • habermas Level 1 Level 1 (0 points)
    I have the same problem using the Mac Book Pro from work. I tried all the solutions mentioned in the above but none work. My iMac at home has no problem accessing the Mac store. My colleague here at work using a MacBook Pro 13 inch latest generation does not have the problem with the Mac App Store not loading and he connects through the same network..
  • Stephen McNutt Level 1 Level 1 (0 points)
    Thanks, PAP60. Unfortunately, no cigar so far. I don't have either of the items you specify in my Keychain Access app, and yes, I do have All Items specified for Category in the left pane and have looked in all Keychains categories in the left pane (login, FileVaultMaster, System, and System Roots).

    I do have Apple .Mac Certificate Authority, auth.apple.com (Passwords not saved), and auth.me.com (Passwords not saved).

    Here's some more information:

    1. My AppleID seems to work fine. I used it to log into this forum on the same network from which I'm trying to access the App Store.

    2. While I AM on my school district's nasty Windows network, I'm my school's instructional technology specialist, so I know what I'm doing for the most part. And...

    a. I can access the iTunes Store, .Mac, and my iDisk from within this network.

    b. My friend and counterpart at another school in the same district (and so in the same WAN) is able to access the App Store.

    c. I don't know whether I mentioned this, but I can access the App Store from home, although that's on a different Mac, a four year old MacBook.

    3. In the Keychain Access preferences, Certificates tab, I've got Best Attempt, Best Attempt, and Require Both selected right now, but I've tried the other two choices for the third parameter, too.
  • Stephen McNutt Level 1 Level 1 (0 points)
    Here's some more weirdness. I noticed the Store --> Login option in the App Store menubar. I tried logging in with my AppleID (not including @mac.com), and I got a message that my account had been disabled for security purposes and that I should visit iForgot. I don't know what iForgot is because typing iForgot into the browser address field doesn't get me anywhere, but I clicked the Forgot link above the message, and that took me to a page to change my password. I failed the verification questions because apparently my birthday isn't entered properly and temporarily gave up that pursuit. Instead, I went back and tried Store --> Login in the App Store app again, but this time I used my AppleID INCLUDING @mac.com, and it apparently logged me in because now it says Store --> Logout. However, I'm still staring at the Cannot Connect to the App Store screen.

    Message was edited by: Stephen McNutt
  • Stephen McNutt Level 1 Level 1 (0 points)
    And yet more information: In the App Store, I can select Store --> View My Account, and I can log in there successfully and see my account information.
  • MASJsy Level 1 Level 1 (0 points)
    Hi everyone,

    I have tried everything suggested beforehand.

    My story is that I upgraded my hard drive to move from Parallels to Bootcamp. Prior to the upgrade I was running 10.6.6 with Apps Store access no problems.

    I did a fresh install from the Snow Leopard DVD, did the 10.6.6 combo update and BANG, no Apps Store access.

    I then reintalled AGAIN and instead of going straight for the 10.6.6 combo,I downloaded the 10.6.5 combo, and then upgraded to 10.6.6 from there. SAME STORY!

    I have no other software on the machine. I certainly don't have APE or Fruitmenu - in fact I had never heard of either of them until yesterday when I encountered this issue and was seaching for the fix and saw this:

    http://support.apple.com/kb/TS3638

    Come on Apple,get this sorted! We actually want to use a feature that MAKES YOU MONEY!

    VERY p*ed off!
  • webLuthier Level 1 Level 1 (0 points)
    I am having the same problem.

    When I launch the App Store, it "Cannot Connect to the App Store". I too have tried all of the suggested in the thread (reinstalling the latest OS update, changing the Keychain settings, repairing disk permissions, etc.) without success.

    Also, when I select "Store > Sign in..." or "Store > Create Account...", nothing happens.

    I have tried to access the App Store on multiple networks (home, work, public, friends...).

    Thoughts?

    Thanks.
  • MASJsy Level 1 Level 1 (0 points)
    I have finally fixed my problem. However, it's not a real fix - but it's now running.

    LONG story short:

    I called Apple Support today and although my MacBook is out of warranty by a year, they tried to help. 3 hours on the phone I was at the same point I was before I called. It's now escalated to 'Engineering'.

    The 'fix':

    1. Install from the Snow Leopard DVD over the top of the exisiting install which preserves all users, data & Apps. This returns your 10.6.6 OS X back to 10.6.0

    2. Download each 10.6.X update manually - I didn't download 'combo' updates other than 10.6.5 as that's all I could find, but it didn't matter as it turned out.

    3. Install each update in order, reboot and then install the next.

    4. After 10.6.6 update (not the combo update) it worked again.

    Note:

    I had previously installed 10.6 on a fresh hard drive as a test and had upgraded straight to 10.6.5 combo and then to 10.6.6, but the App Store was broken still.

    My best guess is that there is something in one of the previous updates to 10.6.5 which the Mac App Store depends upon.

    Message was edited by: MASJsy

    Message was edited by: MASJsy
  • delhiboy Level 1 Level 1 (0 points)
    Bravo! Take a bow PAP60 - I just upgraded to 10.6.6 and had the same issue. You saved me HOURS of debugging/re-installing/frustration with your "Keychain Access" solution. Thank you!
  • mculmore Level 1 Level 1 (15 points)
    For the last week or so, since all the storms started across the US, I have found the same issue at various times, but mostly at peak use times, and all has come back fully and shortly. Probably many bottlenecks along the route. I have seen this only on Apple.com, support portal, Software Update, App store and iTunes stores, really anything Apple, and almost always all are unable to be connected to and ultimately timing out. ALL other sites are just as fast opening as usual, and other applications that need access to the internet for updates either internal to the application itself or otherwise. But Apple sites all come back, presently hours later and just slower than I can remember since modem days.

    So, to beat that bottleneck, pop open a longneck and relax.
  • jasonfromwakefield Level 1 Level 1 (0 points)

    Also worked  for me thankyou very much

  • Ricky Barnaby Level 1 Level 1 (25 points)

    Pap60s solution worked for me

    i did add app store to Little snitch, it was set to deny.

    i also added it to allow incoming connections in my security prefs

    then i did pap60s solution...

     

    1. Open Keychain Access

    2. Keychain Access > Preferences

    3. In Preferences window select the certificates tab

    4. The first option: "Online Certificate Status Protocol" select "Best Attempt"

    5. The second option: "Certificate Revocation List" select "Best Attempt"

    6. The third option: "Priority" I left alone, is set to "Require Both"

     

    relaunched app store and YES

     

    thanks Pap60

  • robganly Level 1 Level 1 (0 points)

    my macbook's charger happened to die halfway through a software update then when i got a new charger this kept happening, pap60's solution also helped solve it for me.  great work pap60!

     

    rob ganly