1 2 Previous Next 20 Replies Latest reply: Mar 13, 2012 9:20 AM by cajphoto
LoneWolfBW Level 1 Level 1 (0 points)
I have just used Bootcamp to install Windows 7 Enterprise 64-bit version on my Macbook Pro (6,1 2010 edition). (This was done because I need a particular application at work that requires Windows to run.) The Macbook Pro is running with the following details:

OS: 10.6.6
Intel Core i7, 2.66GHz
8GB RAM
500GB SSD HD
Paritioned for 150GB for Windows/Bootcamp, the rest for my OS X.
Wireless: Broadcom BCM43xx 1.0

Installation of Bootcamp and Windows 7 went without a hitch. I did have to use a compatibility tweak and run as Admin to install Boot Camp 3.0 off the DVD, and then downloaded and installed Boot Camp 3.1 and 3.2 updates from the website. (I used this website to assist: http://michael.anastasiou.me/index.php?option=com_content&view=article&id=22:qbo ot-camp-x64-is-unsupported-on-this-computer-modelq-solution&catid=7:how-to&lang= en )


Once all this was finished, I noticed that I had no wireless connectivity. A further check showed that the drivers had not installed. I then took the following steps:

1) Following advice found on http://forums.whirlpool.net.au/archive/1308795 - I went into the Snow Leopard DVD and extracted the drivers from the following location: DVD>Boot Camp>Drivers>Broadcom> BroadcomInstaller64.exe. I used Device Manager in Windows to select these particular drivers, using the "Have Disk" option. When I completed the update, the following error occurs: "Broadcom 802.11 Multiband Network Adapter. This device cannot start (Code 10)."

This suggests to me that I actually have the wrong driver. But considering I selected it from Boot Camp, that seems a bit strange. I also tried using the BroadcomInstaller.exe from the same location, but the same problem occurs.

This brings me to my questions:

1) Am I perhaps using the wrong procedure to update the Wireless drivers here?

2) If not, and I am correct in assuming I simply do not have the right driver, then what drivers should I be using if not the ones on the DVD? I did some checking on Google, but I did not have any luck in finding a version that will work.

Thanks,

Brian

Macbook Pro, Mac OS X (10.6.6)
  • 1. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    LoneWolfBW Level 1 Level 1 (0 points)
    Update:

    I downloaded the following: http://download.cnet.com/WLan-Driver-802-11n-Rel-4-80-28-7-zip/3000-2112_4-16241 1.html

    But it too has failed. After attempting to install the driver, it remains an error mark in Device Manager with the following message: "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

    Evidently still not the right driver.
  • 2. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    Mel64 Level 1 Level 1 (5 points)
    Are you running AVG 9 full version? The reason I ask is I am having a similar problem with a friends Macbook Aluminium (2008). It has been dropping the network for about 6 months. Last week it lost the Airport Card altogether. The machine is mainly used in bootcamp running Vista.

    It also says "No Airport Card Installed" when clicking on the Airport menu icon under OSX.

    There are posts around with similar problems and no answer, but I noticed most were those running Bootcamp. I upgraded to Snow leopard hoping it would update something, but it still would not come on. I also upgraded to Windows 7 hoping it would update drivers.

    I uninstalled AVG9 as the upgrade to Windows 7 stated to do and on restart the wireless card came back on. I have restarted 3 times in both windows and Mac and it still works okay. I am about to re install AVG to see if that is the problem. I can't work out how it would effect OSX though.
  • 3. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    mjnicolls Level 1 Level 1 (0 points)
    I installed the upgrades to bootcamp to get me to 3.2. I don't know if this helped or not but alone did not get me airport connectivity. What was finally successful for me what to go to my original macbook pro discs and run this ... Boot Camp/Drivers/Broadcom/BroadcomNetworkAdapterWin7_64

    This worked. I had also previously uninstalled the old driver through the control panel/system/device manager.

    So apparently using the driver installs from the Snow Leopard and bootcamp upgrades don't do the trick. Now on to my audio drivers.
  • 4. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    audion1nja Level 1 Level 1 (0 points)
    I am having the same issues with my wireless driver. It was working fine a couple weeks ago, but I lost the wireless driver a couple days ago on BootCamp, and decided to do a fresh install to see if that would work.

    I followed the same steps you did with the compatibility-run of the BootCamp drivers off of the Apple disc and then updating to 3.1 and 3.2 from the site. Saw the same missing Network Controller, tried installing the Broadcom x64 drivers, and got the same Code 10 error.

    I don't understand why this was working two weeks ago for me and now it's gone. Airport still works fine in OS X.
  • 5. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    audion1nja Level 1 Level 1 (0 points)
    So I had a fresh install of Windows 7 x64, but apparently it wasn't completely fresh.

    To resolve this, I had to nuke the Boot Camp partition from Disk Utility, rerun Boot Camp Assistant to repartition the space, and reinstall Windows again to get the wireless drivers working properly. Other than that step, I did everything exactly the same as described above, and for some reason the WLAN driver decided to start working again.

    Hope you have the patience and time to try this for a fix.
  • 6. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    earlybird63131 Level 1 Level 1 (0 points)
    Problem solved! (at least for my configuration which it the similar to Brian's.)

    PURCHASED copies of OS X 10.5 & 6 do not contain a wireless driver. If you use Control Panel > Device Manager > Network Adapters you see two Blue Tooth and one ethernet drivers. On the other hand if you install drivers from the DVDs that came with the computer I get those three plus the wireless driver and things work beautifully. As a 27 year user of Macs I have difficulty remembering when I removed those DVDs from the box. (-:
  • 7. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    JC_Ted Level 1 Level 1 (0 points)
    Thank the lord for this post!

    I've spent two days trying to fix this on a brand new MBP and was about to launch it out of the window.

    Thanks for posting, it certainly helped me

    Message was edited by: JC_Ted
  • 8. Re: Wireless Drivers not functional Windows 7 x64
    The hatter Level 9 Level 9 (58,880 points)
    It would be nice if:

    Apple posted drives or provided them to MS so that
    Windows had access to and included with Windows 7 SP1

    Go out and buy 10.6.3 DVD $29 retail would have everything needed.

    If your OEM DVD came out in 2007 or 2008 you may be on the "banned from supported to run Windows 7?" there are "unsupported" x64 group of which I am one.

    But you have to use OS X DVD (PDF Guide in BCA) to run and install Apple Setup.exe to get drivers, services, and of course chipset HAL (hardware abstraction layer), ie, motherboard support which is needed normally anytime you run an OS. Apple goes a step further with BIOS/Firmware for the OS.
  • 9. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    Christine Dattilo1 Level 1 Level 1 (20 points)
    I found my answer finally on an archived thread here.

    I have Windows 7, Bootcamp 3.2, Broadcom driver identified as 802.11(n) - but I followed the below to get my wireless working on a MacBook Pro.

    The trick is to google by the Device Instance Path (ID) . I was able to find a BCM4353 driver here: http://wikidrivers.com/wiki/BroadcomBCM43xx5.60.18.8

    Once you get the driver extracted, install it manually by browsing to the directory where the extracted driver is and choose the Broadcom 43224AG 802.11a/b/g/draft-n Wi-Fi Adapter.
  • 10. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    skullmunky Level 1 Level 1 (0 points)
    Thanks for that tip, that's exactly what I've been searching for. Although it still doesn't work for me. I have a 15" i7 MBP. The wireless card isn't being identified, it's just listed as "Network Controller" in Device Manager. It's ID is

    PCI\VEN14E4&DEV4353

    which wikidrivers says is a BCM 43224AG.

    Here's what I've tried:

    * installed drivers using the Snow Leopard install DVD
    * downloaded drivers from wikidrivers.com:
    BCM43xx5.60.18.8win6x, BCM43xx5.60.18.12win6x, BCM43xx_5.30.20.0.

    60.18.8 and 30.20.0 will both install but the card is still not being recognized. The setup file in 60.18.12 seems to be corrupt.

    Anything else I should try? This is really baffling me ...

    thanks ...
  • 11. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    Christine Dattilo1 Level 1 Level 1 (20 points)
    @skullmunky What I did was I uninstalled the Network Controller, then I went to Manage Devices and added a new device, choosing the wikidriiver I indicated above. This added the correct driver.

    Try uninstalling the Network Controller first. Then adding it manually back in. At least that is the sequence that worked for me.

    Good luck, I’d been searching for an answer for months and am thrilled to finally find something that worked.
  • 12. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    Nik_2213 Level 1 Level 1 (0 points)
    "go to original macbook pro discs and run this ... BootCamp/Drivers/Broadcom/BroadcomNetworkAdapterWin7_64"

    Thank you, thank you, thank you...

    I've spent many miserable hours googlin', installed & rolled-back drivers other forums have suggested, come perilously close to hurling the stupid machine down the stairs...

    Now I just have to figure out why it connects wirelessly to the further two of our three WAPs-- But NOT the one just three feet away
  • 13. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    skullmunky Level 1 Level 1 (0 points)
    @christine - thanks ... still no joy. I eventually gave up and installed XP 32 bit. I got the broadcomm driver to work by running the boot camp 3.0 installer, running 3.1 update. and then running 3.1 update again. and waving a dead chicken over it. not my original plan but oh well, close enough
  • 14. Re: Wireless Drivers not functional under Windows 7 x64 using Boot Camp
    bbhflts Level 1 Level 1 (0 points)

    I have an almost identical problem.  New MBP13 2011.

     

    I tried all the above fixes and no joy:-(

     

    Wireless is bullet proof when running OSX.  100% reliable for months for general internet browsing and massive 100+ gig file transfers to my home theatre system and backup NAS.  I only experience the intermittent connectivity when running bootcamp windows 7 x64.  Tried updating the driver to the original osx bootcamp one, tried the broadcom ones that comes with windows etc...  Always the same crap or they refused to install.  Tried the latest one from apple via the update also with zero joy. 

     

    The only key difference I'm seeing from you is that the wireless adapter did install when installing the bootcamp drivers.  It also behaves intermittantly.  It associates with my access point, and I can see that L1 and L2 are fine, I even see DHCP requests and get an IP address.  It may work fine for a few hours or a few minutes or seconds and then suddently it craps out with a yellow triangle and black exclamation mark on the tray icon.  When it does crap out, I notice that in the connection status that it's not receiving any packets anymore.  More likely the IP stack on the driver is dropping corrupted packets or something similar and it is actually receiving the packets, but dumping them.  Next step is to sniff the interface and be 100% sure that the packets are coming in.  I need to be sure that L1 and L2 are being maintained and not dropped without windows telling me.  Eitherway, this does seem to be a driver issue.  What would be nice would be be able to clean the registry and all old driver files to start again with a clean slate without having to scrub my Bootcamp partition.

     

    Any suggestions?

     

    Cheers.

     

    Ben.

1 2 Previous Next