8 Replies Latest reply: Oct 17, 2011 1:59 PM by BenGuilbaud
SteveMacUser1 Level 1 Level 1
I have a MacBook Pro 13" I purchased October of 2009, and I have a unique problem concerning my Display. When using an external monitor, IF I try spanning across the two monitors (share both montiors for my desktop), I experience a complete lock-up of my mac (freeze, white screen, must reboot). If I mirror displays, no issue. I thought perhaps it was the resolution, but I notice the problem on any resolution. The logic card on the mac has been replaced at the Genius Bar to no avial. Anyone having this problem ? Is this just a driver issue ?

MacBook Pro 13", Mac OS X (10.6.5), Purchased October 2009
  • sandfox Level 1 Level 1
    Me too. I am using macbook pro with 24" external monitor.
    I had thought this problem is over when I updated 10.6.5.
    But it have happened again. Sometimes display of my macbook pro change to white color and I can't any control.
  • Alex_miksa Level 1 Level 1
    Out of curiosity have you tried resetting pram and smc? Also have you booted off the install disc and tried doing a repair disk? Definitely a weird issue, are you running any intensive applications while you are moving that program to the next screen when it freezes?
  • karoy01 Level 1 Level 1
    I also have a dual monitor set up and experience white screens periodically. The Genius bar replaced my hard drive but that didn't help. Actually, it made things worse since they didn't know to tell me special things to do to backup outlook and I lost my virtual box info as well - time machine is not perfect.
    I was wondering if there is any difference based on whether you use a VGA or a digital interface?
  • ajweedman Level 1 Level 1
    I have the same issue. My Macbook is less than 3 months old and I cannot find the answer. It will work fine when connected, then randomly I get the white screen on both and have to hold the power button down to restart.

    HELP!
  • tastentom Level 1 Level 1

    I have exactly the same annoying issue with my Macbook Pro, 13", purchased in 2010. How can this be fixed?

  • rogierfm Level 1 Level 1

    Having the exact same problem with my Macbook Pro 13"....

  • starryeyez024 Level 1 Level 1

    I have been experiencing the same problem with my Macbook Pro, 13", but my boyfriend has the same computer and uses dual monitors all the time with no issues.

     

    We both have the same "About this Mac" Graphics/ Displays descriptions:

    NVIDIA GeForce 320M:

     

      Chipset Model:          NVIDIA GeForce 320M

      Type:          GPU

      Bus:          PCI

      VRAM (Total):          256 MB

      Vendor:          NVIDIA (0x10de)

      Device ID:          0x08a0

      Revision ID:          0x00a2

      ROM Revision:          3533

      Displays:

    Color LCD:

      Resolution:          1280 x 800

      Pixel Depth:          32-Bit Color (ARGB8888)

      Main Display:          Yes

      Mirror:          Off

      Online:          Yes

      Built-In:          Yes

    Display Connector:

      Status:          No Display Connected

  • BenGuilbaud Level 1 Level 1

    Had the same problem with a 2010 13" MBP. Froze after a few minutes when hooked up to certain external displays. Hard to hard reboot, etc.

     

    Had the motherboard replaced (thank you AppleCare) and that sorted the problem. Guy at the Apple Store had never heard of the problem, couldn't reproduce it, but took my word for it.

     

    All sorted now and very happy.