9 Replies Latest reply: Feb 4, 2011 1:01 PM by vince730
vince730 Level 1 Level 1 (5 points)
For the past few months, I've noticed that in iTunes the only backup that shows in the list in the Preferences menu is for my iPod Touch (and closer inspection within Finder agrees with this), with a date stamp from 5/25/10 -- Yikes. I've synced my iPod MANY times since then. Recently, after getting my iPhone 4, I restored my iPod Touch and noticed that it restored to this old backup from May rather than the backup I just performed prior to restoring. I also notice that even though I have also synced my iPhone 4 many times, there is no backup file in iTunes. I'm getting very worried that when a software update comes out iTunes is going to say that my iPhone is backed up, but then give me no choice but to restore from this old iPod Touch backup. Why is iTunes refusing to actually backup any of my iDevices?

iPhone 4, iOS 4, Mac OS X 10.6.6, iTunes 10.1.1
  • alryder Level 2 Level 2 (220 points)
    With your iPhone connected to your computer try right clicking on your device in the left hand column under devices. There should be an option to manually backup (simply listed as "Back Up") your iPhone. If there is some problem preventing your iPhone from being backed up maybe this will produce an error message that will help troubleshoot why the backup process is not working.
  • RainingOutside Level 1 Level 1 (0 points)
    I had used this manual backup process; it appeared to do it properly; Inc zero error messages. But then first of all when tried to restore from backup iTunes said backup failed (even though backup was created on laptop; located and checked it via NON iTunes tool). Future attempts appeared successful backup process, but iTunes not even showing datestamp.
    Sep thread lists selection of whole host of probs currently experiencing, all since on win 7. Can iTunes function properly in 64bit?
  • vince730 Level 1 Level 1 (5 points)
    Here is what I see:
    http://i53.tinypic.com/r9n41e.png

    Unfortunately I don't get any error messages. My iPhone always Syncs correctly, yet there is no backup file where it should be. I also just tried deleting the old iPod backup file and syncing just in case it was corrupted and causing problems, but nothing has changed.

    @RainingOutside - I've heard quite a bit about the problems with 64 bit Windows 7 too. But in my case it is not an issue since I have a Mac
  • RainingOutside Level 1 Level 1 (0 points)
    Oooops sorry
    Musta had two similar threads open same time and confused users

    With the backup method you were able to use... Maybe navigate directly (NOT via iTunes) to see if it created files in Mac (but just can't see via iTunes); if DID create backup files ....maybe (working on a copy of them) see if a backup extractor works successfully with the files? I know it not fix the core prob, but at least saves your contacts etc. in more recent backup. Won't fix another test that might help you narrow down

    That was the only way I could retrieve my contacts etc; iPhone still not syncing etc but at least I was able to extract all my photos, contacts, etc using non-iTunes method. Ie backup process had shown as successful; then iTunes later would not restore (THEN it said backup failed); BUT files were all there on laptop... If used tools other than iTunes.

    Hope that all makes sense
    And not just more frustrating given it not a solution
  • vince730 Level 1 Level 1 (5 points)
    I have navigated to ~/Library/Application Support/MobileSync and there are no device backups. So unfortunately a Backup extractor won't be of help since there is no backup to begin with.

    What is so odd about this is Syncing occurs with no problems or error messages, purchases copy between iTunes and the device fine, and iTunes displays that it is backing up, but no backup is made. I'm beginning to wonder if there is something up on the iTunes side. Besides reinstalling, are there any .plist or similar files I could try trashing?
  • vince730 Level 1 Level 1 (5 points)
    Just bumping this up since it has been a week.
  • vince730 Level 1 Level 1 (5 points)
    Any ideas?

    I've also noticed that if I right click my iPhone in iTunes, I get NO option to manually "Back up"

    (See: http://km.support.apple.com/library/APPLE/APPLECARE_ALLGEOS/HT1848/HT1848transfe rpurchases.png)

    The option won't show up for any of my older iPods either....so there is a big problem on the iTunes side of things.
  • RobGutierrez Level 1 Level 1 (10 points)
    Make sure iTunes is closed and then type the following in Terminal:

    defaults write com.apple.iTunes DeviceBackupsDisabled -bool false

    defaults write com.apple.iTunes AutomaticDeviceBackupsDisabled -bool false

    Then open iTunes right click your iDevice and the manual back up option should be back.
  • vince730 Level 1 Level 1 (5 points)
    Thank you very much That worked perfectly.
    I wonder what causes that glitch to occur. Either way, I'm relieved to know I now have a backup so I can safely upgrade to the next version of iOS when it comes.