Previous 1 2 3 Next 32 Replies Latest reply: Apr 13, 2012 2:42 AM by Kackalaki Go to original post
  • vazandrew Level 6 Level 6 (17,190 points)
    No, that's not the case. You just need the iphone to have wifi turned on and be on the same network as the ATV.

    If you are home-sharing from your iTunes library then yes, you do need a computer on with iTunes running.

    Message was edited by: vazandrew
  • Roaming Abroad Level 1 Level 1 (10 points)
    I'm sitting in front of my Apple TV (the Apple TV with HDD) with all software updates confirmed and I'm using an iPHone 4 (4.2.1) and when I try to stream music there is no choice for Apple TV.

    I can use the Apple Remote App from my iPhone 4 to control the Apple TV.

    I can see the choice to stream to Airport Express in another room (don't have speakers on that Airport Express I use only to extend the wireless signal from the Time Capsule that sits in the same room as Apple TV).
  • ndmike Level 1 Level 1 (0 points)
    Did anyone ever resolve this issue? I'm having the same problem. Pandora and the iPod app appear to be streaming audio to my Apple TV (e.g., the status bar moves as if it's playing the audio), but it's not really working. Videos and YouTube both play fine (with audio and video). I've tried it from my iPad, my iPhone 3GS, and my wife's iPhone 3GS with the same results. I assume it's something with the Apple TV. Please help.
  • Roaming Abroad Level 1 Level 1 (10 points)
    Apple told me --when I called them on the phone-- that with the latest update to the iPhone software the disable the ability to stream music from the iPhone / iPad to the Apple TV (1st generation).

    The Apple technician I called had to put me on hold for 5 minutes and ask around to find out why it wasn't working.

    Later someone posted on this discussion board under a separate thread that everyone already knew that AirPlay between iPhones and Apple TV (1) was disabled.

    I have no idea why it would be disabled and it came as a big surprise to me.
  • ggarthe Level 1 Level 1 (65 points)
    I can't stream from any of the iPhones in my house (two iPhone 4's, two iPhone 3g's, and a 3GS) to my 2nd gen Apple TV either. I can stream from all my Macs just fine. I can also stream to my Airport Express from all the iPhones just fine as well, but as soon as I try to stream from an iPhone to the Apple TV, it's all done. I have to reboot both the phone and the Apple TV to get it to release it's hold for anything else to work. I can use Apple's Remote app to control the Apple TV just fine, and I can stream pictures, but no music.

  • ggarthe Level 1 Level 1 (65 points)
    Well, I found the problem...for me, and maybe others.

    I'm using a Netgear 802.11N router as my main source of wireless for the house. I also have an old Airport Express in the kitchen that isn't connected to internet, it's just used to stream music to speakers in the kitchen. So as an experiment, I brought the Airport Express to the living room, put in place of my Netgear router, mated both my iPhone and Apple TV to the Airport Express and voila, it works flawlessly.

    So in my case, Airplay from iDevice to Apple TV either doesn't like Netgear routers, or requires an Apple router to get the job done. In either case, it looks like I'm off to the Apple store to buy an Airport Extreme today, which is OK because I hate this Netgear P.O.S. anyway and have been looking for a good excuse to get permission to spend the money on one.

  • mlipm Level 1 Level 1 (0 points)
    Had the same problem with my iPhone 4 and atv2, but was sure this used to work. Rebooted the phone and the atv2 and now it works fine. I had lost the airplay icon in the iPod window, this was since I've been using a car cradle and Bluetooth headphones to listen to music, don't know if it's something to do with this as you select the audio send to when you use these.
  • Hollis_in_Oregon Level 1 Level 1 (0 points)
    I am having the same problem with my iPad and Apple TV. When I first got it, I was able to play from teh ipad through the Apple TV, but suddenly, whatever I do, I can't play it. The Apple TV works fine with my itunes, but not the ipad. THey are both on the same network. My computer with itunes is open. nothing seems to work
  • Jc4evermac Level 1 Level 1 (0 points)
    Like some of us I am not able to extreme pandora from the iPad to the atv 2 maybe you have the old apple tv and apple router extreme or express plus airport utility. Now this little box worth 100$ when you use it with XBMC app. Every time I tried to extreme pandora to the atv2 I double click home bottom and then press the airplay bottom to change to atv2 and pandora stops, when I press play again I received a message that pandora had found a problem, please to restart or reinstall, so I had done both and nothing change, for you information I got a new netgear dual band router, hope somebody can help me. Thanks
  • Bateman500 Level 1 Level 1 (0 points)
    I was running into the same problem. I could stream video from my iphone 4, but not ipod or pandora music. A reboot of the phone and suddenly it was working again.
  • Michael Daninhirsch Level 1 Level 1 (25 points)
    I had the same problem this evening, and found that unplugging the ATV2 and plugging it back in seemed to fix the problem. Specifically, the problem I was having was that I could use my iPhone 3GS to control my ATV2 (via the remote app) and to play music from an iTunes computer in another room. However I could not get music to stream from Pandora or iTunes on my phone to the ATV2. In Pandora I received the error someone mentioned previously in Pandora, stating there was a problem and the app had to be restarted.
  • ryanfromphiladelphia Level 1 Level 1 (0 points)

    I can confirm it is the router that is the problem.  I use dd-wrt for my netgear router.  Everything used to work, then suddenly everything EXCEPT ipod music worked for me as you say (even pandora worked).  Reboot/restoring etc...didn't work for me.




    I connected all the devices to a freshly restored aiport express and presto! everything worked EVEN ipod audio. Then I did some more testing and figured out that I needed to have my ATV and iphone on exactly the same type of network connection to work.  I originally had the ATV on ethernet and the iphone on wireless.  Once I disconnected the ATV from ethernet and connected them both to the exact same wireless ssid (I have a dual band router, so I have two ssid's) it worked like a charm.  My guess is that Apple changed something in the airplay protocol to make it better/faster/more compliant...whatever...


    Short-Term Fixing:

    connect your ATV to the EXACT same wireless ssid as the iphone.  If you have a dual band router, reconfim that it is on the exact same ssid and not the "n" connection.



    Someone need to figure out if it is a new bug, or more correct implementation of standard wireless communication protocol.  If it is the correct implementation, then the router software (like dd-wrt) need an update.

  • patriciafrombothell Level 1 Level 1 (0 points)

    Check the audio/video settings on your ATV2.  Sound effects need to be set to ON, and on the Audio out tab, try 16 bit.  This worked like a charm for me, and I can now stream the Bose am/fm app, Pandora, you name it, I can stream it from my iPod Touch and iPad2!!  I am so pleased because I have been struggling with this issue for a couple of weeks.  Here's a link that might help you also.


    Good luck - please post if this fixes your problem.

  • patriciafrombothell Level 1 Level 1 (0 points)

    Check the audio/video settings on your ATV2.  The sound effects need to be set to ON, and you might try changing audio output to 16 bit.  This worked for me, and I am streaming everything I can find now!!  Please post if this helps you.

  • _heath_ Level 1 Level 1 (0 points)

    I was having the same issue with my iPhone and iPad. I just reset the apple tv and it works fine now.