1 2 3 Previous Next 76 Replies Latest reply: May 23, 2014 9:39 AM by Allan Eckert
fazmanicg Level 1 Level 1 (15 points)
Signed in with my only apple ID.
Whenever I try to Update an installed app, I keep getting a popup windows that reads .....

You have updates available for other accounts
Sign in to (null) to update applications for that account.

I don't get it. Anyone experience this?
Advice on how to resolve?

Mac OS X (10.6.6)
  • 1. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    fazmanicg Level 1 Level 1 (15 points)
    When O look at the purchases tab, I do see my purchased apps. There is an UPDATE button to the right. I get the error mentioned above when I click on it. If I look at the Updates Tab, It says All apps are up to date. I only have ONE apple ID, and everything seems to be in order when I look at my account.
  • 2. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Richard Shanahan Level 1 Level 1 (5 points)
    I also have this problem. Angry Birds has had 2 updates, they will update and show I need the update on my macbook (where I initially purchased it), but on my macpro, it shows no updates and if I choose the 'update' link on the installed apps page I get the same error to login to (null).
  • 3. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Richard Shanahan Level 1 Level 1 (5 points)
    I forgot that I also have set the app store up on my family room mac-mini, I just tried that and it updated fine. The problem seems to only be on my macpro.

    Initial 10.6.6 updated on my mbp, purchased Angry Birds
    Updated to 10.6.6 on my macpro, installed Angrty Birds

    Angry Birds 1.0.1 came out, able to update on mbp, not on macpro

    Two days ago, updated mac-mini, app store, installed Angry Birds ok.

    Today, 10.0.2 came out, updated on mbp and mini ok, macpro shows no updates available and will not let me update the app. Verified version of AB is1.0.0.
  • 4. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    BinaryMango Level 1 Level 1 (10 points)
    Same thing happens to me with the "(null)" error when trying to update apps.

    I have been following this thread hoping someone posts an answer:
    http://discussions.apple.com/thread.jspa?messageID=12924034
  • 5. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Peggy Lynn Level 4 Level 4 (2,470 points)
    I don't know if this is the problem that others are having but my Apple and iTunes accounts have different ID's. I got a similar message and had to log into my other account to do the update. I can download stuff using either account.
  • 6. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    BinaryMango Level 1 Level 1 (10 points)
    Thanks Peggy for the suggestion; for me personally I only have a single Apple/iTunes account that I use for all Apple services, so I'm still stumped as to why I'm getting this error.
  • 7. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Peggy Lynn Level 4 Level 4 (2,470 points)
    The only thing I can think of offhand is that something in your Apple and iTunes accounts don't match exactly which confuses the App store application. If you check and find out that the information in both accounts is the same it would probably be a good idea to contact support for the App Store. The link is under Quick Links on the App Store Featured page.
    http://www.apple.com/support/mac/app-store/
    Click on the Account and Billing link on the left to get an email form.
  • 8. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    tamsler Level 1 Level 1 (0 points)
    I have the exact same issue. Apple please fix this.
  • 9. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Allan Eckert Level 8 Level 8 (41,525 points)
    This is a user to user forum. Apple isn't here. If you wish to let Apple know about the problem sent it to the feedback URL.


    ___________________

    Allan
    tiger

    ___________________
  • 10. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    strangebirds Level 1 Level 1 (10 points)
    I also have this. I have an Imac with a single user account on it and I've only used the App Store on this machine.

    Things I've tried that haven't worked:

    * Logging in and out.
    * Restarting.
    * Removing cache and preferences for storeagent and appstore in ~/library
    * Erasing all cookies and cache from Safari (as the App Store is a Webview I thought it was worth a shot)
    * Being sure I had no "haxies" that do code injection on my system. I read somewhere that there were problems with the app store and two of Unsanity's offerings, but those were related to downloading programs at all.
    * I've sent a message to Apple detailing the problem (and you should too! http://www.apple.com/support/mac/app-store/contact.html?form=account Under "Specific Request" choose I have another App Store question and fill in the details).

    I am able to delete the applications that show updates under the Purchases tab and download the new versions: Quit App Store, drag applications from Applications to the Trash, restart App Store, go to Purchases, and click install. Cludgey and it negates any benefits to the central location for updating, but it does allow you to update applications. Curiously this seems to point to something on individual machines as the issue as I can download already purchased applications to the same account, but then the problem reoccurs.

    Has anyone tried anything else so we can continue narrowing it down? Right now I'm downloading the 10.6.6 Combo Update to try reinstalling (last time I used Software Update) and see if that sorts it out.
  • 11. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    strangebirds Level 1 Level 1 (10 points)
    The combo update for 10.6.6 did not resolve this.
  • 12. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Peggy Lynn Level 4 Level 4 (2,470 points)
    Log into your iTunes account. It's probably not necessary but Reset all warnings for buying and downloading. Quit iTunes. That fixed my problem with the App Store not recognizing the fact that I had downloaded updates which is different from the OP's problem and yours. It didn't work for the OP but is probably worth a shot to try.

    When I emailed the App store about the problem I was having with updates the response I got for the two separate times I emailed indicated that the responder hadn't actually read the email I sent. I replied by politely stating that the problem was "x" as stated in my original email, not "y" in the response. That seemed to work to get them to actually read and comprehend my issue on the third try. However, I stumbled on the solution on my own. If you have AppleCare, calling them might be more helpful if you don't get a meaningful reply to the email you sent the App Store.
  • 13. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    strangebirds Level 1 Level 1 (10 points)
    Solved! (for me and hopefully others)

    I checked the console (Applications/Utilities/console.app) and found the following warning:

    [date] [time] mds[processID] (Warning) Server: No stores registered for metascope "kMDQueryScopeComputer"

    mds is part of Spotlight.

    I has disabled Spotlight by adding "Macintosh HD" to the Privacy tab of Spotlight preferences. I allowed Spotlight to reindex (by removing the root drive) and the updates now appear and I can update the apps without the deleting/reinstalling rigamarole. Unfortunately it appears the App Store uses Spotlight in some manner and having no scope specified caused the update process to fail for me at that point.

    Contacting App Store support resulted in an email offering to reset my password with no indication that my original had been read: I laid out solutions I had attempted, possible causes, etc. I received an email back that Denise could do nothing until I provided the requested billing information to reset my password, which I had said I didn't want to do just yet as it didn't seem to be related to the problem. So, good luck with customer service there…

    Hopefully this solves it for others as well. If someone comes up with a way to have Spotlight disabled and still get updates I'd be happier (or wants to experiment with exactly what scope is needed by Spotlight so I can disallow the remainder of the drive - mds and mdworker often start thrashing my drive and slowing down everything (or did - it's been off for awhile)).
  • 14. Re: Cannot Update Purchased App Store Apps ... Error message (You have updates
    Peter Jarvis Level 1 Level 1 (5 points)
    Solution: (Worked for me)
    Select the app in applications folder, right click, select "Move to Trash".
    Launch App Store
    Select updates in the App Store
    Select purchases.
    * App should now show "INSTALL"
    Select INSTALL
    * App is downloaded and installed
    Empty TRASH

    If this does not work, put the current app back and contact apple.

    Message was edited by: TechnoPhobe01
1 2 3 Previous Next