Previous 1 2 3 4 Next 76 Replies Latest reply: May 23, 2014 9:39 AM by Allan Eckert Go to original post
  • SC::UK Level 1 (45 points)
    Just to confirm, I tried this and it fixed it for me. A rebuild of the spotlight index was the solution, and the iMovie update that I couldn't download appeared in the updates and is now installing.

    In Summary:

    Go to System Preferences, then Spotlight
    Go to the Privacy tab, and add "Macintosh HD" or whatever you call your main drive.
    Close and check that spotlight has cleared the index for that drive - I tested by searching for iMovie or iPhoto.
    Go back to Spotlight prefs in System Prefs and remove the added "Macintosh HD"
    The index should rebuild (little dot in spotlight magnifier top right)
    When complete, App Store updates that were broken should work again.
  • kkampen Level 1 (0 points)
    I can confirm this solved my issue completely.
  • DonovanBartish Level 1 (0 points)
    Reactivating Spotlight worked for me... but I'm not too happy about it. In fact, I've already deactivated spotlight again, and I think I'll just shy away from the Mac App Store for the moment.

    My pro audio software (particularly Pro Tools) has guides for optimizing Mac OS for audio recording that specifically says to add the system drive to the privacy pane of the spotlight preference tab.

    I assume this is to keep real time recording from being disturbed by spotlight indexing.

    Anyways, my pro audio setup has priority over anything the Mac App Store might have to offer.

    I hope that Apple will devise a way for the update system to not be dependent on spotlight in the future. In addition, a system for uninstalling what you don't want would be nice as well.
  • fluffy Level 1 (25 points)
    I was having this problem after I upgraded the hard drive in my computer and used the migration assistant to pull the apps over. It seems that the migration assistant screwed up the file permissions. Uninstalling the app and reinstalling it did the trick.
  • FishComputer Level 4 (1,035 points)
    Delete the app, reinstall, you will not lose your data oddly
  • fluffy Level 1 (25 points)
    Of course you don't lose your data. Apps on the Mac don't tie the data to the app like they do on the iPhone.
  • JEinFLFL Level 1 (0 points)
    This worked for me. Thanks for the solution to a problem that shouldn't be a problem in the first place.

    Message was edited by: JEinFLFL
  • Hemlaw Level 1 (0 points)
    I have the same problem and this "solution" doesn't work for me. I have never been able to trash an app from the App Store. Trying to move it to Trash simply brings up an error message.

    This problem is NOT solved - at least not for me.

    It is disturbing that Apple would rig these apps so they cannot be trashed.
  • Allan Eckert Level 9 (50,731 points)
    Two points; first is the solution didn't work for you then you don't have the same problem. Secondly, it is solved for the person who stated the post and it is he can mark it that way. If you wish to continue the discussion you will have to start your own post for your problem. Once you do that then you will have to right to say when that post is solved.


    .
    .
    |___________________

    Allan
    tiger

    ___________________
  • fluffy Level 1 (25 points)
    Make sure you're trying to delete the app from an administrator account. If you're just getting an error message, either you don't have permission to do it (i.e. you're not an administrator) or the app is currently open. Or maybe something else is happening; you might try, I dunno, sharing what the error message IS.
  • Hemlaw Level 1 (0 points)
    I am, of course, logged in as an administrator. I have deleted hundreds of apps over the last 25 years on various Macs.

    The error message is:

    +The operation can’t be completed because an unexpected error occurred (error code -8072)+

    I don't recall seeing that before.
  • fluffy Level 1 (25 points)
    Hm, strange. Have you tried repairing permissions?
  • Hemlaw Level 1 (0 points)
    I doubt I am the only one scratching their head at the "Solved" flag. Seemed more useful to continue from other people's efforts than to till the same ground again.

    What has been posted here as solutions does not work for my computer.
  • Hemlaw Level 1 (0 points)
    Yes. I doubt it's a permissions problem as I had no problem trashing Google Chrome or MS Messenger.
  • fluffy Level 1 (25 points)
    Google Chrome and MS Messenger weren't installed by the App Store app.
Previous 1 2 3 4 Next