Previous 1 2 3 4 5 6 Next 76 Replies Latest reply: May 23, 2014 9:39 AM by Allan Eckert Go to original post
  • foureyedsoul Level 1 Level 1 (0 points)

    I had a very similar issue which prevented me from updating, only it was worded in a slightly different manner. Instead of reading "Sign in to (null) to update applications for that account," mine read "To update this application, sign into the account you used to purchase it."

     

    The thing was, I knew that I hadn't used any other account because I (a) don't have any others and (b) had posted a review for the app in question under the single account name I use.

     

    The Apple Support person was actually very helpful in my case – when I wrote that I'd already tried deleting the offending application and reinstalling it, Gautam explained that if there was still an icon pointing to it from the dock, the deleting and reinstalling procedure wouldn't work.

     

    Is there a chance that the folks who are still having this issue have references to their apps from the Dock or from a Stack? I'm not knowledgeable about the technical side of all this, but perhaps the Spotlight re-indexing "solution" doesn't work when there's an alias lurking somewhere in the Dock/Stacks?

     

    For the Terminal-averse, this is at least another thing to try, and it did indeed solve my issue. Good luck!

  • HariTech Level 1 Level 1 (0 points)

    Yes thsi worked for me too.  Seems that the App Store application thought it was not installed and displays the update notice but I guess when it starts the update the signature shows it alreay applied.  I suspect the message is trying to say you have updated this machine but maybe not some others?  In any event forcing a re-index of the hard disk cleared the problem.

     

    Many thanks, Lawrence

  • BugsMI Level 1 Level 1 (0 points)

    You presented a Solution that saved my sanity

     

    I've been attempting to get iTunes Support personal to understand the issue for three days:  "application was not purchased on this account Please login to that account and update.

     

    I even contacted my local Apple Store Manager to assist me in getting someone capable of assisting me with this Account Issue. He was understanding and told me he would contact corperate and go through channels to help me. He even offered me a copy of iLife 11.

     

    iTunes Support wanted me to uninstall my iTunes, when there was nothing wrong with it. my only issue, is iPhoto would not update.

     

    I've replied to Apple iTunes Support with your solution.

     

    Thank you.

  • Network 23 Level 6 Level 6 (11,865 points)

    Whew...the solution in this thread solved my problem. Simple regeneration of the Spotlight index, and now I can update my apps. Thank you so much.

  • mmb Level 1 Level 1 (10 points)

    I get the same as original poster "You have updates available for other accounts..."  I suspect that much of the problem occurred after i had to wipe computer and reload SL after a failed Lion upgrade.  Long story short, I think my spotlight indexed itself before I restored all my software and user files.  If that's the case then the solution of reindexing spotlight should do the trick. 

     

    On a side note, anyone else find it worrisome when told to enter a command "arch -i386 mdimport /Applications" for which no one seems to know what it does?  Gives me pause...

  • Network 23 Level 6 Level 6 (11,865 points)

    mmb wrote:

     

    On a side note, anyone else find it worrisome when told to enter a command "arch -i386 mdimport /Applications" for which no one seems to know what it does?  Gives me pause...

    I don't dabble in the command line much, in fact I fail as a programmer of any kind, but it doesn't bother me because it's not difficult to decode. The last part is obviously a path, the Applications folder. "mdimport" I recognize as a Spotlight command. "arch -i386" sounds like Intel CPU related. And that's before I look it all up. In the terminal you can type "man arch" to identify the "arch" command. Anything else I don't recognize I Google, because it's Unix and exists far beyond just Macs.

  • Zeran Level 1 Level 1 (0 points)

    me too but apple acts like i am kidding them lol I keep trying to tell them it is on thier end and they tell me I am the only one with this issue lol.  so they lie lol

  • Gary Sumlak Level 3 Level 3 (585 points)

    Perfect solution!! Worked for me as well when Evernote update said the app was purchased with another ID.  To those who chastized others saying the problem was the result of illegal apps,having a FREE app have the same problem proves that you don't have to be dishonest to have problems.

     

    Ta

  • fenechy Level 1 Level 1 (0 points)

    Sorry if I have missed this but I get the same error message as the oringnial poster but it actually states an e-mail account (username) instead of "Null". It is a user account I've never seen before and the e-mail enda @mail.ru

     

    I'm in the UK and am guessing .ru is Russia? Should I be worried if my Mac thinks a Russian user account I've never seen before is a user on my mac? Have I been hacked?!? Sorry for novis question - just freaked me out a bit.

  • Zeran Level 1 Level 1 (0 points)

    the proble is with spotlight you either have it turned off or it has becomed corrupted it you have it turned off you must turn it on

     

    here is a ling on turning it back on  http://www.technipages.com/os-x-leopard-enabledisable-spotlight.html

     

    Once it is active allow it to index and it will allow you to update your purchases on ap store. 

     

    If it has become corrupted you will need to

     

    1. open system preferences

    2. open spotlight

    3. select the tab privacy ( then add your hard drive to the privace items do this by clicking the pluss and then go down to the icon of your hard drive it should be at the bottom of the left side of the menu most are called macintosh. 

    4. restart your computer

    5. Open spotlight and the the privacy tab again and remove the hard drive bye selecting it and pressing the minus sighn. 

    6.  on you desktop the magnifying glass on the upper right should have the word indexing once it is finished indexing you should be able to purchase using app store again. 

  • asjk Level 1 Level 1 (15 points)

    Thanks strangebirds for your suggestion. Let me say what was need on my computer to enable the App Store updates. I removed my HD from the privacy list (see System Preferences>Spotlight>Privacy) and then made some changes so that the Application folder was NOT in the privacy list or that of any of its parent folders. Some other users--I suspect many other user--having this problem may simply need to make sure there is a checkmark next to Applications (number 1 by default) in the Search Results tab of the System Preferences for Spotlight.

    Summary: Spotlight indexing means that Appilcations can be downloaded again or updated from the App Store

    --jk

     

    PS the reason I wasn't indexing my root drive is because its SSD. My Users have their files on another drive.

  • CrescentMike Level 1 Level 1 (0 points)

    The MAS was also prompting me to update iPhoto and then showing the "You have updates available for other accounts..." message and telling me to log into my wife's account. My iPhoto app was up to date so this had me scratching my head!

     

    I finally realized that since Spotlight was being used by the MAS to verify the applications it was also looking at a clone of my wife's MacBook which was on a partition on the external drive connected to my iMac. it was the iPhoto app on the clone which needed updating.

     

    The solution was to open System Preferences and go to the privacy tab in Spotlight. Adding the MaBook clone prevents Spotlight from including this in its search and now it only examines the apps on the iMac.

  • ian129 Level 1 Level 1 (0 points)

    strangebirds:

     

    Your solution (removing the startup drive from Spotlight indexing, restarting the computer, and putting the drive back into Spotlight indexing) worked very well for me.

     

    I have two Macs on the same Apple ID.  The update problme occurred only on the Mac that I used to change my Apple ID.  No trouble on the other Mac before or after tha change of Apple ID.

     

    So it may not be necessary to remove the startup drive (which is also where the app is installed) for normal purchases and updates.  Instead, wait for trouble and then re-index the drive.

     

    Many thanks for your solution.

  • ruben952556 Level 1 Level 1 (0 points)

    thank u soooo much dude I solved my problem!!!!!

  • Toiler Level 1 Level 1 (0 points)

    Here's a possible solution (or at least a further clue) for late-comers who have tried everything suggested here and are still having this problem...

     

    I tried deleting apps, re-authorizing, re-indexing, etc. Nothing solved my problem. Until I noted a certain comment on this forum about Spotlight indexing a remote hard drive. Well, I happen to have a separate MacMini and a MacAir residing on my ethernet, and they both belong to a different user/Apple ID.

     

    Spotlight appeared to be indexing these remote drives, and in the process, may have been getting the AppStore confused about who owns what. In any case, I added these computers to my Privacy list in Spotlight preferences, and my problem was solved. No more "You have updates available for other accounts..." It's downloading just fine.

     

    To try this fix:

     

    1. Open System Preferences.

    2. Select Spotlight.

    3. Select the Privacy tab.

    4. Click '+' to add a folder or drive to block.

    5. Browse to a network device. Be sure you navigate to the shared hard drive itself and not just a folder on that drive. Add it to the privacy list.

    6. Close System Preferences.

     

    Now see if your downloads will work in the Mac AppStore. Mine did.

     

    Good luck.