Previous 1 2 3 4 5 6 Next 76 Replies Latest reply: May 23, 2014 9:39 AM by Allan Eckert Go to original post
  • b-lo matty Level 1 Level 1

    Here are two solutions from Apple Tech:

    Short version:

    In App Store login window make sure FULL email address is in the "User Name" field. If not add it and then try to login....

    Long Version:

    If the above works, you'll realize you do indeed have two Apple IDs but with only one password. Let's call them, "Apple ID (A)" and "Apple ID (B)." Apple ID (B) is the one without the full email address. So I went to:    I went to, "Manage Account." I entered my FULL email address, then password. Then I got the primary email address "Verified" for Apple ID (A)(the one with the FULL email  address). I then logged out and logged back in using Apple ID (B)(just user name) & entered the same password. I made sure Apple ID (B) was NOT verfied.

       So there's supposedly NO way to delete either account. But this is a way to live with it & still be able to function. Think of one account as the other's alter-ego. This may help in dealing with the two simultaneaously. In addition: I was told that in the future I may need to add a SEPARATE email address for Apple ID (B) and verify it.... Hope this helps someone.

  • shornby Level 1 Level 1

    @Strangebirds --->  Bingo!  Excellent find.  (Running Lion 10.7.2 - App store still depends on Spotlight!)


    I turn off the Spotlight search from the root volume too.  MDS and MDworker often "work" when they shouldn't, and I'm in Terminal too much to utilize Spotlight anyway.


    Who would have thought... looking at the logs! 

    I kick myself when I (rarely) spin my wheels before realizing I haven't checked the logs!






    (And now my CPU is at 100 percent...)

  • Raziel DERF Level 1 Level 1

    This method did not work at all. I have a brand new iMac and nothing is working at all! I do not have multiple accounts and I do not have an update for any app, yet the app store insists that I have an update to Angry Birds in which I dont even own this app! What gives?!

  • skyzlmt Level 1 Level 1

    This worked for me... and very easy.  TY!

  • Lee May Level 1 Level 1

    Did you try checking the App Store info (select icon and Get Info) and uncheck the 32-Bit mode? I did and my apps started updating/downloading!

  • Jason Staloff Level 1 Level 1

    I got this error trying to install Mountain Lion, but my setup was more complex. I had the developer seed, which I downloaded with my work email address/Apple ID because that's the ID part of my employer's developer program. When I went to download the official ML release on my personal Apple ID, it objected that there were updates in the other ID.


    I went and did the one update there, and when both Apple IDs showed no updates, I still got the error.


    Resetting warnings in itunes and signing out of the itunes store didn't help.


    What did help was trashing the 10.8 developer seed installers out of my Applications folder.


    So here it is, in case that's not glaringly obvious to someone other than me. FWIW, it was not obvious to Apple phone support either. :-)

  • John Muccigrosso Level 1 Level 1

    Nice. Re-indexing worked for me too.

  • the.hammer Level 1 Level 1

    Good job!

    Had a similar issue, and followed Strangebirds' instructions.

    I share my experience, hoping it can help.


    If (the app is installed): move to the trash -> disable spotlight -> login @AppStore -> download&install -> enable spotlight


    else: disable spotlight -> login @AppStore -> download&install -> enable spotlight


    Kudos to apple for the rock-solid application management system

  • Charles Clark Level 2 Level 2

    ditto Solution: (Worked for me)


    Excellent tip.

  • Uwe Hobohm Level 1 Level 1

    I went thru all replies in this thread without avail. Repaired disk permissions and re-built spotlight index, several times, controlling via console if indexing went fine. Always, this annoying and uninformative message "You have updates available for other accounts. Sign in to (null) to update applications for that account." (Why does the appstore not tell which account ?)


    Finally, I sorted it out, kind of.


    I have two Apple-IDs in the app-store (ID1, ID2). I have two laptops from where I purchased apps (MBP-2008, MBP-2011).


    On MBP-2011 I could not update from Xcode-4.6 to Xcode-4.6.1. Xcode shows up with the "update" button, but update failed with "wrong account". This is clearly a bug on the app-store, since Xcode is free. There should be a possibility for a fresh install no matter what. I finally found Xcode-4.6.1.dmg for download on bittorrent and did a fresh install.


    I had purchased Yojimbo-3 from ID2 on MBP-2008 from the App-store. My hard disk was propagated from MBP-2008 to MBP-2011 with Yojimbo on it or Yojimbi was migrated using migration assistant; I do not remember. I faced the same problem with update from Yojimbo-3-0-2 to Yojimbo 3.0.4 on MBP-2011. Update refused because wrong account (tried from both accounts ID1- and ID2) . However, I could update using my prior MBP-2008 using ID2. I copied the executable to MBP-2011. Starting Yojimbo-3.0.4 for the first time on MBP-2011 I got a message like "This was purchased on another computer (!!!! now you got it correct Apple !!!), sign in with your Apple.ID." So I signed in with ID2 once and all is fine.



    1. messages from the app-store are completely confusing, even wrong.

    2. It should be possible to download FREE apps again (rather than update only), no matter what.

    3. Do not purchase from the app-store but from the software vendor directly. In many cases, you have a serial number and support.

    4. The update procedure via app-store is fundamentally flawed compared to old Snow Leopard times.

  • Connie Angeles Level 1 Level 1

    I was having issues buying apps from the app store too since December! I noticed that after I did a system update, the buy it now button dos not work.


    But I just figured it out. Something about the Firewall system on my iMac was preventing me to purchase Apps from the app store. I cannot sign in and the sign in option on the right side is greyed out.


    So I tried turning off my firewall from the System Preferences, and also my Norton firewall(Yes, I do have it). Then, yup my APP store is now  working.


    If you guys noticed there was an update last year, that after updating to that, you were asked again to remember your password on the websites that you needed to log in.

  • MFRWD Level 1 Level 1

    My original Error Message was:

    You have updates available for other accounts.

    To update this application, sign in to the account you used to purchase it.


    I couldn't fix this for a while but finally found the solution to my problem. The app I couldn't update was XCode. Anyway, first I tried reindexing by running:

    sudo mdutil -avE


    This command deletes the spotlight index. ... After spotlight finished rebuilding it's index, I tried updating the app in the App Store again, but to no avail. I still got the same message.


    Finally I found the solution that worked. I ran the following line of code in Terminal:

    mdimport /path/to/application/

    (i.e. this was /Applications/ for me, it also might be ~/Applications/ for something else)


    This worked beautifully, and took about 30 seconds to run. After the command ran, I was able to open the App Store and update XCode normally. I hope this helps someone.

  • am5ki Level 1 Level 1

    My symptoms were identical to those reported by MFRWD (error message: "You have updates available for other accounts.  To update this application, sign in to the account you used to purchase it."  The way I managed to get the application updates to work was by simply opening the offendig application and retrying the update.  Here is the process I followed:

    • open App Store and try to update the application
    • get the error message ("updates available for other accounts")
    • open the application itself (leave AppStore running)
    • go back to appstore and press "update"; this time around, the update would magically work.


    This may work when one is not sure where exactly the application resides or for those who are less than comfortable with cryptic Terminal commands.

  • MacLion Level 2 Level 2

    I had a similar issue trying to get the last previous version of an app update after it received a major update to a newer paid version. When I looked over my "Purchases" list in the App Store is showed an "Update" button vs. "Installed" button. But when clicking on the update button, it gave a 1004 error (I believe). If I clicked on the app name it would say the app was no longer available in the App Store (as the newer paid version was in place). I deleted the app and reinstalled it from the App Store and I now had the most current version without getting the error in the download process.


    The app was Sketch and version 2.4.4 was released about the same time as the newer version 3 was released, and I must have missed the chance for the 2.4.4 update via the normal "Updates" pane of the App Store. So now I can benefit of the fixes in 2.4.4 (from 2.4.3) until I decide to pay to go to Version 3. Also this will help if any additional Sketch 2 updates are posted from this point forward and I see the "Update" button again in "Purchases".

  • Allan Eckert Level 9 Level 9

    Instead of replying to a thread that has been dead for a year, you really should start your own thread so that your problem get noticed.