Previous 1 2 3 Next 43 Replies Latest reply: Apr 20, 2016 5:01 AM by Starwalker
cameronkay Level 1 Level 1
With Mac OS X 10.6.6 and 10.6.5 I'm having a problem with MS Office documents opening as read-only from AFP shares. This seems to be a problem with Office 2008 and 2011.

If you create a new document in as Word and save it to an AFP share. Then quit Word and reopen the document, the document is marked as Read Only. It's not marked as Locked in the Finder. Quitting the app and opening the document again has the same problem.

If you unmount and remount the AFP the problem goes away. The problem also goes away after about 30 minutes.

Any idea what's going on?
  • William W. Higgins Jr. Level 1 Level 1
    Same problem with Excel 2004. My configuration uses AFP share as a Network User's Home directory. Document is not locked in Finder, but Excel says it's Read-Only and will not save.
  • Richard Cartledge Level 2 Level 2
    What AFP Server are you using?
    Can you look on the server to see if the user has more than one connections?
    We always had this problem where a user invokes additional connections to the same server as their home directory.
  • obssidian Level 1 Level 1
    I have seen this happen as well, our situation is a bit more convoluted since we have AFP and SMB connections to the same share, and clients using Office 2003 on PC, 2008 and 2011 on the Mac. Permissions are AD ACLs and different people open and close the same files in a short period of time.

    So far our workaround has been to move the "read only" file to the user's desktop and then back on to the file server. As you mention disconnecting the drive also helps in some cases, as does navigating away from the folder and then back in.

    So far we have not found an iron-clad solution or even a logical way of reproducing the problem and the solution. But I feel your pain.
  • cavenewt Level 2 Level 2
    This is a problem with Microsoft office documents that's been going on for years. If you Google around enough, you'll find people complaining about it going back to Office 2004. I've been looking into it for a couple of years for a client who uses Leopard and office 2004. Possible solutions include: creating an invisible folder at the root level of the SharePoint called “TemporaryItems” and using Terminal to give it the proper permissions; changing all of the numeric user IDs away from 501 and 502 and using very large unique numbers instead; and changing the owner of the share point on the server to something called NETWORK SERVICE (it's unclear to me if this will work on a Mac server or only Windows).

    I have applied the TemporaryItems folder solution, and it did solve the problem for a number of months. But it just came back with a vengeance. So here I am, googling around again. I can tell you this problem occurs, with some variations, in versions of Office from 2004 through 2011, and Mac operating systems from Tiger through Snow Leopard. It's rather mind-boggling that this has never been dealt with.

    Here are some links for your perusing pleasure:

    You can find lots and lots of people online complaining about this. Just spend some time searching. In my case, my clients are only using two computers, one of which is using native filesharing, so it's not even a full-on server situation.

    Message was edited by: cavenewt
  • STMac Level 1 Level 1

    What worked for us was creating the temporary folder at the top of the share and set the sticky bit, so the folder could not be deleted. We are using the default share '/Users' with all the home directories of the users:


    sudo mkdir /Users/.TemporaryItems


    sudo chmod 1777 /Users/.TemporaryItems


    drwxrwxrwt+  12 root wheel   408 Oct 13 13:01 .TemporaryItems



    Snow Leopard Server 10.6.8

    Microsoft Office 2011


    Message was edited by: STMac

  • Espen Eiesland Level 1 Level 1

    I have this same problem running Lion client against an AFP share on a Lion Server. I have played a little with this and seem to see a pattern with the Finder Preview Column being active or not? It is not 100% consistent but for at least one file. If I have preview column unactive, the file can be opened without problems. If I activate the preview column the file becomes read-only. Could this be something?

  • Airbrakes Level 1 Level 1

    I adjusted the permissions on the ".TemporaryItems" folders at the root of the share on my server so any user has full control. It seem to fix my problem. I think by design the specific user has full control and everybody else is read only...well that seems to be the case with my issue. My client is running a Windows Server 2003 backend and I have OS X 10.6.8 with Office 2011. Took me all day to figure this out. Still testing thru out the file structure but so far everything is finally working finally!


    I hope this helps you out.

  • Zohx Level 1 Level 1

    I had this same problem at one of the schools we take care of and making the users account a mobile account on the server fixed the problem completley

  • Wannes Van Loock Level 1 Level 1

    Found out this is due to the QuickLook Office plugin in the system.


    Disabling this plugin will fix this behaviour, unfortunately you can't use QuickLook anymore for Office documents.


    1. Open Terminal

    2. Enter or copy this command and it will be fixed :


    sudo mv /System/Library/QuickLook/Office.qlgenerator /System/Library/QuickLook/Office.qlgenerator.bak ; killall Finder

  • Phixter Level 1 Level 1

    Can I ask which machine you do the terminal command on... user or server?


    Seems to be very intermitent all this & I can't seem to find the deciding factor.


    Some drives have the problems, some don't.  Not POSTIX, not SMB (with or without OPLocks and Strick Locking - which some people seemed to think it maybe on other forums), clearly not straight permission. Some users have it, some don't, some docs have it some don't at all.


    With regard to the cleaning permissions of the temp folder: as office saves the files off a different way (moving to and from temp folders) it kinda makes sense on the server.


    If quicklook command was on the server i'd kinda believe it worked ( i'm no experet by a long shot - just instincts). If it was on the users mac then... I don't know.


    Please help. I have a few people giving me Jip and it's frustrating the **** out of me.


    Thanks in advance.



  • Phixter Level 1 Level 1

    AirBrakes or anyone avtually. How does one adjust the permissions on a hidden files like the



    Thanks again



  • STMac Level 1 Level 1

    Have you read the whole post?


    Open a terminal on the server, and then type


    sudo chmod 1777 /Users/.TemporaryItems


    (or whatever your folder is...)


    You should see the premissions with 'ls -la'


    drwxrwxrwt+  12 root wheel   408 Oct 13 13:01 .TemporaryItems


    The sticky bit (the '1' in the command that produces the 't' in the permissions) allows only the owner (root) to delete the folder even if everyone has write permissions .





  • petewhite Level 1 Level 1



    I have the same problem however the .TemporaryItems permissions fix has not worked. I have a 5 user setup all running Mountain Lion and Office 2011, there is a share on one iMac where each user logs in using their own user/pass.


    When one user creates a excel/word file in the share and its opened by someone else, it only opens as read only.


    The permission on my .TemporaryItems folder is:


    drwxrwxrwt+  2 server  staff       68 15 Jan 18:36 .TemporaryItems


    Help suggestions would be much appreciated.



  • Wannes Van Loock Level 1 Level 1

    You've to disable the quicklook office plugin on the client side :


    1. Open Terminal

    2. Enter or copy this command and it will be fixed :


    sudo mv /System/Library/QuickLook/Office.qlgenerator /System/Library/QuickLook/Office.qlgenerator.bak ; killall Finder

Previous 1 2 3 Next