Previous 1 2 Next 24 Replies Latest reply: Sep 10, 2015 8:28 AM by Charlie Nancarrow Go to original post
  • STMac Level 1 Level 1 (0 points)

    Hi petewhite


    I don't think that your issue is related to the ".TemporaryItems" folder, as the problem only seems to happen when trying to open a file created by other user.


    Check the group permissions on that share, of course the users have to belong to the same group and that group needs write permission on the "Share", and you need to enforce that new files are created with that write premission for the group.





  • Yokoshimax Level 1 Level 1 (0 points)

    Found out this is due to the QuickLook Office plugin in the system.


    Disabling this plugin will fix this behaviour, unfortunately you can't use QuickLook anymore for Office documents.


    1. Open Terminal

    2. Enter or copy this command and it will be fixed :


    sudo mv /System/Library/QuickLook/Office.qlgenerator /System/Library/QuickLook/Office.qlgenerator.bak ; killall Finder

    this worked!


  • Wannes Van Loock Level 1 Level 1 (10 points)

    Can you please mark my solution as Solved then ? Which gains me 10 points. Thanks.

  • Yokoshimax Level 1 Level 1 (0 points)

    Sorry, but I find that option, maybe it's only for the creator of the post
    PD: I speak Spanish, google translate helps me.
    PD2: My system is OSX 1.8

  • slavoine727 Level 1 Level 1 (0 points)

    Try setting the permissions of the folder that contains all of the "read only" and change to  "read and write" for all users ( or certain user if you olny want certain people to acces them ) and apply to "enclosed items". In my case the files were on the server the office is sharing so I change the permissions on the server so that everyone can acess the files.



    here is a link in case your not familiar with the process.



    This solve the problem for me.


    Good luck!!



  • TKOWinterMute81 Level 1 Level 1 (0 points)

    This fixed it for me! Thanks!

  • kpezkpez Level 1 Level 1 (0 points)

    This solved my issue, thank you. My user had both an smb and an afp connection to the server. One was set up to be auto-login while the other she was doing manually.


    Screen Shot 2013-09-13 at 4.50.35 PM.png = bad

  • bct737 Level 1 Level 1 (0 points)

    Turning preview off (right click folder->show view options->uncheck show preview column) fixed the issue for me. I played with this a bit more and in my case, the preview is definitely what was causing the server to only allow read only. That was only happening for larger documents that took a while for the preview to load; while the preview was loading I tried to open repeatedly and kept getting "read-only", but once the preview loaded the document opened right up. Which led me to another solution for those (like me) who want to keep preview on--switch to the file list view in Finder, which doesn't have the preview pane, and documents open right up with no read-only issue.

  • Wannes Van Loock Level 1 Level 1 (10 points)

    As simple solution seems to be that there were special characters used in the file name, like a slash "/"

    After replacing or removing these special characters from the filename, the file was accessible again !

    This happened over an AFP connection with 10.9.5

  • Charlie Nancarrow Level 1 Level 1 (0 points)

    Several causes and fixes —


    This is often due to the hidden .TemporaryItems folder at the root (top level) of a file share not having the correct permissions or not existing, or being symlinked to another storage device.


    Use these commands to create the required folder and set the correct permissions on the .TemporaryItems folder


    sudo mkdir /Shared\ Items/Share/.TemporaryItems

    sudo chown -R 99:staff /Shared\ Items/Share/.TemporaryItems/*
    sudo chmod 1777 /Shared\ Items/Share/.TemporaryItems



    If this folder already exists and has stuff in it, make sure no one is connected to the server and then remove the contents of the folder.  Then set the permissions correctly.


    It can also be caused by the finder locking the file as it creates a preview icon or Preview pane view of the file.

    This can fix that —

     sudo mv /System/Library/QuickLook/Office.qlgenerator /System/Library/QuickLook/Office.qlgenerator.bak ; killall Finder



    This problem can also be caused if a Users home folder is on a different drive than the main Macintosh HD and their Caches folder or items within that are symlinked elsewhere (say to /tmp or similar).


    The last cause is an overlap between UIDs of users on the local machines and the server.

    This can cause one user's Office to think the files are opened by the same user, but they cannot still access the files, at best. At worst, is can cause crashing as word tries to delete and reuse them files in use by another user on another machine.


    You will need to check the UID of each user and compare that to the server. If there are mismatches they will need to be created. It can sometimes be enough that every one has a unique ID and there are no overlaps, but it is much better if the local UID also matches the server.

    To fix this can be messy — Involving changing the UID on the server and local machine, then ensuring all the users existing files are then chown to the new UID.

Previous 1 2 Next