Skip navigation

Netflix slow on MAC, speedy on Win 7 PC

14598 Views 36 Replies Latest reply: Jan 30, 2014 12:38 AM by POA_ RSS
  • a brody Level 9 Level 9 (62,010 points)
    Currently Being Moderated
    Jan 14, 2011 3:12 PM (in response to moshem)
    Delete iTunes from the Startup Items in the System Preferences - Accounts.
    Restart, and try again

    Message was edited by: a brody
    An Apple user since 1981, Mac OS X (10.6.2)
  • a brody Level 9 Level 9 (62,010 points)
    Currently Being Moderated
    Jan 14, 2011 6:45 PM (in response to moshem)
    Maybe it is a sign of bad RAM being installed. If you get any four language screens saying you must restart your computer now, that's another sign. You can run the hardware test that came with your Mac, and sometimes detect bad RAM, but not always.
    An Apple user since 1981, Mac OS X (10.6.2)
  • a brody Level 9 Level 9 (62,010 points)
    Currently Being Moderated
    Jan 15, 2011 11:56 AM (in response to moshem)
    I didn't have a chance to test it on my Mac till now. But I can see now the source of the problem. It is a bug in the Netflix software. They max their Mac speed at a manual selection of 1500. I don't know what shortcut you used on the Mac, but when I do it on Safari 4.0.4 on 10.6.2, buffering rate can't be selected above 1500. So it would appear the problem is Netflix's software. Contact Netflix and let them know the Mac software is still limited to 1500 and this is too slow for your internet service. Mine, it never has been a problem, since I have 7 Mbps.
    An Apple user since 1981, Mac OS X (10.6.2)
  • a brody Level 9 Level 9 (62,010 points)
    Currently Being Moderated
    Jan 15, 2011 6:26 PM (in response to moshem)
    Interesting. Maybe they need you to use a different web browser. But as I say, I'm not using either the most current web browser, or the most current Mac OS X. The fact it limits me to 1500, and I don't see a problem, suggests something else is eating up more bandwidth on your system. Turn off all file sharing in your system preferences.
    An Apple user since 1981, Mac OS X (10.6.2)
  • lowfokus Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jan 15, 2011 6:43 PM (in response to moshem)
    Are you sure you have the latest? On chrome, my manual selection is also capped at 1500.
    I'm using it right now, rock solid 1500/1500 for Shutter Island full screen.
    MBP 2.66 i7, 1.83C2D Mini, 15" G4 iMac, Mac OS X (10.6.6), 32GB iPhone 4 Black
  • lowfokus Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jan 15, 2011 6:54 PM (in response to lowfokus)
    Nevermind, it is the same version I have.
    GPU acceleration on my i7 MBP is not enabled either. The only differences I notice between mine and yours is I'm using 83MB of memory (you are using 14MB), playing bitrate of 128 (yours reads 64). Your frames rendered is 24, mine are 30 (PAL maybe?). And finally my buffer size is 258/242 seconds.

    Message was edited by: lowfokus
    MBP 2.66 i7, 1.83C2D Mini, 15" G4 iMac, Mac OS X (10.6.6), 32GB iPhone 4 Black
  • lowfokus Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jan 15, 2011 7:16 PM (in response to lowfokus)
    I think I got it for you.

    You are playing and buffering at the same speeds. Limit your playback to less than 1000. You are only buffering at 1000, thus, if your buffer is only 20 seconds or so, and your play rate exceeds your buffer, you get choppy/stuttering video. Limit it to 500 and keep the diagnostics up to see if it plays correctly.'
    In other words, my playing bit rate was 128/500, buffering bit rate is 128/1500.

    Message was edited by: lowfokus
    MBP 2.66 i7, 1.83C2D Mini, 15" G4 iMac, Mac OS X (10.6.6), 32GB iPhone 4 Black
  • lowfokus Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jan 15, 2011 7:22 PM (in response to lowfokus)
    Here is someone that had this problem on XP, and this is how he got it to limit the playback:
    Limit the buffer to 500. Wait until Silverlight realizes the buffer is way slower than the playback.
    Return video to beginning, and then the play rate should not exceed the buffer rate. (500/500).
    The stream should stay that way, according to him.

    http://silentarchimedes.wordpress.com/2009/03/29/netflix-watch-instantly-silverl ight-workaround-for-windows-xp/

    All in all, I don't know anymore if that really does solve your problem, but it is a work around for crummy video. Sorry I can't be of more help than that, but if I do run across a real solution I will shoot it to you.
    MBP 2.66 i7, 1.83C2D Mini, 15" G4 iMac, Mac OS X (10.6.6), 32GB iPhone 4 Black

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.