1 2 Previous Next 27 Replies Latest reply: Jun 3, 2014 3:01 AM by matsvm
coqui_pregunton Level 1 Level 1 (0 points)
Hi,

I have owned a Magic Trackpad for a few months and it works great. I left for vacation and I left it in a shared project room at work and somebody else paired the device while I wasn't here (somehow). This person is in a different state and now that I tried to use it, it has his name in it and although I am able to pair it, only cursor movements work (and they are sort of erratic) and the multi touch gestures do not work at all. I've searched the forums and nobody seems to have had this problem before. Any ideas on how to reset the Magic Trackpad to its factory settings so that I may pair it again. What is interesting is how that person was able to pair the device when it was already paired to my MacBook Pro and now I can't do the same thing. I've tried removing the device, changing the name, updating the services, etc. through the Bluetooth preferences pane. I feel like I need a hardware or low-level solution.

MacBook Pro 15'' Unibody (2009)
Snow Leopard

Thanks in advance!

MacBook Pro Unibody 15'', Mac OS X (10.5.8)
  • 1. Re: How to force a reset on Magic Trackpad
    Keltis Level 1 Level 1 (0 points)
    I read somewhere that resetting to factory settings is achieved by pressing the ON button for 5 sec. I did not manage to make it work any way and I have found no other info on resetting (other than that one and your posted question). Although I guess that after so many days you may have found the way, I just tell you that I solved my problem (which was no pairing of trackpad after format and restoring one of the office iMac's) by *removing it from the list of the bluetooth devices*. Check if it will work with you in case you can do so. Also, let me know what the resetting "secret" is.

    Thanks anyway.
  • 2. Re: How to force a reset on Magic Trackpad
    kyle.cottle Level 1 Level 1 (0 points)

    If you hold down the button for on the side of the Magic Trackpad for ~5 seconds, one of two things will happen.

     

         1.) The light will come on and then go off

         2.) The light will come on and then blink.

     

    In the case of number 1, you've turned the trackpad off.  In the case of number 2, if you continue to hold down the button the light will continue to blink and it will become discoverable in your Bluetooth setup assistant.  If you continue to hold down the button through the entire wizard, you should be able to reestablish connectivity. 

     

    This is what finally worked for me.

  • 3. Re: How to force a reset on Magic Trackpad
    psyberknaut Level 1 Level 1 (0 points)

    This also worked for me when I needed to re-pair my TrackPad with my iMac after pairing it with another Mac that was not easily accessible. 

     

    Thanks    

     

    :-)

  • 4. Re: How to force a reset on Magic Trackpad
    jawkat Level 1 Level 1 (0 points)

    I also experienced the same problems as coqui_pregunton, but resetting the magic track pad did not help.  I had to go to the "Bluetooth" section of "System Preferences" and remove the trackpad from the list of bluetooth devices by clicking the "-" button.  Once it was removed, I added the magic track pad back by clicking the "+" button and following the instructions.  Now everything seems to be working great.  Just offering this up as an alternative solution.

  • 5. Re: How to force a reset on Magic Trackpad
    tem2001 Level 1 Level 1 (0 points)

    Thanks, Jawkat. Removing it and then re- adding it is what worked for me. I held that poor little button down longer than anyone should have to, but "connection" kept failing.

  • 6. Re: How to force a reset on Magic Trackpad
    fairgo4all Level 1 Level 1 (0 points)

    Tried that - no luck -changed batteries no luck - it just turns off after less than 5 seconds and the trackpad icon in the Settings says I don't have a trackpad!

  • 7. Re: How to force a reset on Magic Trackpad
    norg_props Level 1 Level 1 (0 points)

    Also tried the above, with no luck.

     

    Mine was working fine until the batteries ran out.....

    ...then it wouldn't behave again when I put new ones in.

    I tried removing it from the Bluetooth devices and now it never gets re-detected.

     

    There's no obvious way of getting it to that initial flashing light stage where it has been reset and is 'trying' to pair up again.

    This is clearly what's required....

     

    ...so to re-iterate the OP :  can anyone please explain how to reset the trackpad?

  • 8. Re: How to force a reset on Magic Trackpad
    norg_props Level 1 Level 1 (0 points)

    Just to say I RESOLVED MY ISSUE

     

    -  the replacement batteries (both sets) were too flat to work in the Trackpad.

    They lost their charge whilst sitting idle for months.

     

    Sure, they could power the single light flash, but not, apparently, a more informative warning.

     

    So if you are unable to detect your Trackpad, blame your batteries first.

     

    Even a simple rapid triple flash warning with the green power light would have diagnosed this unambiguously.

    Perhaps a firmware update could address this.

  • 9. Re: How to force a reset on Magic Trackpad
    thellum Level 1 Level 1 (0 points)

    This worked perfectly for me (reset discoverability to factory).

  • 10. Re: How to force a reset on Magic Trackpad
    analoghdesc Level 1 Level 1 (0 points)

    thanks @ norg_props

    my fingers where so tired of pressing that button

  • 11. Re: How to force a reset on Magic Trackpad
    BarbLevine Level 1 Level 1 (0 points)

    jawkat's approach [removing and re-creating the Bluetooth pairing] solved my problem too.

    Thanks

  • 12. Re: How to force a reset on Magic Trackpad
    cmasten Level 1 Level 1 (0 points)

    simple, under the bluetooth settings in control panel you have + to add - to delete and the star for settings there you can select the trackpad with the old name and select "rename" and just rename it

     

    no need to reset the trackpad , it just updates the name and your good to go

  • 13. Re: How to force a reset on Magic Trackpad
    Scott Rose Level 3 Level 3 (895 points)

    Another problem that commonly happens:

     

    The Magic Trackpad might be paired to a previous Mac that is still in the same room and turned on.

     

    If that's the case, you should first remove the Magic Trackpad from the previous Mac's Bluetooth System Preferences.

     

    But if you can't do that for some reason, there's another trick:

     

    1. Hold down the power button on the Magic Trackpad for 5 seconds until it turns off.

     

    2. Hold down the power button on the Magic Trackpad for another 5 seconds until the light starts flashing... BUT KEEP THE BUTTON HELD DOWN WHILE YOU TRY TO ADD IT TO YOUR NEW MAC. The act of you keeping the button held down will prevent the Magic Trackpad from falling back on communicating with the previous Mac.

  • 14. Re: How to force a reset on Magic Trackpad
    BrianDrummond Level 1 Level 1 (0 points)

    I'm using 10.8.2, and what finally worked for me was holding the trackpad button down all during the setup process.  I used the Trackpad control panel (not the Bluetooth control panel), and clicked on the button labeled "Set Up Bluetooth Trackpad...".  The Trackpad light went off once during this, but I kept holding the button down/re-clicked the Trackpad button quickly and it finally connected.

     

    Prior to this, I also deleted a previous connected in the Bluetooth System Preferences panel.  Having two control panels to work with the Trackpad is confusing.

1 2 Previous Next