6 Replies Latest reply: Jan 15, 2011 4:42 PM by tonydenson
tonydenson Level 1 Level 1 (0 points)
I use Apple Mail for my GMail iMap account and I am suddenly missing the last 6 months Sent messages. Given that it's iMap, would it be safe to just delete the account and reenter it in the hope that the problem then just comes out in the wash.

13" MacBookPro, Mac OS X (10.6.6)
  • thomas_r. Level 7 Level 7 (30,350 points)
    Go to Mail -> Preferences, click Accounts, select the GMail account and click the the Mailbox Behaviors tab. How is Mail set to handle Sent messages for that account?
  • tonydenson Level 1 Level 1 (0 points)
    "Store sent messages on server" not ticked
    "Delete sent messages" never
  • thomas_r. Level 7 Level 7 (30,350 points)
    Then your sent messages have not been saved on the GMail server, so deleting the account and re-creating it will not help. If that setting was changed recently, you may have them on the server, though, so log on to GMail via the web site and check to be sure.

    As to where they went, I don't know. You could try rebuilding the mailbox (Mailbox -> Rebuild), but if that doesn't fix it, and they're not on the server, then you're out of luck unless you've got those messages in a backup. If you haven't been backing up, they're gone.
  • tonydenson Level 1 Level 1 (0 points)
    Thomas A Reed wrote:
    Then your sent messages have not been saved on the GMail server, so deleting the account and re-creating it will not help. If that setting was changed recently, you may have them on the server, though, so log on to GMail via the web site and check to be sure.

    As to where they went, I don't know. You could try rebuilding the mailbox (Mailbox -> Rebuild), but if that doesn't fix it, and they're not on the server, then you're out of luck unless you've got those messages in a backup. If you haven't been backing up, they're gone.


    Sorry, I didn't make myself clear. The reason I posted this under Apple Mail is because there is no problem at the GMail end, all the messages are there.
  • tonydenson Level 1 Level 1 (0 points)
    Rebuild didn't fix it.
    I also didn't mention that it's fine on both my iPhone and iPad.
    I will have a go at deleting the account.
  • tonydenson Level 1 Level 1 (0 points)
    This is going from bad to worse. I have deleted the account and reentered it and now I don't even have a Sent box, yet all is still well on the server (and my iPhone and iPad).