Previous 1 2 3 4 5 Next 71 Replies Latest reply: Sep 23, 2012 9:01 PM by RobinGD Go to original post
  • appleyu Level 1 Level 1 (0 points)
    Unfortunately this didn't work for me. When you saved it to your desktop, you just saved the link correct?
  • appleyu Level 1 Level 1 (0 points)
    I just can't find the servers. I don't know if the issue you guys are addressing is supposed to help my problem...
  • appleyu Level 1 Level 1 (0 points)
    FINALLY! I've figured out how to find servers when they aren't appearing!

    It's a simple fix too... Just keep clicking refresh list until a list pops up. I did it like 20 times.
  • Silenthunter56 Level 1 Level 1 (0 points)
    Man am I glad I found this thread. Was playing COD4 for years on my PC..before it died...just waiting to upgrade to a P67 mobo and i5-2500K....really missed playing this game. Just loaded it up on my girlfriends iMac and having this punkbuster issue. Haven't used a MAC for a few years so kinda glad I had this problem...gets me digging in and a little forced learning. Elegant thing this OS.
  • dfkt Level 1 Level 1 (0 points)
    For anyone still confused or not able to get it to work online:

    1. Download pbsetup for mac from here: http://www.evenbalance.com/index.php?page=pbsetup.php
    2. Install it in Applications.
    3. Open it and click add game, select Call of Duty 4, then copy and past the path below into the path box.

    /Applications/Call of Duty 4.app/Contents/Call of Duty 4 Data

    4. Then click "file > check for updates".

    To edit the permissions if they are grayed out, click the lock in the bottom right hand corner of the get info window. Change them to Read and Write on the contents folder and app, then on the multiplayer app and it's contents folder.

    Just to be sure I added more paths on PunkBuster by adding the game again, here are the additional ones I added:

    /Applications/Call of Duty 4.app/Contents/Call of Duty 4 Multiplayer.app/Contents

    /Applications/Call of Duty 4.app/Contents

    If It doesn't work now, then I guess you have to contact Aspyr, but since they made the port and apparently didn't test it (or bother to fix it), I'm not sure there's anything more you can do unless it's an unrelated problem you're experiencing.

    Oh and to find servers make sure that the source is: Internet, not Favourites or LAN, then just hit Refresh and wait. If no servers come up it might be because of your internet connection or something else.
  • molecule-eye Level 1 Level 1 (0 points)

    Unfortunately the pb udpater doesn't work on Lion. Is there a manual solution? This is ridiculous, I must say. Might as well download pirated copies next time if retail versions off the lame *** App Store don't work.

  • tuareggs1200 Level 1 Level 1 (0 points)

    I have tried also to to run the pbsetup.run app;ication but this come on " You can't open the application because PowerPc applications are no longer supported"

    How I will go on if I can't run this??

    Is ther any solution?

  • magic890 Level 1 Level 1 (0 points)

    Hi,

     

    for manually fix you can use this files and guide:
    http://www.evenbalance.com/index.php?page=dl-cod4.php

     

    You have to put this file inside

    /Applications/Call of Duty 4.app/Contents/Call of Duty 4 Data/pb/

     

    But unfortunately now it's seems that after pb 14/05/2012 update all the servers kick Mac client for not updated pb version. Maybe it's a bug in pb update.

     

    My COD 4 multiplayer version is 1.7.549.
    Untile yesterday all was good, and I play very well on every server.

  • colintri Level 1 Level 1 (0 points)

    Same here.  I was able to play COD4 with my iMac running OSX Lion for past year but I got kicked today?  Tried to download PBsetup to refresh the files but got this message "PowerPC applications are no longer supported".  I really think this is PunkBuster's doing and they need to fix this.

  • MrNeoo Level 1 Level 1 (0 points)

    I have an Intel machine, and downloading PBsetup solves nothing. Manually updating the files ditto. The problem is from their new update at evenbalance. No Mac can play cod 4 until they solved it. Already submitted a ticket. Waiting for a reply.

  • Dan-o ™ Level 2 Level 2 (380 points)

    Evenbalance needs to "yank their head out". They haven't updated Pbsetup in YEARS for the Mac. There is NO excuse for still having a PPC only executable. That's just lazy, pure and simple. They could easily recompile it for Intel but they don't.

     

    Now I cannot get into any server (this happened tonight), even after updating my Pb files 2 or 3x. Also my pbsec file continuously disappears every time I download it and then run the game.

     

    This is BS.

     

    Just read something at Aspyr.com that said "Pb is no longer supported by Evenbalance for Quake 4 (Mac)." My guess is Evenbalance is discontinuing support for older Mac games. Total crap.

  • MrNeoo Level 1 Level 1 (0 points)

    No Dan-o. Like I said, I have an Intel machine and the PBsetup works fine, so I guess that they don't have a PPC compatible app. The problem is with their updates, they probably did what most companies do: test their files for windows, maybe test the files for linux, and for mac, well, if it worked for linux they "guess" it should work for mac. And then it does not. Had the same BS with HoN.

  • tuareggs1200 Level 1 Level 1 (0 points)

    I tried again today to go on a server and It worked fine. I don't know if they solve the problem but definately works. ????

  • colintri Level 1 Level 1 (0 points)

    I forgot to mention that I have an Intel chip in my iMac and I kept getting kicked out yesterday.  However, when I saw tuareggs1200's comment and decided to try again this morning (7:55AM EST).  It's working for me now!  I guess PB did something about the updates for servers.