11 Replies Latest reply: Dec 16, 2014 8:38 AM by lllaass
Mitoids Level 1 Level 1 (0 points)
I've got a late 2006 mac mini which has begun to run extremely slowly. It has 2GB of RAM and is running OS X 10.6.6. I also have an external 500gb drive connected via USB (firewire 400 cable failed some time ago; haven't bothered to replace).

I've tried numerous things to address the issue and am now looking for suggestions. Here is what I have done so far:
- Verified both disks and repaired disk permissions using Disk Utility
- Used Applejack to clear all caches (including low level)
- Tested the RAM using Applejack (uses Memtest)
- The main drive has over 53GB of 80GB free
- When I look at the activity monitor, the CPU is never even close to pegged
- More than half the RAM is unused

Still when I run iTunes, songs will pause and resume mid-way through. The computer boots very slowly. Larger programs, like Firefox and iTunes load very slowly. There can be long waits in switching from one running program to another.

Any suggestions?

Message was edited by: Mitoids

Additionally, can somebody tell me where I can download the Apple Hardware Test (AHT), or images of the install disks that came with the computer? I cannot find the original disks.

MA608LL/A, Mac OS X (10.6.6)
  • BGreg Level 6 Level 6 (17,500 points)
    Additionally, can somebody tell me where I can download the Apple Hardware Test (AHT), or images of the install disks that came with the computer? I cannot find the original disks.


    Welcome to the Apple discussions.

    You can't download the AHT or the original OS X disks that came with your system. Call Apple support and they'll send you a set. As I recall they run around $60.
  • Boece Level 5 Level 5 (6,245 points)
    I would be inclined to think the problem is related to one of your hard drives. Some possibilities:

    1) Bad sectors, which will cause retries to read data; DiskUtility's SMART status can usually predict this on the internal drive, but not on the external.

    2) Your USB connection to the external drive may have reverted to USB version 1, which is much slower than USB version 2

    3) Directory damage that is not being picked up by DiskUtility. DiskWarrior sometimes is better at finding this sort of thing.

    If you can run your Mini without the external drive, I would try disconnecting the external and seeing if that results in any speed improvement. (However, if programs on the internal drive are referencing files on the external, that may not work.)

    If eliminating the external speeds things up, then you might consider replacing the firewire cable or the external drive. monoprice.com or amazon.com carry firewire cables for reasonable prices.

    Another useful test is to create a new account on your Mini, and see if the Mini performs faster when you log in as that new test user. If so, then there is likely something misconfigured in the regular account. Sometimes it will be a "login item". (See System Preferences > Accounts, Login Items tab.
  • Mitoids Level 1 Level 1 (0 points)
    Thanks for your reply. I find it ridiculous that Apple doesn't provide downloads for something I have already purchased. Every other major vendor I have worked with does.
  • Mitoids Level 1 Level 1 (0 points)
    Boece, I'll try some of the things you suggested. I previously tried logging in as a with different user account that I rarely use and still had the same symptoms.
  • mooblie Level 4 Level 4 (1,925 points)
    Just a long shot:

    You sure you haven't installed a System on your external HD, and set your external HD as the Startup Drive, and you're running off that?

    It would account for the behaviour you're seeing!
  • Mitoids Level 1 Level 1 (0 points)
    I purchased and ran DiskWarrior on the external drive. It found and repaired errors directory. Nearly all were in TimeMachine backup folders. Upon seeing this, I also turned off TimeMachine since I really don't need it on this machine. This Mac is purely for playing media and browsing on my TV, and I am backing up to the cloud also. I suspect TimeMachine could have been causing the apparent performance issues, especially if it was having issues trying to write to the external drive while running in the background.

    Still waiting for the DiskWarrior disk so I can run it against the internal drive. I burned a bootable DVD (from my iMac)to try to test now, but the Mac Mini can't read it for some reason (drive thinks the DVD is blank, and cannot write to blanks I put in it)--I don't want to get sucked into diagnosing this issue right now.

    I also ran the computer without the external drive attached. It's hard to say whether there was a difference. Things seem OK with it attached now. I also found a spare Firewire cable and attached the drive with that instead of USB.

    Things seem better now. At this stage, I think I'll just need to use the system for a while to see if things have improved.
  • Mitoids Level 1 Level 1 (0 points)

    It turned out that the disk was gradually failing.  Also, the laser on the DVD drive was also dirty.  I had to buy a cleaning disk before I could run the DiskWarrior DVD successfully.

     

    When I was finally able to run the DiskWarrior DVD successfully, the program diagnosed the hardware issue.  I ended up buying a new 640GB drive, installed that, and reinstalled the OS.  Everything is working fine.

     

    Thanks again,

     

    Mitoids

  • Gonzalo.Martinez Level 1 Level 1 (0 points)

    Any recommendation on what to do with this Man Mini to make it after, besides changing the HHD to an SSD?

     

    EtreCheck version: 2.1.2 (105)

    Report generated December 15, 2014 4:49:16 PM GMT-05:00

     

    Hardware Information:

    Mac mini (Late 2006) (Verified)

    Mac mini - model: Macmini1,1

    1 1.83 GHz Intel Core Duo CPU: 2-core

    2 GB RAM

      BANK 0/DIMM0

       1 GB DDR2 SDRAM 667 MHz ok

      BANK 1/DIMM1

       1 GB DDR2 SDRAM 667 MHz ok

    Bluetooth: Old - Handoff/Airdrop2 not supported

    Wireless:  en1: 802.11 a/b/g

     

    Video Information:

    GMA 950 - VRAM: spdisplays_integrated_vram

      FVT1744Z2   1280 x 1024

     

    System Software:

    Mac OS X 10.6.8 (10K549) - Uptime: 0:19:20

     

    Disk Information:

    FUJITSU MHV2080BHPL disk0 : (74.53 GB)

    S.M.A.R.T. Status: Verified

      - (disk0s1) <not mounted> : 210 MB

      Macintosh HD (disk0s2) /  [Startup]: 79.68 GB (7.83 GB free) (Low!)

     

    USB Information:

              USB Flash Memory 1.87 GB

      S.M.A.R.T. Status: Verified

      NO NAME (disk1s1) /Volumes/NO NAME : 2.00 GB (1.91 GB free)

    Apple, Inc. Keyboard Hub

      Kensington      Kensington Expert Mouse

      Apple, Inc Apple Keyboard

    TigerJet Network, Inc. USB Internet Phone by TigerJet 6.8 MB

      S.M.A.R.T. Status: Verified

      - (disk2s0) <not mounted> : 6 MB

      - (disk2s0s1) <not mounted> : 32 KB

      magicJack (disk2s0s2) /Volumes/magicJack : 588 KB (0 B free)

    Apple Inc. Bluetooth USB Host Controller

    Apple Computer, Inc. IR Receiver

     

    Kernel Extensions:

      /Applications/proXPN.app

    [not loaded] foo.tap (1.0) [Support]

    [not loaded] foo.tun (1.0) [Support]

     

      /Library/Parallels/Parallels Service.app

    [loaded] com.parallels.kext.prl_hid_hook (4.0 3848.450204) [Support]

    [loaded] com.parallels.kext.prl_hypervisor (4.0 3848.450204) [Support]

    [loaded] com.parallels.kext.prl_netbridge (4.0 3848.450204) [Support]

    [loaded] com.parallels.kext.prl_usb_connect (4.0 3848.450204) [Support]

    [loaded] com.parallels.kext.prl_vnic (4.0 3848.450204) [Support]

     

      /System/Library/Extensions

    [loaded] com.kensington.mouseworks.iokit.KensingtonMouseDriver (3.0) [Support]

    [not loaded] com.kodak.printer.XXXX.kext (1.3.0) [Support]

    [loaded] com.pctools.iantivirus.kfs (1.0.1) [Support]

    [not loaded] com.phidgets.driver.Phidget (1.0.0d1) [Support]

     

      /System/Library/Extensions/KensingtonMouseDriver.kext/Contents/PlugIns

    [not loaded] com.kensington.mouseworks.driver.ADBID32Mouse (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.ADBID32MouseX1 (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.ADBID4Mouse (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.ADBID4MouseX1 (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.KMWBluetoothHIDMouse (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.KMWBluetoothOldHIDMouse (3.0) [Support]

    [loaded] com.kensington.mouseworks.driver.KMWUSBHIDMouse (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.USBMouseX1 (3.0) [Support]

    [loaded] com.kensington.mouseworks.driver.VirtualMouse (3.0) [Support]

    [not loaded] com.kensington.mouseworks.driver.VirtualMouseX1 (3.0) [Support]

    [not loaded] com.kensington.mouseworks.iokit.KensingtonMouseDriverX1 (3.0) [Support]

     

    Startup Items:

    HWNetMgr: Path: /Library/StartupItems/HWNetMgr

    HWPortDetect: Path: /Library/StartupItems/HWPortDetect

    ParallelsDesktopTransporter: Path: /Library/StartupItems/ParallelsDesktopTransporter

    Privoxy: Path: /Library/StartupItems/Privoxy

    StartOuc: Path: /Library/StartupItems/StartOuc

    Startup items are obsolete in OS X Yosemite

     

    Problem System Launch Daemons:

    [not loaded] org.samba.winbindd.plist [Support]

     

    Launch Agents:

    [loaded] com.google.keystone.agent.plist [Support]

    [loaded] com.parallels.desktop.launch.plist [Support]

    [not loaded] com.trusteer.rapport.rapportd.plist [Support]

     

    Launch Daemons:

    [loaded] com.adobe.fpsaud.plist [Support]

    [loaded] com.google.keystone.daemon.plist [Support]

    [running] com.parallels.desktop.launchdaemon.plist [Support]

    [running] com.trusteer.rooks.rooksd.plist [Support]

     

    User Login Items:

    FreeMemory Application (/Applications/FreeMemory.app)

    MouseWorks Background Application (/Library/PreferencePanes/MouseWorks.prefPane/Contents/Resources/Support/MouseW orks Background.app)

     

    Internet Plug-ins:

    JavaAppletPlugin: Version: 13.9.8 - SDK 10.6 Check version

    o1dbrowserplugin: Version: 5.38.6.0 - SDK 10.8 [Support]

    iPhotoPhotocast: Version: 7.0

    QuickTime Plugin: Version: 7.6.6

    Google Earth Web Plug-in: Version: 7.1 [Support]

    FlashPlayer-10.6: Version: 16.0.0.235 - SDK 10.6 [Support]

    Yahoo! Installer 3: Version: 1.0.128 [Support]

    Silverlight: Version: 5.1.10411.0 - SDK 10.6 [Support]

    googletalkbrowserplugin: Version: 5.38.6.0 - SDK 10.8 [Support]

    Flip4Mac WMV Plugin: Version: 2.4.0.11 [Support]

    Flash Player: Version: 16.0.0.235 - SDK 10.6 [Support]

    Gears: Version: 1.0 [Support]

     

    User internet Plug-ins:

    Move_Media_Player: Version: npmnqmp 071303000006 [Support]

    WebEx: Version: 1.0 [Support]

    BabelgumPlugin: Version: 1.0 [Support]

     

    Audio Plug-ins:

    iSightAudio: Version: 7.6.6

     

    3rd Party Preference Panes:

    Flash Player  [Support]

    Flip4Mac WMV  [Support]

    MacFUSE  [Support]

    Kensington MouseWorks  [Support]

    Rapport  [Support]

     

    Time Machine:

    Time Machine information requires OS X 10.7 "Lion" or later.

     

    Top Processes by CPU:

          2% WindowServer

          1% Finder

          0% fontd

          0% FreeMemory

          0% prl_disp_service

     

    Top Processes by Memory:

    79 MB mds

    28 MB WindowServer

    24 MB Finder

    19 MB Dock

    15 MB coreservicesd

     

    Virtual Memory Information:

    1.11 GB Free RAM

    422 MB Active RAM

    276 MB Inactive RAM

    336 MB Wired RAM

    541 MB Page-ins

    0 B Page-outs

     

    Diagnostics Information:

    Dec 15, 2014, 04:30:28 PM Self test - passed

  • lllaass Level 10 Level 10 (162,905 points)

    Just what is slow?

    Removing antivirus may help

    [loaded] com.pctools.iantivirus.kfs (1.0.1) [Support]

    The support link is dead.

    You also have a lot of third party stuff load. Do you use all of it?

    You model only supports 2 GB of RAM

  • Gonzalo.Martinez Level 1 Level 1 (0 points)

    Thanks lllaass, this program is NOT in the application folder, and "antivirus uninstall" is not available any where is it a good idea to move to trash anything name antivirus from the Macintosh HD? or that may not do the job? Or will you just recommend to buy a new SSD and install the fresh OS X?

  • lllaass Level 10 Level 10 (162,905 points)

    Best would be an SSD and reinstall a fresh OSX.

    It appear that the anitvirus app was not previously removed correctly.Some apps requires that yo use their uninstaller vice just removing it from the Applications folder and Startup iTunes. Sometimes yo have to reinstall the app and then use the uninstaller to completely remove it.