Skip navigation

OS X startup disk has no more space available for application memory

127269 Views 129 Replies Latest reply: Apr 6, 2014 5:36 AM by FruitbatFran RSS
  • chapplie Calculating status...

    Hey yeah I think you are right, it is currently using 846 MB and maybe (i can't recall) I had already shut down safari and turned off wireless when I looked at the activity monitor. It's pretty crap that an application that came in teh box, so to speak, could cause such problems. Thre was another process which was using 100% of my CPU but I can't remember what it was called.

  • Kenoki Calculating status...

    I just got this error today running iMac with 16 GB of memory and 1 TB Fusion drive (700 GB free).  I wasn't running any apps that I don't normally run, and none of them *should* have been taxing the system.  I guess there could have been a recent update to an app that is now causing a memory leak...  I have OS X v10.8.4.  I've read most of this thread, and what I'm wondering is:  Is there room for improvement in the OS to avoid what happened to me today?  The OS stopped responding to the point where I could not even Force Close applications.  I had to power down the hard way.  It would be nice if the OS could reserve enough juice for me to help it recover instead of requiring a hard reboot.  If I can look at the Activity Monitor and know there's a "culprit", then I'm wondering if the OS can do that for me... and then pre-emptively cut that process off at the knees while informing me that it needs attention.

  • Kevin Stanchfield Level 1 Level 1 (110 points)

    What you are suggesting is probably possable but it would really upset power users who (like me) prefer to keep tabs on whats going on in their system.  Plus it would be tricky for an automated system to know weather a process is in fact out of control or simply needs all the resources it can grab.

     

    A system like you sugges is probably more appropreate for something like an iPad, where the goal really IS to hide all the technical, nerdy OS stuff from the user.

  • storrao Calculating status...

    hi!

     

    happened the same to me during this week :/

     

    i've been backing up my imac (running osx 10.8.2 with 4G ram 1TB hard disk/ +730GB free) no applications open and suddenly i get this message

     

    i'm backing it up because it started giving me problems with permissions and i think i have my profile somewhat corrupt and i want to format and clean install osx...

     

    the problem is that now i can't even run carcon copy to the end

     

    did you manage to fix this?

  • Trimbil Calculating status...

    are you sure that there is no application running? Try to check your dock and see if there is a light on the software icon. I can manage my problem by unistalling the software that cause this problem. In my case, Adobe Photoshop.

  • Kenoki Level 1 Level 1 (0 points)

    Hi, storrao.

    I'm not sure I did anything to fix it, and I wouldn't be surprised if it popped up again.

    I did the usual... turn it off, turn it on, run disk check, run permission check.

    It hasn't reoccured yet, and I'm running the same apps I always run.  I don't tax the system heavily and I shut down my apps when I'm not using them.

    I am keeping a Finder window open to the virtual memory folder now, but so far, it has not budged.  There's one file there that is 67MB is size.

    I guess if I started to see a huge increase in the number and size of files there, then I will examine which apps are using up the resources and maybe find the one that's leaking.  Although, I'm not entirely convinced that any of them are leaking since I've seen weird things with Mac OS X over the years and wouldn't disqualify this being a bug.

    I agree with what Kevin said (above), but IMHO, there is no excuse for an OS to allow itself to get to the point where the user is completely locked out and has to power off the system.  (This has happened to me on Linux servers and has happened frequently on windoze which I rarely us any more, so I'm not picking on Mac OS X, I'm picking on all OS's that have this issue -- and my old roommate would say "Then, write your own OS!")

  • MrsCuriousity Calculating status...

    Try deleting all your cookies in your internet browser.  It made my message stop popping up.

  • jpostelnek Calculating status...

    Can you offer any suggestion for a similar issue on an early 2009 MBP running Lion?  (I know this is a Snow Leopard discussion, but it is the best thread on this topic that i have found so far).  I have followed all of your suggestions about using activity monitor to find the culprit, and here is what I found:  with no programs open, loginwindow and SystemUIServer are devouring Real Mem.  After my laptop being on for 20 minutes, they have used 1.88 and 1.85 GB respectively and counting.  No other acvtivities are using an increasing amount of real mem.  Further, when I open a program, (in this case I opened VLC and Onyx) they too begin to devour Real Mem at an alarming rate.  Further, the increase in real mem usage by loginwindow and SystemUIServer speeds up with the applications open.  Keep in mind that Onyx and VLC are open but not actually being used at the time. 

  • mabo89 Calculating status...

    Same thing here, I'm on a MBPro 2010 8gb Ram

     

    I think it's weird that everyone has having this issue right now, the first thing that comes to mind is some kind of virus

     

    By the way, I restored from a previous backup and uninstalled Chrome. I'm using Safari right now. The problem disappeared (so far at least).

    Is it a Chrome problem? Maybe a faulty update? I think the problem is browser-related

  • FruitbatFran Calculating status...

    I've got a 12GB memory and 1TB HD plus 1TB external HD. I've been using Chrome after that security problem with Safari. Just restarted my iMac and going to use Safari again now that they've done a fix update and see how that goes. Only bought my iMac last year do shouldn't expect to have problems this soon.

1 ... 5 6 7 8 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.