Previous 1 2 3 4 5 Next 130 Replies Latest reply: Nov 14, 2014 2:02 PM by Datkins2888 Go to original post
  • Kevin Stanchfield Level 1 Level 1 (110 points)

    My Dad recently started getting this same exact error on his trusty little mac mini (10.6.7, 2gigs of RAM).  It's essentially an "out of RAM" error (including swap).  Rebooting the machine always fixed it for a couple of days.

     

    The last time it happened however I loaded up Activity Monitor and quickly noticed that there was a process called "HP Device Monitor" taking 130% of his CPU and almost 800mb of RAM.  "HP Device Monitor" was something installed recently when he got a new HP printer...

     

    Moral of the story is that the OP probably has some process running in the backgroud that has a serious memory leak - it's not a hardware issue.

  • jenniferfromprosper Level 1 Level 1 (0 points)

    We recently had the same problem and had plenty of space on the hard drive 500 gig out of 1 TB.  Pull up the console in utilities and see if you see anything strange in there.  For our particular problem Google Chrome had a memory leak.  The activity monitor in utilities also showed HP device monitor was using 357% of the CPU and 4 gig of memory.  After killing the HP device monitor and Google chrome the out of space on the startup disk message went away.  I also recreated the problem by starting Chrome again and the console clearly showed there was a memory leak.  So, if you have plenty of disk space check these two utilities to get an idea on what application is causing the problem.  Good luck!

  • glenfromcorona Level 1 Level 1 (0 points)

    my wife's imac had the same thing happen only after i bought a new HP printer and downloaded the new software.  i see many of these posts have HP high activity inthe monitor.

     

    I think it is their issue.

  • karenRaa Level 1 Level 1 (0 points)

    Also have this issue. In my case PID4729 Process Name:Safari Web Content was using 6.81GB of memory, leaving 39MB Free. Even though 3.51GB was showing as inactive I still got the message.

  • WZZZ Level 6 Level 6 (12,640 points)

    Inactive memory isn't really free, it's in a kind of limbo. If that's real memory, 6.81 for Safari suggests a severe memory leak there. 39MB free just isn't enough.

     

    Activity Monitor> Memory what are the page outs?

     

    Also open Terminal and type in "top" (no quotation marks) then hit return. What are the figures inside the parenthesis?

     

     

    http://www.thexlab.com/faqs/lackofram.html

     

    see

     

    Determine how much paging your system is performing

  • Andy Ruina Level 1 Level 1 (0 points)

    SOLVED!!! (for me, anyway)

    I have Mac powerbook pro (Dec 2011), ) OS10.7.2 (LION)

    Error message started with

     

    Your Mac OS X startup disk has no more space

    available for appliaion memory.

     

    But after that every thing was frozen.

     

    I narrowed the problem down to a program I use called iglasses.  I solved it by installing

    the version 3.1 Beta.  Now, no more crashes with the above error message.  I asked Ken

    at ecamm.com (the nice makers of iglasses) what the problem was, that he fixed with his beta version 3.1

    and he wrote this:

     

    "I was able to work around a bug in Apple's Unsharp Mask Core Image filter when it's used with the Intel HD3000 graphics card. It was leaking memory with each frame, causing virtual memory to grow out of control. Virtual memory is disk-backed memory, and that caused the hard disk to eventually fill up. Once the vm page file fills up the hard disk, no more memory (or disk space) is available for the kernel or applications, and everything just falls over. It's very unusual for it to happen that way and I've never seen it happen before, but that's what it was! The solution was to restrict the range of input parameters to that filter to avoid the bug which only happened with certain parameters."

     

    So, even if you are not using iglasses, perhaps the problem is still from the HD3000 graphics card?

    Anyway, my problem was basically solved by process of elimination.  What things were running when crashes occured and what things were not when they did not.

  • DeanfromSC Level 1 Level 1 (0 points)

    Had the same issue today (MacBook Pro Oct 2011, OSX Lion 10.7.2). As far as I can figure, it was somehow caused by internet difficulties at my workplace. I had only one application running, and I was still getting the error message every few minutes. Didn't check Disk Utilities then since everything kept freezing up, but the memory couldn't possibly have been full with only 1 application open. I restarted 3 times, but it didn't help at all. I did still have the internet cord attached, since I was hoping for restored service. I'm wondering if there was somehow a leak through that connection…

     

    Anyway, when internet was finally restored, I restarted again and have experienced absolutely no more problems. I didn't change anything. Checked Disk Utilites when all was over, and have very low %CPU (all under 10), page ins 378.6MB, page outs 0 bytes, swap used 0 bytes. It seems the problem is over without my doing anything at all. It must be due to an outside cause (in my case, internet woes).

  • Alphington Flash Level 1 Level 1 (0 points)

    A search through the posts reveals a number of similar  issues.  It is unfortunat there is no way to aggregate issues when becoming aware of this.  My almost identical issue arose during the  attempt to sync  my address book with my new icloud contacts list.  The  attempt  basically froze my maz for four hours , consummed around 70gig of hdd and burnt up 9 gig of my broadband bandwidtrh - all without managing to do the one thing I wanted which was the sync. Obviously there is something going on inside Lion!

  • harrimf Level 1 Level 1 (0 points)

    Just started having the same issue, 24" iMac (early 2009) / 2.66GHz Core 2 Duo / 8GB DDR3 / 630GB HDD with 281GB free space / Lion 10.7.3.

     

    Ive had this twice in as many days, with only a few apps running on the second occasion (finder/chrome/mail/app store).

    I suspect a memory leak, with Chrome being my number 1 suspect at the moment.

    Am monitoring and will update if I find the culprit.

  • Alphington Flash Level 1 Level 1 (0 points)

    What ever it is it is temp or swapfiles being created.  I turned off wifi last night and then attempted to run the find duplicates in my address book.  It ran very slowly , possibly because somewhere in the translation from 10.4.8 to 10.6 to 10.7  I have magically gone from a couple of hundred contacts to 24,000.  (That's a separate issue.)

    I had no other applications running.  When I came back to the imac today I had the full disk message and the request to close an application.

    Closed the only application open - address book. Restarted the imac and got back 90gig.  The find duplicates program had got less than 1/6 of the way through on its status bar.

     

    Apple. I'd say it's a bug

  • ylluminate Level 1 Level 1 (0 points)

    I am very nearly positive this is an Apple bug.  I have started to see this really start to occur in 10.7.3.  I too have over 30GB free on my primary volume (my ssd system disk as I'm running ZFS for my home and other volumes).  Further, I have 20GB of RAM.

     

    It just started happening after about the middle or end of the beta phase of the 10.7.3 update for me so I'm hopeful that it's something we can get enough bug reports for to get addressed soon.  Memory management for Mac OS X has been in decline, particularly with regards to the kernel.  I mourn because of the lack of attention we're getting at the core os level.  Everything is focusing on the frameworks and UI/UX, which I understand due to the success of iOS platforms... however we're all suffering while not enough attention is being given to the kernel. 

     

    We should really all speak up and submit feedback.

  • Kevin Stanchfield Level 1 Level 1 (110 points)

    Everyone, this is not an Apple bug.  You are merely getting an "out of memmory" message.  If you open the Activity Monitor when you're getting this error you will quickly discover which process is causing the problem.

  • ylluminate Level 1 Level 1 (0 points)

    Kevin this does not appear to be the case for me.  I have this without errant processes consuming inordinant amounts of RAM.

  • Alphington Flash Level 1 Level 1 (0 points)

    Kevin.  If it is not a bug I would be interested to know why I can no longer access Address ook without it  basically hogging my ram , CPU and eventually every spare bit of memory on my HDD.

    This was never the case until I installed LION.

    You will notice that address book is consuming 100.1% of my CPU

    If I turn force quit address book the next  process demanding CPU  is just more than 3%

     

     

  • Kevin Stanchfield Level 1 Level 1 (110 points)

    You are the first person here to mention Address book.  It sounds to me like you might have a problem with your Address Book database.  I use Address Book daily on Lion without issue, but I only have a few hundred contacts.

     

    The only point I would like to make everyone clear of is that this specific error (mentioned in the original post) is a very general error that simply means your machine is out of RAM.  To find out why, you need to open Activity Monitor and have a look at running processes.

Previous 1 2 3 4 5 Next