3 Replies Latest reply: Jan 19, 2011 7:26 AM by Kinsey1
dyee Level 1 Level 1 (5 points)
My keynote (and all my iWork apps) are inexplicably crashing on start up. I've reinstalled iWork 09 from the DVD, after deleting all support files (plist...; application support files; dock icons). But I'm running into the same problem even after the reinstall. Anyone have any insights? Below is the first 20 lines or so from the 'Problem Report' (if you want the entire report, I can post that in a follow-up message):


Process: Keynote [2807]
Path: /Applications/iWork '09/Keynote.app/Contents/MacOS/Keynote
Identifier: com.apple.iWork.Keynote
Version: 5.0.5 (942)
Build Info: Keynote-9420000~2
Code Type: X86 (Native)
Parent Process: launchd [175]

Date/Time: 2011-01-18 15:49:52.360 -0800
OS Version: Mac OS X 10.6.6 (10J567)
Report Version: 6

Interval Since Last Report: 190277 sec
Crashes Since Last Report: 31
Per-App Interval Since Last Report: 22512 sec
Per-App Crashes Since Last Report: 11
Anonymous UUID: 72D038B1-9976-4A9A-80E0-F28E111123AA

Exception Codes: KERNINVALIDADDRESS at 0x00000000158e861f
Crashed Thread: 9

MBP 17" 2.4 Ghz, Mac OS X (10.6.6)
  • dyee Level 1 Level 1 (5 points)
    Okay, I discovered in another thread that there's some incompatibility between iWork 09 and a font that was in my username > library > fonts folder. I may have inadvertantly dropped in Courier.dfont into that folder, causing all sorts of havoc.

    The advice I read in the other thread was to simply compress the username > library > fonts folder, so it becomes 'fonts.zip'. And then trash the original fonts folder. Then you can see if the iWork apps open. If so, then you know there was some font incompatibility. You can then load in each font a few at a time to try to pinpoint which font is causing the problem.
  • dyee Level 1 Level 1 (5 points)
    Actually, it turns out it wasn't Courier.dfont, but rather another font that was activated through my font management program, Suitcase. Same principal applies though: turn off all the fonts, and turn each one on to see which is causing the problem. The crash happens immediately (at least in my case).
  • Kinsey1 Level 1 Level 1 (0 points)
    Hi Dyee,
    Can you please supply more information about how you solved this problem?
    I downloaded Keynote from the MacApp Store the day it opened. Until last Friday, it worked fine.

    However, it now works intermittently, and generally hangs after about a minute's work, if it opens at all.

    I created a zip folder of my fonts as you suggested, but the system would not let me trash my normal fonts folder. I have also disabled almost all of the fonts in fontbook, apart from the ones that the system would not let me disable (22) in all.

    I have also uninstalled and reinstalled from the Mac App Store, but am still experiencing problems with Keynote.

    Any help would be appreciated, thanks.