1 Reply Latest reply: Mar 7, 2011 2:01 PM by TiGPS
Hotwheels22 Level 1 (5 points)
I keep getting a verify certificate prompt on my desktop machine and I have to click "connect" for most (all?) of my email accounts. I don't get this on my laptop machine.

Would anyone mind letting me know if there is a good way to prevent this?


Mac OS X (10.6.3), Mac Pro, MacBook Pro
  • TiGPS Level 1 (0 points)
    I am looking for a similar thing too, but to answer your question, that prompt comes up because the certificate your mail server is using is not dedicated to your domain name (shared hosting woes). You can buy an SSL certificate and apply it to that domain (quite costly), or disable SSL access to your mail server. That means your emails can then be easily read by anyone who sniffs on your internet connection.

    But yes, a short term solution would be to go to the account settings pertaining to that email and untick "Use SSL" in Advanced Tab for both incoming and outgoing servers.

    EDIT: here's a serious workaround while still keeping your SSL encrypted email access:

    When the prompt pops up, click on Show Certificate, then browse through until you see these options:

    Select Always Trust and you're set. No more questions.

    Message was edited by: TiGPS (added the real solution)