5 Replies Latest reply: Jan 20, 2011 4:02 PM by rkaufmann87
KYL Level 1 Level 1 (20 points)
Hello

I've had this issue for a while. It happens when I'm using Safari and have more than one window open, I may have some other apps open as well. The expose animation will start to happen but it will freeze half way for 3-5 seconds before running as normal. Sometimes it freezes for 5-8 seconds.

I tried a clean install of my iMac and it stopped doing it but after a week or so it started again.

I am running a 21inch Aluminium iMac 2.4ghz Core 2 Duo with 4GB 667 DDR2 RAM. It is the first aluminium model of iMac.

Is there an issue with my iMac or is it just a case of my Mac being old and am I in need of an upgrade. I am planning on buying a new iMac once the line refreshes later this year.

iMac Core 2 Duo, Mac OS X (10.6.6)
  • rkaufmann87 Level 9 Level 9 (50,630 points)
    It's a little difficult to say for sure what it is right now. However there are a number of troubleshooting steps you can take. The first thing I would recommend doing is creating another account and calling it Test Account. Leave this account pristine, don't change any setting or add any software. Then log into this account and see if they problem still occur. If they stop then it's a software issue in your user account, if the problem still occurs then it's either a system wide hardware or software issue and is pointing to hardware, possibly just a failing hard disk. After creating the new account and testing please post back with your results.

    Roger
  • KYL Level 1 Level 1 (20 points)
    Thanks for the quick response. As I said in my post I have tried a complete erase and install of my Mac and the system runs fine. The problem resurfaces after a week or two of usage when I'm downloading stuff and adding new applications. If I left it from a fresh install without adding any new software the problem isnt there.
  • rkaufmann87 Level 9 Level 9 (50,630 points)
    Well reinstalling OS X was probably totally unnecessary. OS X is not like other OS's and is extremely stable. Reinstalling it didn't help (or hurt for that matter) it was simply a waste of your time.

    Please try my earlier suggestion of creating a test account and then post back with your results.
  • KYL Level 1 Level 1 (20 points)
    I just tested a new account and I had no issues with freezing and I had 6 Safari windows and iTunes open and it was fine.

    It doesnt occur every single time I open expose, its just random.
  • rkaufmann87 Level 9 Level 9 (50,630 points)
    OK that's a good sign. Try using the Test Account for a day or two to see if the problem happens again. If it does not then you have narrowed the problem down to a software problem in your normal user account. Then it's simply a matter of tracking it down.