9 Replies Latest reply: Jan 23, 2011 7:51 AM by Pondini
SKYTORT Level 1 Level 1 (0 points)
Dear All,

Did a search, and can't find similar problem (s):

I just re-installed Snow Leopard. I ran time machine backing up EVERYTHING on a 2 TB WDigital Hard Drive.

I am now trying to selectively restore content. Amongst others, my address book is not to be found in the TM backup file. How the **** is this possible as I have not excluded anything int the backup, so in theory EVERYTHING should have been backed up.

The only backup I have is on my iPhone and I am scared that if I sync my iPhone it will erase my contact because it will now be syncing with an address book that has two contacts - Myself, and Apple America...

HELP!

Thanks!

Macbook Pro, Mac OS X (10.5.8)
  • Matthew Morgan Level 7 Level 7 (22,595 points)
    If you launch the Address Book application and then enter Time Machine do you not see your Address Book?

    Matt
  • SKYTORT Level 1 Level 1 (0 points)
    Matt,

    Thanks for the response. I see one window address book which is the current one "through which I enter time machine". I can not flip through the time line since there is nothing.

    I even opened mail because I wanna restore mail and all my smart email boxes, and there is NOTHING.

    How can this be as my TM backup file is about 30 GB...?
  • Matthew Morgan Level 7 Level 7 (22,595 points)
    OK. How about this:

    Open this folder:

    user>Library>Application Support>Address Book

    Now go into Time Machine.

    What do you see?

    Matt
  • SKYTORT Level 1 Level 1 (0 points)
    Matt,

    I have tried that too. The funny thing is, when I enter time machine, no matter what window I do it through, I cannot navigate the time line, although it does give an approximate start time which correctly reflects when I started using time machine.

    I find the above behavior extremely bazaar since Time Machine worked fine until the system restore. For example, I was able to enter time machine through finder, and simply use the arrow buttons in the lower right hand corner to navigate forwards and backwards in time. I even retrieved a file two days ago which I had deleted from my documents folder about a month ago, but now I simply cannot go back in time.

    Perhaps it has to do with the fact that, my Mac hard drives was named Macintosh HD(4). When I did a restore, I deleted the hardrive in order to install a fresh copy of Snow L. I entered the instller and erased the Macintosh HD, and renamed it Mac HD. So perhaps it could have something to do with be renaming of the hard drive, but then again NONE of the **** folders allow me to navigate back in time. The backups are there because I can enter the backup folders from the normal Finder window.

    Anyways, I have given you a mouthful outnof desperation. Thanks for the help so far. Much appreciated!!
  • Matthew Morgan Level 7 Level 7 (22,595 points)
    One other question.

    In the Finder, if you look in whatever drive you're using for Time Machine, do you see more than one Backups folder?

    Matt
  • Pondini Level 8 Level 8 (38,715 points)
    What version of OSX are you running?

    You've posted in the Snow Leopard forum, but your signature says 10.5.8.

    If you're on 10.6.0 through 10.6.3, see #E5 in [Time Machine - Troubleshooting|http://web.me.com/pondini/Time_Machine/Troubleshooting.html] (or use the link in *User Tips* at the top of this forum).

    If not, try the things in #E4 there.

    Also . . . when you reinstalled OSX, did you set up a user account, and are now trying to restore from your backups? If so, that may be at least part of the problem. The new user account you set up is probably not recognized as the one on your backups, so doesn't have access to the "other" user's backups.

    Why did you reinstall?
  • SKYTORT Level 1 Level 1 (0 points)
    I will try and explain my setup to give you a good idea of what my problem is. 

    I run the latest version of snow leopard. I had a user account with a password. The name of my hard drive of my MacBook pro was named Macintosh HD (4). The name of the hard drive on which I made my backups using time machine is called Mybook. 

    So here is what happened. I run an Internet filter which was causing problems. Due to the nature of the product, it can only be removed with a password which I some how lost ( I installed the program about 2 years ago). I figured the only way to get rid of it is a clean start with Mac OS. So I ran the installation disk, used the disc utility to completely format the Mac Hard drive and install a clean copy of snow leopard. So when the computer finally restarted it ran through the setup as it did the day I took it out o the box when I bought it. 

    I renamed my home folder, and the name of the MacBook hard drive had been changed to Mac HD. So yes, essentially the user account is not 100% the same as before. 

    Now, when I click  Finder > MyBook and access the backup folder, it appears as if though most folders are there. However, when I open address book and then run time machine, I can not navigate up the time line. it simply gives one window and black subfolders behind it. It does the same for any other folder that I open through finder an the open time machine. Could this be that time machine sees me as a different user and therefore does not allow me access to the backup files. 

    Just another thing. When I click Finder > Mybook>backup>System>Library>Application Support....there is no folder named address book. However, when I access Application support on my MacBook pro HD, the folder is there. 

    Finally, when I set up time machine to make backups I set it up to exclude NOTHING. 

    I hope this clarifies the issue somewhat for you guys to be able to work with something. 

    Thanks a lot. 
    ST
  • SKYTORT Level 1 Level 1 (0 points)
    In case anybody cares to explain the logic, I solved the problem, but admit that I officially don't understand the logic of Time Machine.

    So, first of all, it seems I cannot browse the time line of backups from a previous user account.
    Secondly, I was able to restore my address book by clicking Finder>MyBook>Backups.backupdb>Users...then selecting my old user account name I was able to access all the stuff I had backed up.

    Anyways, I solved the problem and I hope it becomes useful to someone in the future.

    Thanks for attempting!
    Cheers
  • Pondini Level 8 Level 8 (38,715 points)
    SKYTORT wrote:
    . . .
    So, first of all, it seems I cannot browse the time line of backups from a previous user account.


    Yes, exactly. What you see in Time Machine reflects how you got there; if you start from, say, a Finder window looking at one user account, you'll see only that account, and only backups where that account was backed-up. If you start from a FInder window of your internal HD (or click it in the sidebar), then you'll see your entire HD.

    But Time Machine preserves the permissions on your system. On your system, one user, even an Admin user, doesn't normally have access to a different user's data.

    The same is true on your backups -- one user doesn't have access to another user's backups. Anything else would be a rather large security breach.