Previous 1 2 Next 28 Replies Latest reply: Mar 7, 2014 2:01 PM by Karl2014 Go to original post
  • Roberto818 Level 1 Level 1 (0 points)
    I reinstall the os and updated up to 10.6.5 and safari is working fine.
    I try reinstalling & updating to 10.6.6 and thats when I get the problem.
    This SHUCKS....
    We need some type of fix asap.
    This is really buggy

    PS: THE ISSUE GOES ALONG WITH THE OTHER WEB BROWSERS TOO. (FIREFOX & CHROME)
  • Volvox_FR Level 1 Level 1 (0 points)
    Dear all,
    I experienced the same problem with my iMAC after upgrading to 10.6.6. The problem remains with another user on the MAC and this is not a space problem on the HD (I have 800 Gb free).

    I would like to reinstall the OS10.6.5 but I have a Boot Camp Windows 7 partition of the HD.

    Will the reinstallation of the OS preserve the Boot Camp settings?

    Thanks for your answers!
  • Volvox_FR Level 1 Level 1 (0 points)
    Hi,
    Thanks realmtl!
    It works also with my iMAC!
    Same as you I did not have any extension, but turning it off, it improves dramatically the performance.
    You will have to do this for all user settings though, otherwise, it will remains slow for the other users.
    They will have to fix this issue for the next upgrade...
    No need to reinstall the OS...
    Thanks!

    Message was edited by: Volvox_FR
  • RedGeminiPA Level 1 Level 1 (50 points)
    I was having an issue of severe lag between pages. I found a fix that worked for me. It's not exactly simple, but it squashed the bug somewhere along the line.

    I've also noticed it seems Safari isn't using Memory as bad as it did.

    First, +*MAKE SURE YOU HAVE A DIFFERENT BROWSER INSTALLED, or download Safari from Apple's website and keep it in your download folder!*+

    (Note: You may lose bookmarks. I missed a step shown below, and had to manually save them all again.)

    Move Safari from Applications to the Trash (AppTrap won't remove the following folders/files for you)

    Open Finder>Library>Caches

    Search for Safari; make sure to select "Search: Caches" You should have 2 folders (com.apple.safari, Safari)

    Open the folder labeled Safari

    Drag the Bookmarks folder to the desktop (this should preserve them, at least)

    Go back to the search results for Safari (the 2 previously mentioned folders)

    Drag them both to the trash

    Go back to Library and locate the Safari folder

    Drag the TopSites.plist and Bookmarks.plist files to your desktop

    Go back and drag the Safari file from Library to the Trash

    This should now have ALL Safari files moved into the Trash (except for the folders/files listed above)

    Empty Trash (if it won't because it says files are in use, click on Finder in the menu bar then select Secure Empty Trash. It may take a while to delete all files.)

    For safe measure, reboot your Mac

    Use the Safari installer (in Downloads) to install Safari again. You should now have a completely clean install.

    Open Finder>Library>Safari

    Drag the 2 .plist files back in

    Go back to Library>Caches>Safari

    Drag the Bookmarks folder back in

    This should restore Safari with your Bookmarks and Top Sites.

    If your Bookmarks don't show up (as my mistake for not saving the Bookmarks.plist file), you can open the Bookmarks folder that was on your desktop and Select All>Open>With Safari then add them all back, one dreaded page at a time. LOL (not real sure how I missed the Bookmarks.plist file, but I did)

    Hopefully this gets Safari running fast again for all of you. It's been super speedy and purring like a kitten since I did this.

    Enjoy!
  • ~Bee Level 7 Level 7 (31,125 points)
    Red --

    It's really great that you want to share your solution.
    However, I need to warn other readers that this is tremendous overkill for most Safari glitches and slowdowns. Very often, it's simply people forgetting to empty the Safari cache. Or perhaps they have fonts duplicates. Or they've installed an incompatible 3rd party internet app/extension on there.

    In addition, even as careful as you were, there are other Safari files on your Mac that could have easily prevented a reinstall. I'm glad for you that your ideas worked for you, but it's an extreme solution to say the least. And the possibility of a real mess-up are excellent that would require a series of really
    daunting steps.

    But we've seen so many people not be able to reinstall Safari without a lot of work.
    I don't mean to dampen your enthusiasm to help others here.
    That's part is just great.
  • mcconnchie Level 1 Level 1 (0 points)
    I have experienced exactly the same issue on my work MacBook Pro (my home MacBook Pro is unaffected). The problem arose the moment I 'upgraded' to 10.6.6. No only is Safari unresponsive to the point of being unusable, but it allows affects all other processes / apps running at the same time. I tried numerous things to fix but in the end the only solution was to switch to Chrome.
  • Roberto818 Level 1 Level 1 (0 points)
    I got a solution for the people that get all their browser very slow (safari, firefox, chrome, etc).
    Like I mention before on this post, the problem is with flash.plugin.
    What you need to do is downgrade (version 10.0.45.2 )or upgrade (version 10.3.162.28 know as adobe flash square) the flash.plugin and everything it will work like a charm, for some reason the current update of flash.pluin (10.2.xx.x) is not working well with 10.6.5 & 10.6.6 (I haven't try it on 10.6.4).
    I hope this will solve your problem, because it solved mine.
  • chrisfromhopewell Level 4 Level 4 (1,085 points)

    Has anyone tried reinstalling safari?

  • Ashtree Level 1 Level 1 (0 points)

    I had the same problem with Safari being slow... A lot of lollipopping, and frustration. Did some research, and implemented just two suggestions I found.

     

    One: Clear out all the junk in "other forms" in the autofill preferences.

     

    Two: Delete the favicon database file "WebpageIcons.db" in users/yourloginname/library/Safari. It seems that the favicon database doesn't automatically delete old icons from itself, so it ends up bloated. Mine was 74.2 MB in size.

     

    Since I've done these two things Safari has worked wonderfully.

  • Michelasso Level 1 Level 1 (80 points)

    I apparently made it a little faster deleting the history. Checking in Finder it was 132MB and it was more than 1 year old. With 11 tabs the starting memory usage is still 432MB (and growing). Usually it went up to 1.1 GB. Having a MacBook with 3GB of RAM it seemed a little too much to me. I also installed the 64 bit version of Flash. But when watching videos WebkitPluginHost is still running. How comes?

  • lustring Level 1 Level 1 (0 points)

    me too, my safari is so slow, eventually I have to stop using it, right now, I am using firefox, it's much faster than my safari anyway, I think i will never go back to safari, it's a shame for apple, I am using mac mini, and can't use safari duo it's speed issue. hope apple techy can id the problem, but anyway, firefox already fixed it , it seems no way i will return to safari.

  • Karl2014 Level 1 Level 1 (0 points)

    It appears that the issue is fixed with OSX 10.9.2.

  • christhewiz Level 1 Level 1 (0 points)

    After updating to 10.9.2 Safari is extremely slow. Especially when using Google Picture Search. Chrome gives me the serach results in an insant, while Safari takes minutes...

  • Karl2014 Level 1 Level 1 (0 points)

    It appears that I jumped the gun.  Initially it appeared that the problem was solved with OSX 10.9.2 after installation.  Now things have once again slowed right down.

Previous 1 2 Next